Apache Testing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Testing

Postby Marta » 19. December 2006 17:10

I am trying to test my appache on my machine. Could you help me please?
I created a test.html file in htdocs and I have tried to browse for it at http://localhost/test.html and I got the message object not found.
I have checked the status on XAMPP Control Panel Application and
I got the info :
Apache State 0 Service 1 Start O Thread 0 Op 0
Mysql State 1 Service 1 Start O Thread 0 Op 0
ftp State 0 Service 0 Start O Thread 0 Op 0
mercury State 0 Service 0 Start O Thread 0 Op 0
busy…
appache server started

State and Start 0 is it ok?
Thanks
Marta
Marta
 
Posts: 5
Joined: 19. December 2006 16:40

Postby sthosting » 19. December 2006 18:20

Make sure your port is set to 80 and your ip address is set to.
check to see if your ISP isnt blocking port 80.
However if you are checking it thru localhost it sounds like the port setings are not corect. or your htdocs is not in the proper dir.

Apache state 1 service 1 start 0 thread 0 op 0

this is my xampp ..
Image
sthosting
 
Posts: 19
Joined: 26. January 2006 06:10

re appache

Postby Marta » 19. December 2006 18:43

I have also tried the other path - ttp://localhost/xampplite/htdocs/test.html - it does not work either.
Could you please explain to me how can I set up Ip address port and ISP?
thanks
marta
Marta
 
Posts: 5
Joined: 19. December 2006 16:40

Postby Izzy » 19. December 2006 22:12

Your Apache has not started and as such will not serve the file you are asking for, test.html.

Try and start apache with the bat file and paste back here any error messages you get:
\apache-start.bat
leave the console window open if it starts and try your http://localhost/test.html again as this is the correct address if your test.html file is in the \htdocs\ directory.

If your apache won't start then copy and paste the error message here.
You copy and paste by clicking on the little icon C: in the top left of the console window and selecting 'Edit' and use the menu items you find in that presented menu.

BTW did you make any changes to any of your configuration files?

There is a help section in the XAMPP Control Panel, although a bit thin, it is worth reading to set up your CP to start the services or the XAMPP components correctly.

Also what OS and XAMPP version are you using?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

MySQL database deactivated

Postby Marta » 23. December 2006 10:56

Hello

The Apache is running now.

I have problem with the MySQL. I have checked the stataus and MySQl database is deactivated. And I also got the message saying phpMyAdmin tried to connect to the MySQL server and the server rejected the connection. You should check the host, the username and password in the config.inc.php and make sure they correspond to the info given by the administrator of mysql server.
ERROR 1045 -Access denied for user 'pma' @'localhost '(using password:no)

Could you please help me how to check it? Where is the file-config.inc.php?

By the way I am using the Microsoft Windows XP Home edition and XAMPP for Windows version 1.5.5.

Thanks
Marta
 
Posts: 5
Joined: 19. December 2006 16:40

Postby deepsurfer » 23. December 2006 13:07

Could you please help me how to check it? Where is the file-config.inc.php?


The file called " config.inc.php " and is in the folder
\xampp\phpMyAdmin
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Marta » 23. December 2006 19:35

Hello
I got the error message:

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

Error
MySQL said:

#1045 - Access denied for user 'pma'@'localhost' (using password: NO)

I also had a look at the error file and I got the messages.

[Sat Dec 23 17:57:58 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 configured -- resuming normal operations
[Sat Dec 23 17:57:58 2006] [notice] Server built: Sep 30 2006 21:24:06
[Sat Dec 23 17:57:58 2006] [notice] Parent: Created child process 2776
[Sat Dec 23 17:58:03 2006] [notice] Child 2776: Child process is running
[Sat Dec 23 17:58:03 2006] [notice] Child 2776: Acquired the start mutex.
[Sat Dec 23 17:58:03 2006] [notice] Child 2776: Starting 250 worker threads.
[Sat Dec 23 17:58:03 2006] [notice] Child 2776: Starting thread to listen on port 443.
[Sat Dec 23 17:58:03 2006] [notice] Child 2776: Starting thread to listen on port 80.

Could you please help me to sort it out?How can I check or change the configuration settings?

Thanks
Marta
 
Posts: 5
Joined: 19. December 2006 16:40

Postby Izzy » 24. December 2006 01:48

Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests