public_html folder not visible

Problems with the Windows version of XAMPP, questions, comments, and anything related.

public_html folder not visible

Postby nutkenz » 14. December 2006 12:10

Check out http://nutkenz.net/browse/tmp/xampp.png

I already tried renaming the folder to webroot and TEST, but neither would show in the browser after a hard refresh... How is this possible?
nutkenz
 
Posts: 12
Joined: 14. December 2006 11:45

Re: public_html folder not visible

Postby Izzy » 14. December 2006 12:30

nutkenz wrote:Check out http://nutkenz.net/browse/tmp/xampp.png

I already tried renaming the folder to webroot and TEST, but neither would show in the browser after a hard refresh... How is this possible?

You need to put an index file in the directory like index.html or index.php etc.
Edited
Last edited by Izzy on 14. December 2006 12:57, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby nutkenz » 14. December 2006 12:37

No, I want the default index because on the production server the actual webroot will be the /public_html folder. The problem is that I cannot see or access it on localhost.

When I try going to http://localhost/Zoek.net/public_html/ manually (the folder I do not see listed), I get a 500 Error:

Error 500
localhost
12/14/06 12:36:02
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0

Could this be related to the CakePHP .htaccess file?

Here's the contents of it:

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?url=$1 [QSA,L]
nutkenz
 
Posts: 12
Joined: 14. December 2006 11:45

Postby nutkenz » 14. December 2006 12:42

Apparently it is because changing the .htaccess to:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php?url=$1 [QSA,L]
</IfModule>

Resulted in the page being loaded, with errors of course because mod_rewrite isn't enabled by default apparently. I'll find out how to enable it and post it here, in case anyone else is having the same issue and stumbles upon this post. :-)
nutkenz
 
Posts: 12
Joined: 14. December 2006 11:45

Postby nutkenz » 14. December 2006 12:43

Uncommented LoadModule rewrite_module modules/mod_rewrite.so and restarted Apache. I think that did the trick.
nutkenz
 
Posts: 12
Joined: 14. December 2006 11:45

Postby Izzy » 14. December 2006 12:50

I see now what you are talking about but it was not clear in your first post.

When you get a server error read the xampp\apache\logs\error.log
The log file will have more clues than a message sent back to the browser.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

re mysql error

Postby Marta » 23. December 2006 12:54

Hello
I looked at the error file but is not clear enough and here are the messages.

[Sat Dec 23 11:50:18 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 configured -- resuming normal operations
[Sat Dec 23 11:50:18 2006] [notice] Server built: Sep 30 2006 21:24:06
[Sat Dec 23 11:50:18 2006] [notice] Parent: Created child process 3068
[Sat Dec 23 11:50:23 2006] [notice] Child 3068: Child process is running
[Sat Dec 23 11:50:23 2006] [notice] Child 3068: Acquired the start mutex.
[Sat Dec 23 11:50:23 2006] [notice] Child 3068: Starting 250 worker threads.
[Sat Dec 23 11:50:23 2006] [notice] Child 3068: Starting thread to listen on port 443.
[Sat Dec 23 11:50:23 2006] [notice] Child 3068: Starting thread to listen on port 80.
Could you please give me any suggestions?
Marta
 
Posts: 5
Joined: 19. December 2006 16:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests