RSS and authCGI issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

RSS and authCGI issues

Postby boored » 05. December 2006 03:17

I have installed xampp 1.5.5 on win xp. Everything is running just fine, Apache, Mercury, Filezilla, Mysql....

I installed Raven's RavenNuke76 v2.02.00 Distro as webpackage, and it works nicely...however i have some small issues which makes me think if i have missed something in apache/php setup, or missed to load some needed modules.

- Seems that backend.php cant generate pages. i validated my backend.php and it was ok. I see my headlines in RSS-readers, but clicking on them just brings me to 404 error(object not found). For example http://myurl/article-1--0-0.html. (as i understand this should work out-of-box, so i am maybe missing something on xampp)

- My encryption for Nuke Sentinel admin authCGI: (to use the login i have to copy the encrypted password(that Nuke Sentinel created) and use it, or just use plain text password manually). In other words, the crypted password is created, but if someone tries to login they have to use the exact password from .staccess file.

When logging into xampp control panel, xampps encrypted password works fine.

error.log just says the obvious, page missing, none authorized user...etc

been searching mostly on nukephp sites before, seems no one has exactly those problems, so im thinking that i missed something in xampp. Maybe a path, module, setting....cant be that big error since everything works just nice otherwise......
boored
 
Posts: 2
Joined: 05. December 2006 02:35

Postby Izzy » 05. December 2006 08:03

I just downloaded and installed RavenNuke with no issues at all on XAMPP 1.5.5 and I followed the installation instructions in the HowToInstall.

I set up some articles and did an RSS test and it worked perfectly.

My XAMPP installation is stock standard out-of-the-box with no additional tweaks as I use it for testing the problems submitted on these forums.

To find out why you're maybe having php errors, change this line in your config.php and save the file then visit your RSS pages again:
$display_errors = false;
to
$display_errors = true;

Change it back when you are finished debugging as it may be a possible security issue by giving out too much info to a site visitor.

With regard to your authCGI: issue you need to read this part in /html/HowToInstall/index.html

Configure NukeSentinel

If your host is running PHP as an Apache module, then you have the capability of using HTTP Authentication as a function of the browser and you do not even need .htaccess/.staccess.

PHP is running as an Apache Module in XAMPP.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby boored » 05. December 2006 15:31

I dont know how it went wrong, its a clean new install of both Xampp and Raven, and i tried to follow every step in How to install etc.....
Seems like there is a bug in backend.php though(not affecting everyone??)
http://ravenphpscripts.com/postt11173.html
by following that posts code-replace my RSS headlines .html pages now works fine.


I know PHP is running as Apache module, but it doesnt show up in NukeSentinel as available option(maybe another bug). Just "Off" and "AuthCGI" options are available.
As i understand NukeSentinel should automatically put that option available. Did it show up for you?
When i didnt have that option available i tried to get AuthCGI working(but maybe thats impossible if PHP is running as Apache module)
...doh... and NukeSentinel wont give me the AuthHTTP version...hmmm
boored
 
Posts: 2
Joined: 05. December 2006 02:35


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests