Page 1 of 1

Apache Service won't start - even listening on 8080

PostPosted: 01. December 2006 16:41
by gssi
I have installed XAMPP (Basic) twice with the same unsuccessful result: the install process completes successfully but the apache service won't start.

During the initial start-up of the apache service, I get the error message "Ports 80 or 443(SSL) already in use! Installing Apache service failed!"

In accordance with the book 'Beginning PHP5, Apache,MySQL Web Development' by Naramore, Gerner, Le Scouarnec, Stolz, Glass I have revised the http.conf file to reference port 8080 but the problem continues.

Any assistance would be appreciated ...

PostPosted: 01. December 2006 19:57
by Wiedmann
Just look with "xampp-portcheck.exe" which programm is using the Apache ports.

Stop this program.

Now start Apache with the original "httpd.conf".

PostPosted: 01. December 2006 21:56
by gssi
Thanks, Wiedman. Tried this but still having a problem. When I run the apache_start.bat file manually, I get an error report as follows:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. :make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs

Apache could not be started.

Any more thoughts?

PostPosted: 01. December 2006 23:19
by Wiedmann
You have used the "xampp-portcheck.exe" and what is the result?

PostPosted: 02. December 2006 10:50
by gssi
Wiedmann wrote:You have used the "xampp-portcheck.exe" and what is the result?

Thanks, Wiedmann. When I went back to review the portcheck results I noticed that the INETINFO process re-loaded itself after temination. When I used the MMC Services dialog to change the Start-up property for this task (IIS Admin) to Manual, from Automatic, I was able to terminate the INETINFO process without it reloading itself.

I presume that I will have to manage this IIS Admin task manually from now on and be aware of the potential conflicts between the two services, IIS and Apache?

Thanks for you help. Apache seems to be working fine now.