How can I enable the Optimizer in the "php.ini".

Problems with the Windows version of XAMPP, questions, comments, and anything related.

How can I enable the Optimizer in the "php.ini".

Postby twoshe » 30. November 2006 10:14

my forum need the zend Optimizer.After I install the XAMPP,how can i enable the zend Optimizer in php.ini????
Is the php.ini in the directory xampp\xampp\apache\bin?
I modify the php.ini for example:

[Zend]
zend_extension_manager.optimizer_ts = "D:\Program Files\xampp\xampp\php\zendOptimizer\lib\Optimizer"
zend_extension_ts = "D:\Program Files\xampp\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
zend_optimizer.license_path =


Local Variables:
tab-width: 4
End:


Is it all right?????????????
twoshe
 
Posts: 2
Joined: 30. November 2006 10:05

Re: How can I enable the Optimizer in the "php.ini"

Postby Izzy » 30. November 2006 10:29

twoshe wrote:my forum need the zend Optimizer.After I install the XAMPP,how can i enable the zend Optimizer in php.ini????
Is the php.ini in the directory xampp\xampp\apache\bin?

Yes
twoshe wrote:I modify the php.ini for example:

[Zend]
zend_extension_manager.optimizer_ts = "D:\Program Files\xampp\xampp\php\zendOptimizer\lib\Optimizer"
zend_extension_ts = "D:\Program Files\xampp\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
zend_optimizer.license_path =


Local Variables:
tab-width: 4
End:


Is it all right?????????????

In my php.ini it looks like this:
Code: Select all
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

Your path is different because you installed to a different location than I. Zend is enabled correctly on my installation.
You can use:
zend_optimizer.enable_loader = 1
as and when required. It is usually required if you have encrypted scripts.

After making changes to the php.ini file you should always restart Apache to have those changes take effect.

Check it is enabled on your installation by going to phpinfo() from the menu in the XAMPP Welcome Page using the localhost access.
You should see this among other zend things:
Zend Memory Manager enabled

Why are you asking, are you having problems with the Zend installation?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby twoshe » 01. December 2006 03:09

I can see the message:"Zend Memory Manager enabled ",but when i install my forum, it still prompt "zend optimizer is not installed "
why???
only because i install the xampp in a different directory????
twoshe
 
Posts: 2
Joined: 30. November 2006 10:05

Postby Izzy » 01. December 2006 03:50

twoshe wrote:I can see the message:"Zend Memory Manager enabled ",but when i install my forum, it still prompt "zend optimizer is not installed "
why???
only because i install the xampp in a different directory????

Then all that is left for you to do now is visit your forum's forum and ask the same questions there as Zend is enabled on your server.

xampp\php\zendOptimizer\docs
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 87 guests