Xampp was installed successfully, port 80 is opened but ...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp was installed successfully, port 80 is opened but ...

Postby clueless » 29. November 2006 18:59

nobody can see my sites... =(

Hello everybody, this is my situation:

I have installed Xampp for Wxp using the installer version. I have opened port 80 in the firewall ( I can see the port open here: http://www.upseros.com/portscan.php).

In C:\WINDOWS\system32\drivers\etc I edited the host:

127.0.0.1 mysite1.com
127.0.0.1 mysite2.com


190.38.xxx.xx mysite1.com
190.38.xxx.xx www.mysite1.com
190.38.xxx.xx mysite2.com
190.38.xxx.xx www.mysite2.com

And the code for httpd-vhost

Code: Select all
NameVirtualHost *:80


<VirtualHost *:80>
ServerName mysite1.com
ServerAlias www.mysite1.com
DocumentRoot "D:/xampp/xampp/htdocs"
<Directory "D:/xampp/xampp/htdocs">
IndexOptions +FancyIndexing NameWidth=*
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName mysite2.com
ServerAlias www.mysite2.com
DocumentRoot "D:/xampp/xampp/htdocs/site"
<Directory "D:/xampp/xampp/htdocs/site">
IndexOptions +FancyIndexing NameWidth=*
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName localhost
DocumentRoot "D:/xampp/xampp/htdocs"
</VirtualHost>


The funny thing is initially (with one domain) everything was working well, but when I tried to add the second domain. It says: Can`t connect with server... I don`t know what`s wrong.

I appreciate any help . Thank you so much for your time

PS: I have been reading the posts of this forum, and I have tried everything, and nothing works for my case... Please help =(
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby Izzy » 29. November 2006 23:04

Is http://www.upseros.com your web site as I can see this site no problem from here?
(or I could see it just tried again but it is now off line - I take it you are still working on it).

Who can't see your site?

In your 'hosts' file you also have to have:
127.0.0.1 localhost

Also you have installed to 'D:\xampp\xampp\" which is not a good idea. You should uninstall and remove that directory structure and install to a single xampp directory structure:
D:\xampp\
http://www.apachefriends.org/en/xampp-windows.html#1156

Because you installed to a double xampp directory did you run the setup-xampp.bat file as outlined in the The Installation instructions?
readme_en.txt

http://www.apachefriends.org/en/xampp-windows.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby clueless » 30. November 2006 00:02

Hi Izzy and thanks for your help!

Is http://www.upseros.com your web site as I can see this site no problem from here?
(or I could see it just tried again but it is now off line - I take it you are still working on it).


No, upseros is a site that scans my ports (http://www.upseros.com/portscan.php) they say that my port 80 is open. And is this ok, that means It`s something wrong with xampp, right?



Who can't see your site?


Anybody. When you try to enter in any of my sites. Simply says can`t connect to server.

In your 'hosts' file you also have to have:
127.0.0.1 localhost


I tried already to do it, but it doesn`t work either...


Initially (with that installation) One site (domain) was working ok. It seem from outside, but I changed for another domain and doesn`t work anymore...


Why it worked with a domain and then it was wrong? :(


Thank you very much for your help Izzy!
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby Izzy » 30. November 2006 00:12

Try moving mysite1 into it's own directory so it is different to the localhost directory. Then change your vhosts file to reflect your changes.
Other than that your vhosts file looks OK.
It can be checked by issuing the command apache -S at a command prompt in the xampp\apache\bin directory.

Does the domain name resolve to your XAMPP server IP at your domain name registrar? ns1.yourxamppserversIP etc.

Or are you using a DNS service like zoneedit.com or noip.com etc. that will allow your web sites to be visible from the Internet?

However http://localhost should show you the XAMPP Welcome Page but will not be visible to anyone else as it is only visible on your local PC.

You can PM me your web site URLs so I can check them from here to see if they are resolving.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby clueless » 30. November 2006 01:00

Hi again!

Ok, I did what you say Izzy. I changed the directory for mysite1. I`m using a DNS services for dinamic Ip. My sites are real domains, here is my apache - S

Image

Apparently everything is ok, but...


Thank you!


PS: It`s late right now (here 8:00 pm). My server is on. See you tomorrow! :wink:
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby Izzy » 30. November 2006 01:22

clueless wrote:Hi again!

Ok, I did what you say Izzy. I changed the directory for mysite1. I`m using a DNS services for dinamic Ip. My sites are real domains, here is my apache - S

Image

Apparently everything is ok, but...


Thank you!


PS: It`s late right now (here 8:00 pm). My server is on. See you tomorrow! :wink:

What does that post mean that all is now working for you? I think not ;)

I see a fundamental error in your localhost configuration in the apache -S results:
120.0.0.1:80
which should be:
127.0.0.1:80
You will need to fix that. Check your Windows hosts file and your httpd.conf file and change any instances of 120.0.0.1 to 127.0.0.1

skinnyhollyfug.com resolves on the Internet and I can access it from here but farandulista.com does not and I can't access it from here.
farandulista.com is set as your default server domain and as such will not load. Try and get the domain name to resolve on the Internet first.
http://70.84.211.98/co/DomainDossier.aspx
Enter farandulista.com in the text box and tick all boxes and you will see what I mean.

And your WordPress needs some configuration tweaks as it is not displaying the home page correctly ;)

Everything else is now working for you.

You just need to fix up those couple of issues and you are all set to go.

Apache doesn't hate you as Apache is nice and friendly to all who understand it and know how it likes things to be just perfectly correct.
Anything short of perfect and it will kick and buck like a struck mule :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby clueless » 30. November 2006 13:17

Good Day!

Hi Izzy, I changed the localhost configuration (I don`t know what I was thinking!!) And I went to the web: http://70.84.211.98/co/DomainDossier.aspx and I verified that farandulista doesn`t have DNS ... ¬¬ Mmmm that`s very strange, I asked already to the Domain service provider, I`m waiting for the answer.

Also I have installed wordpress again... Did you see all ok?


Thanks again Izzy! :D
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby Izzy » 30. November 2006 13:53

clueless wrote:Good Day!

Hi Izzy, I changed the localhost configuration (I don`t know what I was thinking!!) And I went to the web: http://70.84.211.98/co/DomainDossier.aspx and I verified that farandulista doesn`t have DNS ... ¬¬ Mmmm that`s very strange, I asked already to the Domain service provider, I`m waiting for the answer.

Also I have installed wordpress again... Did you see all ok?


Thanks again Izzy! :D


Your Wordpress still does not look like it should. Perhaps you have to set it up properly with a theme in the Site Admin/Presentation/Theme tab.
I am using the default theme but there is another theme choice in there also.

These image links below show you what I see on your wordpress site and the other is my wordpress test site using the default theme.

Your Wordpress

My Wordpress

I am pleased you are now having some success with your XAMPP installation and that you are now aware of your domain name issue.

Good luck with it and it seems that you are not as clueless now as you were when you first posted here. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby clueless » 30. November 2006 15:23

Oooh! I´m happy for the domain (you know is online!) But now I`m sad because the layout... I don`t understand why the theme doesn`t appear, Another mystery for my life. :?





Thanks again Izzy, you`re the best! :D
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby clueless » 30. November 2006 16:22

Hiiii Izzy!:D Farandulista works!! But now, I don`t understand why skinnyhollyfug doesn`t load... Why does it happen? :?
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58

Postby Izzy » 30. November 2006 23:59

clueless wrote:Hiiii Izzy!:D Farandulista works!! But now, I don`t understand why skinnyhollyfug doesn`t load... Why does it happen? :?

Both load just fine from here.

Clear your browser's cache and set it to load on every visit then try again.

Also make sure this line is included in your skinnyhollyfug vhosts container as I can't access the site with the www:

ServerName skinnyhollyfug.com
ServerAlias www.skinnyhollyfug.com

Can't help any more with the WordPress configuration. You will have to experiment or visit the WordPress forums to see if there are any issues with setting Themes. There may be other Themes to download and try on their site.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby clueless » 01. December 2006 12:54

Good Day Izzy!!


Thanks for your patience and your help, you`re the best!
The skinnyhollyfug domain doesn`t work and I don`t know why, I got the alias on the vhost... It`s so strange, but the domain that really matters for me is farandulista.

Anyhow I`ll find out how to solve about skinnyhollyfug and the wordpress theme.

:wink:

Thanks, thanks!

PS: Now Just I need help with mercury mail and I`ll be ready! But this is other topic :D


Thank you very much Izzy!!
Apache hates me!!! :``````( |||| Ok, ok ..Ok... apache almost loves me...
clueless
 
Posts: 8
Joined: 29. November 2006 17:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests