Apache keeps spiking to 100% and staying there!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache keeps spiking to 100% and staying there!

Postby Bidybag » 28. November 2006 22:51

Apache keeping going really high like to 100% and then stays there and goes down and then back up. How can i fix this?

I have celeron 2.4 and 1gb ram. I am using windows server 2003 and latest version of xampp. I use to run my website on a server with 256mb on linux and it was faster than this, it didnt spike. I read the FAQ and it said:

Please, enable following line = > # Win32DisableAcceptEx in the /xampp/Apache/conf/httpd.conf.

but this line isnt in that file. What can i do?
Bidybag
 
Posts: 9
Joined: 03. June 2005 15:53

Re: Apache keeps spiking to 100% and staying there!

Postby Izzy » 28. November 2006 23:15

Bidybag wrote:Apache keeping going really high like to 100% and then stays there and goes down and then back up. How can i fix this?

I am using windows server 2003 and latest version of xampp. I read the FAQ and it said:

Please, enable following line = > # Win32DisableAcceptEx in the /xampp/Apache/conf/httpd.conf.


but this line isnt in that file. What can i do?

You can add it to the bottom of the xampp\apache\conf\httpd.conf file using your fav. text editor like so (backup the file first):
# Win32DisableAcceptEx
Win32DisableAcceptEx


Save the file then restart Apache for your changes to take effect.
Note that this may have no effect on your issue but has been known to fix it on some systems.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Bidybag » 28. November 2006 23:22

I added this and restarted, it hasnt helped.

How am i going to fix this problem with apache at 100% cpu?
Bidybag
 
Posts: 9
Joined: 03. June 2005 15:53

Postby Izzy » 28. November 2006 23:35

Bidybag wrote:I added this and restarted, it hasnt helped.

How am i going to fix this problem with apache at 100% cpu?

If you are using the XAMPP Control Panel you can Exit the Control Panel and see if the CPU uasage drops.

If it does then restart the Control Panel and see if the CPU spikes again. This will isolate if the Control Panel is at fault.

Other than trying that then the only other thing might be to do a forum search to see if others have been able to isolate the issue to a fix.
To get the results in English select these in the Search Options section:
Forum: XAMPP for Windows
Category: Apache Friends in English
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Bidybag » 28. November 2006 23:47

My site is a forum so all the pages are php and using mysql but i have hosted my site on a worse server because and it didnt use to hang everytime i clicked a link. It is doing that now, when i click a few links on my site i see the cpu goes to 100%

Could the problem be with php and mysql causing apache to get a high load?

I exit control panel but i get same problem
Bidybag
 
Posts: 9
Joined: 03. June 2005 15:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests