Want to move root directory to another directory?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Want to move root directory to another directory?

Postby Stiggy » 22. November 2006 10:17

Hi,
I've just installed Xampp (again) after a year or so out from server admin, and i must say what a charm it is to have everything setup so easily and quickly!!!

As i havent used it for a while there was something i wanted to know how to do rather than wade through the pages of instructions available..(i know i'm lazy! ;) )

At the moment the first point of call is obviously the root directory is;

C:/root/xampp/htdocs

no problem there! :D


What i want to know is ..

..is there a way i can move the actual root to say;

C:/root/webroot

:?:

I know how to change the config file in apache (i have already changed the config file there, but to no avail!), but in xampp it's slightly different, how do i redirect traffic to the path in bold above please?

Thanks in advance - first time i've ever had to use this forum to ask a question...


..gotta love Xampp!

;)
Stiggy
 
Posts: 3
Joined: 22. November 2006 10:08

Postby Wiedmann » 22. November 2006 12:53

I know how to change the config file in apache ... but in xampp it's slightly different,

No, in XAMPP is the same Apache webserver as you can donwload from apache.org.

(Just change the 2 directives for the DocumentRoot in httpd.conf)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Stiggy » 22. November 2006 13:43

forgive me if i seem a little perplexed here..

..i had already changed the documentroot and directory to what i'd like the actual root to be, but it still goes to

c:/root/xampp

and not;

c:/root/webroot

i changed the config file in xampp/apache/conf/ so what am i doing wrong here?

It's going to be something really stupid i know (like i feel right now) but i've done everything that i did before and it's just not taking me there..

..i may just end up using what i've got - it's no biggy, but it'd be nice to know what i'm doing wrong!


And thanks for the reply btw, MUCH appreciated!

:D
Stiggy
 
Posts: 3
Joined: 22. November 2006 10:08

Postby Wiedmann » 22. November 2006 14:14

but it still goes to
c:/root/xampp

Sorry, but I think it (your browser) now want go to "http://localhost/xampp/" and not to "c:/root/xampp"?

BTW:
Clear your browser cache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Stiggy » 22. November 2006 14:20

:lol:

thank you!


:lol:

:D
Stiggy
 
Posts: 3
Joined: 22. November 2006 10:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 63 guests