XAMPP worked for some weeks and now I can't use it

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP worked for some weeks and now I can't use it

Postby Tasc0 » 22. November 2006 03:37

I've read the FAQ and I couldn't fix the problem. The Windows firewall is disabled and the firewall I have (ZoneAlarm) is disable too and when I try to go localhost the browser just load and does not see the index, neither works phpMyAdmin, etc.
What could be wrong?
Thanks in advance, I'll aprecciate any reply.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby underdone » 22. November 2006 05:22

Check the error logs and see if they say anything related to those errors.
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby Tasc0 » 22. November 2006 23:34

Thanks for answering.
Where I can find the logs?
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Wiedmann » 22. November 2006 23:56

Where I can find the logs?

I would search them in a directory with the name "logs"...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Tasc0 » 23. November 2006 00:44

Ok, this is the file error.txt in the folder xampp\apache\logs
Code: Select all
[Tue Nov 21 22:56:39 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Nov 21 22:56:39 2006] [notice] Server built: Sep 30 2006 21:24:06
[Tue Nov 21 22:56:40 2006] [notice] Parent: Created child process 2256
[Tue Nov 21 22:56:44 2006] [notice] Child 2256: Child process is running
[Tue Nov 21 22:56:44 2006] [notice] Child 2256: Acquired the start mutex.
[Tue Nov 21 22:56:44 2006] [notice] Child 2256: Starting 250 worker threads.
[Tue Nov 21 22:56:44 2006] [notice] Child 2256: Starting thread to listen on port 443.
[Tue Nov 21 22:56:44 2006] [notice] Child 2256: Starting thread to listen on port 80.
[Tue Nov 21 23:02:15 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Nov 21 23:02:15 2006] [notice] Server built: Sep 30 2006 21:24:06
[Tue Nov 21 23:02:15 2006] [notice] Parent: Created child process 568
[Tue Nov 21 23:02:17 2006] [notice] Child 568: Child process is running
[Tue Nov 21 23:02:17 2006] [notice] Child 568: Acquired the start mutex.
[Tue Nov 21 23:02:17 2006] [notice] Child 568: Starting 250 worker threads.
[Tue Nov 21 23:02:18 2006] [notice] Child 568: Starting thread to listen on port 443.
[Tue Nov 21 23:02:18 2006] [notice] Child 568: Starting thread to listen on port 80.
[Tue Nov 21 23:08:02 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Nov 21 23:08:02 2006] [notice] Server built: Sep 30 2006 21:24:06
[Tue Nov 21 23:08:02 2006] [notice] Parent: Created child process 224
[Tue Nov 21 23:08:04 2006] [notice] Child 224: Child process is running
[Tue Nov 21 23:08:04 2006] [notice] Child 224: Acquired the start mutex.
[Tue Nov 21 23:08:04 2006] [notice] Child 224: Starting 250 worker threads.
[Tue Nov 21 23:08:04 2006] [notice] Child 224: Starting thread to listen on port 443.
[Tue Nov 21 23:08:04 2006] [notice] Child 224: Starting thread to listen on port 80.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Tasc0 » 25. November 2006 05:24

Can anybody help me or tell me what's wrong?
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Tasc0 » 29. November 2006 23:17

Please, I really need help.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Izzy » 29. November 2006 23:26

The error log is not telling us anything untoward.

Try and give more info on what you are doing and what you did from install to now. Did you change any of the configuration files etc?

Do you have the localhost set in your Windows hosts file:
C:\WINDOWS\system32\drivers\etc\host

Drag it into your text editor to read and edit.

Look for:
127.0.0.1 localhost

If its not there then add it then save the file then restart Apache and try again to access http://localhost
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Tasc0 » 29. November 2006 23:36

Thanks for answering.
I haven't change any configuration files, etc.
In the host file I have 127.0.0.1 localhost so I really don't know why isn't working.
Maybe something is wrong with local services in Windows.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Izzy » 29. November 2006 23:43

Tasc0 wrote:Thanks for answering.
I haven't change any configuration files, etc.
In the host file I have 127.0.0.1 localhost so I really don't know why isn't working.
Maybe something is wrong with local services in Windows.


You may have a corrupt installation. Try uninstalling XAMPP and deleting the xampp directory completely, after backing up any files you need to keep of course. Then do an new install and follow the instructions you will find here:
http://www.apachefriends.org/en/xampp-windows.html

If you still have problems then post back.
BTW what OS are you using?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Tasc0 » 30. November 2006 01:01

Ok, I'll try that.
I'm using Windows XP:SP2
Edit:
Do I have to download this version?
http://www.apachefriends.org/en/xampp-windows.html#641
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Izzy » 30. November 2006 01:18

Tasc0 wrote:Ok, I'll try that.
I'm using Windows XP:SP2
Edit:
Do I have to download this version?
http://www.apachefriends.org/en/xampp-windows.html#641

I would then at least you will have the latest and greatest version of XAMPP.

Don't forget to back up your needed files and do a clean uninstall and delete your current xampp directory (or at the very least rename the current xampp directory to say xampp_old - that way you have a copy of your old configuration files if needed later for checking purposes).

Also don't forget to close all XAMPP services, including the Xampp Control Panel, that may be running in the background before trying to uninstall your current version.
Check using the Windows Task Manager (right click on the Task Bar and select Task Manager then the Processes Tab) that there are no instances of apache.exe, mysqld.exe or mysqld-nt.exe, FilezillaService.exe or mercury.exe.
If there are then right click on the exe file and select End Process then click OK on the next window.

Now you should be clear to uninstall your old version. Then install your new version 1.5.5
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Tasc0 » 30. November 2006 02:12

Ok, I unistalled XAMPP, deleted the xampp folder, and clean the registry.
After that I rebooted the computer and installed the latest version of XAMPP. All service are running and I still can't access to localhost. It keeps loading.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Postby Izzy » 30. November 2006 02:20

Tasc0 wrote:Ok, I unistalled XAMPP, deleted the xampp folder, and clean the registry.
After that I rebooted the computer and installed the latest version of XAMPP. All service are running and I still can't access to localhost. It keeps loading.


Clear your browser's cache of all files and set it to load fresh on every visit. Your bowser cache is your worst enemy when dealing with a server at localhost level.

Also check what page your browser is trying to load when you start it. It should be trying to load about:blank. If it is trying to load another page then the page might not be available and so the browser stalls.

Can you stop all the services then run xampp\xampp-portcheck.exe and see if all ports a Free.

Try starting apache using the apache_start.bat file not the Control Panel and see if that works for you. If not past here what is returned when using the bat file.

Another thing you can try if all the above fail is stop the apache server and add Win32DisableAcceptEx to the end of xampp\apache\conf\httpd.conf file.
Save it and restart apache again.

XAMPP works "out of the box" 99.99% of the time if there is nothing wrong with your OS or browser settings.
Last edited by Izzy on 30. November 2006 02:50, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Tasc0 » 30. November 2006 02:47

Cache deleted and still having problems...
Port checking results:
Code: Select all
Please wait a moment...


RESULT
------

Service              Port   Status
==============================================================================
Apache (HTTP)          80   free
Apache (WebDAV)        81   free
Apache (HTTPS)        443   free

MySQL                3306   free

FileZilla (FTP)        21   free
FileZilla (Admin)   14147   free

Mercury (SMTP)         25   free
Mercury (POP3)        110   free
Mercury (IMAP)        143   free

Press <Return> to continue.

I'd like to say something. I tried to use XAMPP some time ago and I couldn't, I had this same problem. Then I formated the computer so I tried again with XAMPP just in case and it worked great for some weeks. One day just stoped working with no reason (I guess).
I'm thinking on a virus, mal-ware, etc. Is that possible, even if I'm running XAMPP in my computer?
Edit:
I saw your edited reply, sorry.
Well, just tried with the apache_start.bat and I get an error:
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)S¾lo se permite un uso de cada direcci¾n de socket (protocolo/direcci¾
n de red/puerto)  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press a key to continue . . .

(*) You may find some words in Spanish, that's my Windows lenguage. But you can read the error message.
Tasc0
 
Posts: 14
Joined: 22. November 2006 03:21

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests

cron