The SSI problem again

Problems with the Windows version of XAMPP, questions, comments, and anything related.

The SSI problem again

Postby edsims » 21. November 2006 23:51

Hi, I have XAMPP 1.5.4a installed and running under XP Pro /SP2. No errors upon install. (re-)Building pages to upload to a new server running FreeBDS/Apache. Need to develop with SSI. Everything says SSI is fine.
I have been reading most of today the post here and have not found this problem EXACTLY. But I think is related to the placement of the directory.
I am using C:\webserver\xampp\htdocs\www\ for all development. HTML works fine. Haven't tried/needed Php.
My httpd-config: lines 436-438
Code: Select all
   AddType text/html .shtml
   AddOutputFilter INCLUDES .shtml

I have testincludes.shtml with these two lines in the body;
Code: Select all
<!--#echo var="DATE_LOCAL" -->

<!--#include virtual  ="./redirect.txt"-->

This file is located in "/www". I issue "http://localhost/www/testincludes.shtml" in several different browsers and get:
Code: Select all
Tuesday, 21-Nov-2006 16:11:25 Central Standard Time

[an error occurred while processing this directive]

Checking the error log I find:

Code: Select all
[Tue Nov 21 16:11:25 2006] [error] [client] unable to include "redirect.txt" in parsed file C:/webserver/xampp/htdocs/www/testincludes.shtml

O.K., Why was it unable to include 'redirect.txt'? I have tried several different files to include, txt, html, etc. Same results. I find nothing unusual in the file properties.
Can anyone please help?
Posts: 1
Joined: 21. November 2006 20:30

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests