Not Starting? says alreaddy been installed?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Not Starting? says alreaddy been installed?

Postby jnymris » 11. November 2006 00:14

I've just installed XAMPP for about the 5th time i remember installing it awhile back when i didn't know what i was doing. Now i installed it again with a bit more knowledge yet when i install it says;apache, MySql & FileZilla have already been installed yet when i try and start them they don't run. I have tried to uninstall and install again yet the same problems occurs.

can anybody help?
jnymris
 
Posts: 8
Joined: 11. November 2006 00:07
Operating System: Windows 7 XP Mode/Windows 7

Re: Not Starting? says alreaddy been installed?

Postby Izzy » 11. November 2006 00:48

jnymris wrote:I've just installed XAMPP for about the 5th time i remember installing it awhile back when i didn't know what i was doing. Now i installed it again with a bit more knowledge yet when i install it says;apache, MySql & FileZilla have already been installed yet when i try and start them they don't run. I have tried to uninstall and install again yet the same problems occurs.

can anybody help?


When you uninstalled XAMPP did you delete the XAMPP directory tree?
xampp\readme-en.txt
Step 5: XAMPP UNINSTALL? Simply remove the "xampp" Directory.
But before please shutdown the apache and mysql.


After a fresh install and before trying to start XAMPP, run xampp\xampp-portcheck.exe to see if the all the ports required by XAMPP are Free
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Not Starting? says alreaddy been installed?

Postby jnymris » 11. November 2006 00:56

Izzy wrote:
jnymris wrote:I've just installed XAMPP for about the 5th time i remember installing it awhile back when i didn't know what i was doing. Now i installed it again with a bit more knowledge yet when i install it says;apache, MySql & FileZilla have already been installed yet when i try and start them they don't run. I have tried to uninstall and install again yet the same problems occurs.

can anybody help?


When you uninstalled XAMPP did you delete the XAMPP directory tree?
xampp\readme-en.txt
Step 5: XAMPP UNINSTALL? Simply remove the "xampp" Directory.
But before please shutdown the apache and mysql.


After a fresh install and before trying to start XAMPP, run xampp\xampp-portcheck.exe to see if the all the ports required by XAMPP are Free


Okay yes i did delete the directory tree. I did remove the directory. i shut down acpache and mysql. i did re-install but still recieve a message saying "apache, MySql & FileZilla have already been installed" and it was aborted.

again i checked the ports was open yet it was again. When i try to run it wasn't starting. apache, MySql & FileZilla
jnymris
 
Posts: 8
Joined: 11. November 2006 00:07
Operating System: Windows 7 XP Mode/Windows 7

Postby Izzy » 11. November 2006 01:21

First, what error messages are you getting when you try and start apache using the xampp\apache-start.bat?

Using the Task Manager/Processes tab check that there are no instances of Apache.exe (2), mysqld.exe or mysqld-nt.exe or FileZillaserver.exe running. If there are then right click on them and select End Process. Then try again to start your XAMPP components.

You could also try this:
a) Close the control panel.

b) Open a command prompt (cmd.exe)and type:

sc delete mysql
sc delete apache2
sc delete "FileZilla Server"


c) Start the control panel

sc stands for service control and will delete any stray services that won't shut down by any normal means.

If you have tried certain things before then post what you did as it will help to speed up the process of finding a solution for you.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Getting their

Postby jnymris » 11. November 2006 08:16

Okay i did
sc delete ...

to everything, now everything runs apart from filezilla.

When i try to start that it says: "ERROR: FileZilla FTP must be run as a service"

I'm gussing to re-install?
jnymris
 
Posts: 8
Joined: 11. November 2006 00:07
Operating System: Windows 7 XP Mode/Windows 7

Re: Getting their

Postby Izzy » 11. November 2006 12:08

jnymris wrote:Okay i did
sc delete ...

to everything, now everything runs apart from filezilla.

When i try to start that it says: "ERROR: FileZilla FTP must be run as a service"

I'm gussing to re-install?

No need to re-install. Just click on the Svc check box next to the FileZilla name in the Control Panel, it will ask questions that you will have to answer. I take it you are using the XAMPP Control Panel.
Or start it using xampp\filezilla_setup.bat
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Thanks But

Postby jnymris » 14. November 2006 00:33

Thanks but a very simple question. Where do i put in my php files and mysql databases?

Thanks the Problems has been sorted
jnymris
 
Posts: 8
Joined: 11. November 2006 00:07
Operating System: Windows 7 XP Mode/Windows 7

Re: Thanks But

Postby Izzy » 14. November 2006 07:34

jnymris wrote:Thanks but a very simple question. Where do i put in my php files and mysql databases?

Thanks the Problems has been sorted

Did you solve where to put your php files and databases?

The php files you want served by Apache go in a directory within a Document Root. One such Document Root is \xampp\htdocs\.
Other Document Roots may be defined in a virtual host directive in \xampp\apache\conf\extras\httpd-vhosts.conf file.

You databases can be created and managed using phpMyAdmin.
http://localhost/phpmyadmin/
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests