Page 1 of 3

Can't Start Apache in WinXP-Pro SP-2

PostPosted: 01. November 2006 03:01
by rabbit hutch
Do I have to post in German? If so, I'm in trouble. I chose "english" as the forum language when I registed but I see German here. Aber, ich koenne nur ein bischen Deutsch.

Just in case English is OK, I'll ask my question.

Why can I not start Apache under Xampp? When I display the Xampp Control Panel, it shows the 3 Svc boxes (for Apache, MySQL and Filezilla checked and indicates that MySQL and Filezilla are running. When I click on the button to start Apache, I get the message "Busy. . . ERROR Apache service not started [-1]" Task Manager confirms that Apache is not running and that the other 2 are. I could post a screenshot if I knew how. Do I have to host the image somewhere before I can post it here?

I read the Xampp FAQ that I thought was relevant, and turned my WinXP firewall off and tried again with the same result. When I looked at the firewall exceptions, Apache was among them.

I am a complete an utter novice using Apache. I was a mainframe programmer back in the '70s and am now retired. I've recently started learning PHP and need a local server which led me to WAMP5, EasyPHP and maybe one or two more 'packages'. I've had trouble with each of them - usually with phpMyAdmin. I even tried to download and install Apache, PHP, and MySQL separately with no luck. On another forum, Xampp was recommended. I downloaded and installed it but can't get past this error.

Would really appreciate any help, guidance, references to on line how-to's etc.


PostPosted: 01. November 2006 10:07
by Wiedmann
When I click on the button to start Apache, I get the message "Busy. . . ERROR Apache service not started [-1]"

Why have Windows an event log for applications?

PostPosted: 01. November 2006 11:40
by DoorsDirect
Good morning Rabbit Hutch

I have just experienced the same problem that you have posted. I have uninstalled/reinstalled several times but with same result.

I am about to try installation on a different computer and will post the results of this later. If you manage to solve the problem I would be grateful for any help.



PostPosted: 01. November 2006 19:33
by rabbit hutch
Wo muss ich besuchen fur diese log?

Wiedmann wrote:
When I click on the button to start Apache, I get the message "Busy. . . ERROR Apache service not started [-1]"

Why have Windows an event log for applications?

Ach! Ich habe dass gefindet aber weiss nicht welcher zeit ist richtig fur diese error.

(Please pardon my Tarzan-like German. It's been 50 years since I studied the language.)

Screenshot of Event Log

PostPosted: 01. November 2006 20:03
by rabbit hutch
I attempted to start Apache again in order to create the error once more.

Here is the Event Log information generated by the error.


Why doesn't the screenshot show?

PostPosted: 01. November 2006 20:04
by Wiedmann
Well, hit the button "start Apachet" once more, look at your watch and you have a timestamp (or just read the last log entry for Apache in this case).

Here is the text of the error.

PostPosted: 01. November 2006 20:09
by rabbit hutch
Faulting application mmc.exe, version 5.1.2600.2180, faulting module ntdll.dll, version 5.1.2600.2180, fault address 0x00010f29.

For more information, see Help and Support Center at

PostPosted: 01. November 2006 20:19
by Wiedmann
This error is not related to the Apache service. (But you have a problem with your Windows...)

You can start Apache with the batchfile (apache_start.bat)?


PostPosted: 01. November 2006 21:52
by rabbit hutch
Viele Danken Wiedmann!

PostPosted: 02. November 2006 08:23
by Lame_Duck
Run xampp-portcheck.exe from the XAMPP folder and see if Apache's ports are being used by something else.

My was being used by Skype, go figured. All I had todo was uncheck the "Use port 80" box in Skype's connection settings.

Apache Ports

PostPosted: 03. November 2006 04:23
by rabbit hutch
Ran Xampp-portcheck.exe as you suggested with these results:

HTTP Port 80 Status Free
WebDAV Port 81 Status free
HTTPS Port 443 Status free

MySQL Port 3306 Status shows pathname to MySQL executable

FTP Port 21 Status shows pathname to Filezilla server executable
Admin Port 14147 Status shows pathname to Filezilla server executable

SMTP Port 25 Status free
POP3 Port 110 Status free
IMAP Port 143 Status free

Does any of this indicate a problem to you?

Thanks for your help, Lame_Duck

PostPosted: 07. November 2006 17:18
by Cruds
I get the same error in my control panel for Apache, Mysql and Filezilla. I did however notice that everything work right when Im logged in as a administrator on windows. But when I use my main-user account - which I use normally - i get those -1 errors too.

Re: Screenshot of Event Log

PostPosted: 07. November 2006 22:54
by nimd4
rabbit hutch wrote:Image

Why doesn't the screenshot show?

Basically you need to post it without the extra "l" on the extension, so just ".jpg" ? .. :D

Also, if you use "Alt + Print Scrn", Windblows will take screenshot of only the active window :) .. save it as PNG (or GIF), for better quality ..

Apache service not started [-1]

PostPosted: 25. February 2007 12:43
by helihoppter

I've got the same problem as all of you ... but I've already had the XAMPP installed successfully, but after trying out a CMS it all crashed and although:

- the firewall is inactive
- the ports are all free
- i've completely deleted every single folder of xampp

it doesn't work anymore ...

Does anyone know how to get round this problem?? Or does anyone know another opportunity how Apache could possibly work alright??


:) Christian

Solution found

PostPosted: 25. February 2007 13:12
by helihoppter

I've already found a solution for my problem:

Due to that I've already had xampp installed before (in the directory c:\programme\xampp 1.5.5\) and now the latest version of xampp installed in c:\programme\xampp\ windows couldn't find the path of the service, that was linked to the old directory ....

However, there was also a second, "new" service that was linked correctly and I started it at services.msc! Now xampp still shows that Apache can't be started, anyhow, it is working now ... so why complain??

:) Christian