Can't Start Apache in WinXP-Pro SP-2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Can't Start Apache in WinXP-Pro SP-2

Postby sven30 » 08. July 2009 21:11

ok, i've done everything on this thread and when i restart from administrative services I get an error saying to check the log files and... if it's a non microsoft service to check with the vendor etc...error 1.

Anyway, Port 80 is free, virus protection disabled. I've uninstalled reinstalled, multiple different ways presented in this thread, nothing works. This is very frustrating. I've never been able to successfully setup a simple web server on my windows machine. It's be nice if it just worked for once. i have a feeling this is a great peice of software but I can't test it out yet. Any help would be greatly appreciated.
Posts: 1
Joined: 08. July 2009 18:50

Re: Can't Start Apache in WinXP-Pro SP-2

Postby hml_h » 15. July 2009 02:49

hello everyone~
i have the same problem----i can't start apache in winxp pro SP3
i have try many methods ,but can't work

i use xampp to start mysql and filezilla ,they work ok.
but when i use the button to start apache , it says "busy apache service started"
i have checked the port 80,81,443 ,they all free .
and i look into taskman ,there is no httpd.exe running.
so i also try to start the apache service through services.msc , the same result....(it says the apache service shutdown when it starts for a while)

thankyou !
Posts: 2
Joined: 15. July 2009 02:19

Re: Can't Start Apache in WinXP-Pro SP-2

Postby Wiedmann » 15. July 2009 03:16

Start Apache with the batchfile and read the error message.
AF Moderator
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't Start Apache in WinXP-Pro SP-2

Postby hml_h » 15. July 2009 16:33

Wiedmann wrote:Start Apache with the batchfile and read the error message.

the error_log says:setup_inherited_listeners(), WSASocket failed to open the inherited socket.
so i look into the internet and find the solution :stop the lmhosts query.
done !
thank you !
Posts: 2
Joined: 15. July 2009 02:19

Re: Can't Start Apache in WinXP-Pro SP-2

Postby asynctea » 18. September 2009 01:35

I know the post title says WinXP, but I was getting the same problem in Vista until I ran as Administrator. Hope it helps someone else who didn't pay attention to the title. In Vista run xampp_control.exe as administrator.
Posts: 1
Joined: 18. September 2009 01:31

Useful tool to x-ray all hidden processes that use-up memory

Postby verysmallears » 18. September 2009 19:59

Hi Folks,

I recommend the X-Ray My PC Scanner tool. It will list all processes running on your computer, even hidden ones with their descriptions and security risks. If you do not have a description for the specific process, then most likely it is a malicious process.

You can download the scanner from the link below (it is free):
Posts: 2
Joined: 31. July 2009 20:27

Re: Can't Start Apache in WinXP-Pro SP-2 - Solution

Postby Golgar_2000 » 02. October 2009 07:31

Hi, I Believe I Have A Solution.
I Have Always Manually Gone & Downloaded, Installed & Configured All The Separate Programs, Apache, PHP, etc. Never Had A Problem I Couldn't Fix Or Find A Solution For, Anyway, I Have Just Downloaded & Installed XAMPP 1.7.2 Also The Tomcat Add-on. Now Everything Was Fine First Run All Services Ran Fine.

Mercury &

The Problem Started After I Restarted My Computer. No Apache? It Says It Started But Nothing, Hmmm Strange. All The Configuration Files Where Correct. So I Mucked Around For A While, Researched Everywhere & Even Tried To Install Apache Over The Apache Directory In XAMPP. Still Nothing. So I Started Again. Uninstall, Re-Install. Hey Apache Is Working Again. This Time No Restart. So I Just Clicked The Stop Apache Button, All Good. Ok Start Apache, NOTHING AGAIN. Sound Familiar?

Now Is Not The Time To Scream, It Has Already Told You The Problem. Apache. Very Simple, Go & Check Out The Error Log (Open With Notepad) The Log Files Are Located Here

" \xampp\apache\logs

Go To The Bottom Of The Log File & You Will See The Date, Time & Status. I Found That A File Was Missing Or Could Not Be Located. The Problem Was Related To Tomcat Which Stopped Apache From Starting.

"" Was Missing From " \xampp\tomcat\Server\xampp\apache\modules\

So I Found A Copy Of "" Located In " \xampp\apache\modules

So Very Simple. I Copied "" From “ \xampp\apache\modules To “ \xampp\tomcat\Server\xampp\apache\modules\

Clicked The Start Apache Button & TADA Apache Is Working Again.

Now If A Different File Is Missing Try Searching Your Computer For It & If You Don’t Have It Download The ZIP File From & You Should Find It In There.

In Conclusion If Apache Won't Start Or Won't Stay On Check You Log Files It Will Tell You The Problem. I Hope This Has Helped.
Posts: 10
Joined: 02. October 2009 06:18

Re: Can't Start Apache in WinXP-Pro SP-2

Postby Izzy » 02. October 2009 08:21

Golgar_2000 wrote:"" Was Missing From " \xampp\tomcat\Server\xampp\apache\modules\
Posts: 3344
Joined: 25. April 2006 17:06

Re: Can't Start Apache in WinXP-Pro SP-2

Postby ginlau46 » 17. November 2009 11:34

I had this problem also. I uninstalled MS IIS and using the xampp control panel, I was able to start Apache :) .
Posts: 1
Joined: 17. November 2009 11:28

Re: Can't Start Apache in WinXP-Pro SP-2

Postby wroken » 27. January 2010 22:49

Hi, possible solution: ... pado-busy/

I fix that with that solution.
This works.
Posts: 1
Joined: 27. January 2010 22:45

Re: Can't Start Apache in WinXP-Pro SP-2

Postby Voices » 25. May 2010 10:15

just like to share my experience on this topic. I had similar problem to many of the prev posters, I had successfully installed xampp and ran apache, filezilla and mysql for one day. It was working brilliantly until I added a ip-address in the "httpd-xampp.conf" file:
# New XAMPP security concept
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny, allow
Deny from all
Allow from ::1 \
::1 \
fc00::/7 \

ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var

Since I was playing around with 3 different computers at the time (2 on the same network and 1 external), it took me a while to note that xampp no longer would start on the computer where the change had been made.
The revelation came when reading "..\xampp\apache\logs\error.log". It was complaining about line 121: "Order deny, allow". The correct syntax was "Order deny,allow" instead of "Order deny, allow".
Now it all works. Simply a newbie fault but not obvious at all.
Posts: 1
Joined: 24. May 2010 14:04

Re: Can't Start Apache in WinXP-Pro SP-2

Postby naji123 » 26. December 2010 15:35

My friend try to close all the application that might be opened automatically when you open your computer because some of those applications interrupts the procedures of the start. and try to close any remote access to your device
Posts: 1
Joined: 26. December 2010 15:31

Re: Can't Start Apache in WinXP-Pro SP-2

Postby ApacheDeSanFran » 15. January 2011 20:13

I don't know if this solution applies to others that have struggled with this problem, but I wanted to post my fix. As for me, I had previously installed Xampp under "C:\Program Files", but later decided to uninstall and reinstall it in "C:\Xampp". At that point, I could no longer start the Apache or MySQL services, regardless of whether I did it through Xampp or Windows -> Control Panel -> Administrative Tools -> Services.

So my fix was as follows:
* I launched regedit looked for all instances of "httpd.exe" and made changes as needed
* I found several locations, including "HKLM\SYSTEM\ControlSet001\Services\Apache2.2", but there were several other places.
** For example (in the above registry location), I changed the value for 'ImagePath'
- from: "C:\Program Files\Xampp\xampp\apache\bin\httpd.exe" -k runservice
- to: "C:\Xampp\xampp\apache\bin\httpd.exe" -k runservice
* I had to do something similar for MySQL as well in regedit.

Posts: 2
Joined: 15. January 2011 20:03

Re: Can't Start Apache in WinXP-Pro SP-2

Postby ApacheDeSanFran » 16. January 2011 22:46

Actually, I missed a VERY IMPORTANT step!

I need to run in a DOS window, the following command:
C:\>net stop w3svc

This stops the IIS WWW service, which will conflict with Apache if left active. You can probably do the same thing in Control Panel -> Administrative Tools -> Services
Posts: 2
Joined: 15. January 2011 20:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests