enablng innodb

Problems with the Windows version of XAMPP, questions, comments, and anything related.

enablng innodb

Postby witham » 28. October 2006 18:38

can anyone please tell me how to enable innodb as it is currently not avaiable in phpadmin
witham
 
Posts: 28
Joined: 03. August 2006 21:53

Innodb in mysql...

Postby Xplorer » 07. November 2006 10:42

...seems not to be enabled in the mysql version shipped together with XAMPP 1.5.4a. As I also wanted to have Innodb engine, I tried to figure out how to make the trick and here's what I've come up with.

- install XAMPP from the ZIP-file, in my case into C:\ (so I get the installation under c:\xampp)
- install a downloaded mysql 5.0 into c:\xampp\mysql
- do the rest of the setup manually, by running setup_xampp.bat and all the other bat-files to get the services etc (also achievable by xampp-control.exe)

I am not sure if this is the kosher way of doing things, as I run mysql 5.0.27 against databases coming from mysql 5.0.24, but it has worked for me. Any comments from anybody?

/Z
Xplorer
 
Posts: 3
Joined: 30. October 2006 22:29

Postby KevinASUDevil » 10. February 2007 01:40

In english, the best way is to edit the "my" file under \xampp\mysql\bin directory.

Look for the line (63 for me):
Code: Select all
skip-innodb

and comment that out.

Then uncomment the non-comments below it, so it looks like:
Code: Select all
#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = /xampp/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /xampp/mysql/data/
innodb_log_arch_dir = /xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50


Super easy (and in English).. Or read the readme_en.txt (line 139 in the 1.5.5 package)

- Kevin
KevinASUDevil
 
Posts: 1
Joined: 10. February 2007 01:15

Postby Kodiak3000 » 03. April 2007 17:22

I've run into this time and time again in my search today - this is the solution given in every post in every forum I've read, but in every case, the next post is "but I can't find that file in my directory"...

Neither can I.

Could it be somewhere else? Could the file path be different in this version of XAMPP?

Cheers
Kodiak3000
 
Posts: 1
Joined: 03. April 2007 17:16

Postby Wiedmann » 03. April 2007 18:02

Could it be somewhere else? Could the file path be different in this version of XAMPP?

No, and no.

It's really so simple:
- select the file "my" (aka "my.cnf") in explorer, path "\xampp\mysql\bin", with your mouse
- drag 'n drop the file in your editor

Or like that:
Windows Taskbar --> Start --> Run:
notepad \xampp\mysql\bin\my.cnf

Or use the file open dialogue in your preferred text editor.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Also try my.ini

Postby geraldgrogan » 30. November 2007 10:00

You will need to also update the file called my.ini located in C:\WINDOWS
geraldgrogan
 
Posts: 2
Joined: 05. May 2007 18:57


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests