Port 80 blocked

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port 80 blocked

Postby Wittner » 19. October 2006 11:32

I was pulling my hair out with this error during installation (was trying to manually install Apache before I discovered XAMPP and got the same error). The problem was that Skype uses port 80 when running and so Apache can't bind with it.

The solution is to quit Skype before installation (or re-install after quitting). Worked a treat for me so I'm posting this for others who search under the port 80 blocked error message in the hope that they get some benefit.

By the way - coooool application. I've installed LAMP/WAMP manually for production purposes many times and this is soooo much better!

cheers,

Mike
Wittner
 
Posts: 6
Joined: 19. October 2006 11:26

Re: Port 80 blocked

Postby Izzy » 19. October 2006 11:44

Wittner wrote:I was pulling my hair out with this error during installation (was trying to manually install Apache before I discovered XAMPP and got the same error). The problem was that Skype uses port 80 when running and so Apache can't bind with it.

The solution is to quit Skype before installation (or re-install after quitting). Worked a treat for me so I'm posting this for others who search under the port 80 blocked error message in the hope that they get some benefit.

By the way - coooool application. I've installed LAMP/WAMP manually for production purposes many times and this is soooo much better!

cheers,

Mike

Running xampp\xampp-portcheck.exe will tell you what is using the ports required for XAMPP. All ports should show as free in the returned results for XAMPP to install smoothly.

Often the other defaults port blocker is IIS which can be deactivated in the Windows control panel.

There is no need to uninstall or close Skype as it can be configured to use another port.

Skype uses port 80 and 443 by default.
You can alter that behaviour by going to:
Tools\Options\Connection
Untick
Use port 80 and 443 as alternative for incoming connections
You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

With Skype using these incomming ports you become a supernode:
Basically you relay others calls, and messages.
Look here for more:
http://forum.skype.com/viewtopic.php?t= ... =supernode

Info from this thread:
http://forum.skype.com/lofiversion/inde ... 51147.html

Quote from this site:
http://en.wikipedia.org/wiki/Skype
wikipedia wrote:The use of end-user bandwidth in the form of supernodes, the use of closed source software in general, the use of closed source software for encryption of network traffic in particular as well as security of the software, have caused concern among open source advocates. Independent analyses of the software have addressed the latter to some degree.

And with Skype you really don't have a choice to not be a supernode.
Last edited by Izzy on 19. October 2006 23:50, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wittner » 19. October 2006 16:37

Thanks a lot Izzy, that makes things very clear - and sounds a bit cheeky of Skype since they don't make any note of it in any clear way,


cheers,

Mike
Wittner
 
Posts: 6
Joined: 19. October 2006 11:26

Postby j » 26. October 2006 00:31

Great tip on xampp-portcheck.exe! Thanks Izzy!

However, I'm still pulling out my hair for the fail on Apache installation. After checking, this is what I got for my port80 blocker:

Servie Port Status
============================
Apache (HTTP) 80 C:\WINDOWS\system32 \inetsrv\inetinfo.exe

Any clue about how to relinquish this port80 to XAMPP?

Thanks in advance!

J
j
 
Posts: 1
Joined: 26. October 2006 00:22

Postby Izzy » 26. October 2006 00:50

j wrote:Great tip on xampp-portcheck.exe! Thanks Izzy!

However, I'm still pulling out my hair for the fail on Apache installation. After checking, this is what I got for my port80 blocker:

Servie Port Status
============================
Apache (HTTP) 80 C:\WINDOWS\system32 \inetsrv\inetinfo.exe

Any clue about how to relinquish this port80 to XAMPP?

Thanks in advance!

J

This is the Windows Internet Information Server IIS which is set on by default. I don't have it installed so not too sure about how to deactivate it.

I am told you can do this in the Windows Control Panel. You will have do a look see in the CP to find it then select to deactivate it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests