Help on outside access

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help on outside access

Postby Corvisier » 18. October 2006 04:45

Sorry for nagging you all again but I have a problem with my sites.
I installed everything, redirected port 80 and configured the files like this:

httpd-vhosts.conf

Code: Select all
<VirtualHost *:80>
DocumentRoot /xampp/xampp/htdocs/
ServerName localhost
ServerAdmin admin@localhost
</VirtualHost>

<VirtualHost *:80>
ServerName forumisvouga.org
ServerAdmin admin_fisvouga@clix.pt
ServerAlias forumisvouga.pt.vu
DocumentRoot /xampp/xampp/htdocs/forumisvouga.org
<Directory "/xampp/xampp/htdocs/forumisvouga.org">
Options            Indexes FollowSymLinks
AllowOverride      All
Order              allow,deny
Allow              from all
</Directory>
<Directory "/xampp/xampp/htdocs/forumisvouga.org">
Options Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddHandler server-parsed .html .htm .shtml .shtm
</Directory>
HostnameLookups    Off
ErrorLog           /xampp/xampp/htdocs/forumisvouga.org/logs/error.log
LogFormat           "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat           "%h %l %u %t \"%r\" %>s %b" common
LogFormat           "%{Referer}i -> %U" referer
LogFormat           "%{User-agent}i" agent
CustomLog          /xampp/xampp/htdocs/forumisvouga.org/logs/access.log combined
ServerSignature    On
ScriptAlias        /cgi-bin/  "/xampp/xampp/htdocs/forumisvouga.org/cgi-bin/"
<Directory "/xampp/xampp/htdocs/forumisvouga.org/cgi-bin">
AllowOverride      None
Options            None
Order              allow,deny
Allow              from all
</Directory>
DirectoryIndex     index.php
AccessFileName     .htaccess
<FilesMatch "^\.ht">
Order allow,deny
Deny from all
</FilesMatch>
AddHandler         cgi-script .cgi
<IfModule mod_negotiation>
<IfModule mod_include>
Alias /errors/ "/xampp/xampp/htdocs/forumisvouga.org/errors/"
<Directory "/xampp/xampp/htdocs/forumisvouga.org/errors">
AllowOverride None
Options IncludesNoExec
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority pt
</Directory>
</IfModule>
</IfModule>
ErrorDocument 400 /errors/400.html
ErrorDocument 401 /errors/401.html
ErrorDocument 403 /errors/403.html
ErrorDocument 404 /errors/404.html
ErrorDocument 405 /errors/405.html
ErrorDocument 408 /errors/408.html
ErrorDocument 410 /errors/410.html
ErrorDocument 411 /errors/411.html
ErrorDocument 412 /errors/412.html
ErrorDocument 413 /errors/413.html
ErrorDocument 414 /errors/414.html
ErrorDocument 415 /errors/415.html
ErrorDocument 500 /errors/500.html
ErrorDocument 501 /errors/501.html
ErrorDocument 502 /errors/502.html
ErrorDocument 503 /errors/503.html
ErrorDocument 506 /errors/506.html
</VirtualHost>

<VirtualHost *:80>
ServerName blog
ServerAdmin hept@netc.pt
ServerAlias blogsemnexo.pt.vu
DocumentRoot /xampp/xampp/htdocs/blog
<Directory "/xampp/xampp/htdocs/blog">
Options            Indexes FollowSymLinks
AllowOverride      All
Order              allow,deny
Allow              from all
</Directory>
<Directory "/xampp/xampp/htdocs/blog">
Options Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddHandler server-parsed .html .htm .shtml .shtm
</Directory>
HostnameLookups    Off
ErrorLog           /xampp/xampp/htdocs/blog/logs/error.log
LogFormat           "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat           "%h %l %u %t \"%r\" %>s %b" common
LogFormat           "%{Referer}i -> %U" referer
LogFormat           "%{User-agent}i" agent
CustomLog          /xampp/xampp/htdocs/blog/logs/access.log combined
ServerSignature    On
ScriptAlias        /cgi-bin/  "/xampp/xampp/htdocs/blog/cgi-bin/"
<Directory "/xampp/xampp/htdocs/blog/cgi-bin">
AllowOverride      None
Options            None
Order              allow,deny
Allow              from all
</Directory>
DirectoryIndex     index.php
AccessFileName     .htaccess
<FilesMatch "^\.ht">
Order allow,deny
Deny from all
</FilesMatch>
AddHandler         cgi-script .cgi
<IfModule mod_negotiation>
<IfModule mod_include>
Alias /errors/ "/xampp/xampp/htdocs/blog/errors/"
<Directory "/xampp/xampp/htdocs/blog/errors">
AllowOverride None
Options IncludesNoExec
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority pt
</Directory>
</IfModule>
</IfModule>
ErrorDocument 400 /errors/400.html
ErrorDocument 401 /errors/401.html
ErrorDocument 403 /errors/403.html
ErrorDocument 404 /errors/404.html
ErrorDocument 405 /errors/405.html
ErrorDocument 408 /errors/408.html
ErrorDocument 410 /errors/410.html
ErrorDocument 411 /errors/411.html
ErrorDocument 412 /errors/412.html
ErrorDocument 413 /errors/413.html
ErrorDocument 414 /errors/414.html
ErrorDocument 415 /errors/415.html
ErrorDocument 500 /errors/500.html
ErrorDocument 501 /errors/501.html
ErrorDocument 502 /errors/502.html
ErrorDocument 503 /errors/503.html
ErrorDocument 506 /errors/506.html
</VirtualHost>


httpd.conf

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>


hosts

Code: Select all
127.0.0.1       localhost
192.168.1.2   localhost
127.0.0.1   forumisvouga.org
127.0.0.1   blog


I guess everything should work fine and it did but when I added my second site people can't access the sites. They're redirected to xampp panel.
I use dyndns updater because I have a dynamic IP and added both sites.
Could you please help me?
And by the way I have a router and two pcs connected and my second pc can't access the site too is that normal?

My sites should be working on:

http://forumisvouga.dyndns.org
http://blogsemnexo.dyndns.org

Thank you.
Corvisier
 
Posts: 9
Joined: 24. September 2006 05:32

Postby Izzy » 18. October 2006 04:51

At a command prompt in xampp/apache/bin issue this:
apache -S
for the vhosts file

and
apache -t
for the httpd.conf file

Check for any errors.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Corvisier » 18. October 2006 05:18

Thank you for your fast reply and help.

apache - S:

Code: Select all
[Wed Oct 18 05:12:10 2006] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
[Wed Oct 18 05:12:10 2006] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   localhost (F:/xampp/xampp/apache/conf/extra/httpd-vhosts.
conf:20)
*:80                   forumisvouga.org (F:/xampp/xampp/apache/conf/extra/httpd-
vhosts.conf:26)
*:80                   blog (F:/xampp/xampp/apache/conf/extra/httpd-vhosts.conf:
97)
_default_:443          localhost (F:/xampp/xampp/apache/conf/extra/httpd-ssl.con
f:74)
Syntax OK



apache -t

Code: Select all
[Wed Oct 18 05:13:04 2006] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
[Wed Oct 18 05:13:04 2006] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
Syntax OK


Sorry but I don't know how to solve this.
Thanks
Corvisier
 
Posts: 9
Joined: 24. September 2006 05:32

Postby Izzy » 18. October 2006 05:48

Try changing this around:
ServerName blog
ServerAdmin hept@netc.pt
ServerAlias blogsemnexo.pt.vu

To:
ServerName blogsemnexo.pt.vu
ServerAdmin hept@netc.pt
ServerAlias blog

Test it, not sure if that is your issue but looking at your host file it would appear you are overlapping as suggested in the warning messages.

Perhaps drop these from your host file also as a test.
127.0.0.1 forumisvouga.org
127.0.0.1 blog

Experiment with the above and see if it helps any.
As always backup conf files before editing and restart Apache after making changes to conf files.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Corvisier » 18. October 2006 05:58

Sorry I get the same error.
I'm totally blind here I don't understand anything of this
Glad I have you here to help me :)
Corvisier
 
Posts: 9
Joined: 24. September 2006 05:32

Postby Izzy » 18. October 2006 06:20

http://forumisvouga.pt.vu/
Is working from here and you are serving it with XAMPP via your DynDNS.
Asks for a user/pass

So what is this forumisvouga.org?
It does not resolve on the Internet and my guess is it is not even a registered domain name.

Change the first container to:
ServerName forumisvouga.pt.vu

You dont need a ServerAlias unless you have set one at DynDNS for www.forumisvouga.pt.vu if so then use it as an alias.

Or you could use:
ServerAlias forumisvouga.dyndns.org

Thats the first container.

Now the second container:
http://blogsemnexo.pt.vu
Redirects via DynDNS just fine from here and you are serving it with XAMPP also.
Asks for a user/pass

So change the second conatiner thus:
ServerName blogsemnexo.pt.vu

Same applies to the ServerAlias as in the first container.

Or you could use:
ServerAlias blogsemnexo.dyndns.org

Your sites are being servered by XAMPP because of the ServerAlias entry but should be served from the Internet using the ServerName entry.

Add what ever you like to the ServerAlias, perhaps for your local network of which I know absolutely nothing.

These don't go anywhere for me at the time of writing this post:
http://forumisvouga.dyndns.org
http://blogsemnexo.dyndns.org
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Corvisier » 18. October 2006 06:36

Thanks I did what you said above and i get the same error but if you can access it maybe it's not important.
I forgot to say that http://blogsemnexo.pt.vu and http://forumisvouga.pt.vu are URL redirects. Is there any trouble in that?
I just have registered with dyndns and nothing more....
I'm really sorry for the trouble I'm causing and I wanna thank you for your help and patiente.

Thanks
Corvisier
 
Posts: 9
Joined: 24. September 2006 05:32

Postby Izzy » 18. October 2006 06:45

You are not a bother or any trouble at all.

If you still get the same warnings then it must be your network or your host file giving you issues as now all your addresses work from the Internet.

Thats all I can do for your external access as I am not a local network guru to advise on your local setup.

Good luck!
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Corvisier » 18. October 2006 06:47

Ok Izzy glad to have your help.
Thanks for everything.
Corvisier
 
Posts: 9
Joined: 24. September 2006 05:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests