Problem with XAMPP 1.54a

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with XAMPP 1.54a

Postby underdone » 17. October 2006 21:02

First, i'd like to say that i'm brand new at setting up xampp.

The website was working fine before i upgraded to winxp x64 edition from the x86 edition. What its doing is when you go to the website it loads either blank page or says the server is not responding, but if you hit the refresh button 2 or 3 times it loads the site, and it works fine for a while or until you close the browser window. Using a different browser causes the same effect. I do not have a firewall on my computer, and my router is set to forward the correct port ranges to my computer. The routers settings did not change when i reinstalled windows. I also did not change any settings after the reinstall.

I'm not sure if this could be causing the problem but to keep the files and settings from the old setup i just copied the xampp folder and pasted it over the old one. I know this is probably not a good idea but i could not find and documentation on what files need to be backed up.

Here's the website so you can see what i am talking about.

http://www.rainender.com

Help much appreciated.

edit: I forgot to mention that these problems happen if i use localhost:80 or just localhost to get to the site. And it also effects the configuration pages withing xampp and phpmyadmin.
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Re: Problem with XAMPP 1.54a

Postby Izzy » 18. October 2006 00:20

underdone wrote:...I'm not sure if this could be causing the problem but to keep the files and settings from the old setup i just copied the xampp folder and pasted it over the old one. I know this is probably not a good idea but i could not find and documentation on what files need to be backed up.

[Rant]Documentation for the XAMPP project is abysmal to say the least especially for users who have not much experience with such things. Much is taken for granted that you at least know as much as the developers about all things XAMPP. ;)[/Rant]

However, what version did you overwrite with 1.5.4a?
It could make a difference as some versions just won't update that way and need a fresh install.

If you feel your current installation is corrupt in some way then rename you current XAMPP installation directory.
Then reinstall 1.5.4a to the same named directory structure as your previous installation.
Copy over your web content from the old renamed directory structure.
Now check that your localhost and your web access work.
If not, I suspect your web access won't work, you will need to make those changes to your conf files you had in the old version - don't overwrite the conf files again but edit the conf files in the usuall way - backup the original before editing so you have a revertable working file and restart Apache after every change made to check you changes will allow Apache to restart.

Your databases are stored in the xampp\mysql\data directory.
Or do a a database export to an sql file so you can import them again into the new installation.

A bit messy but it's the only way to be sure you didn't mess up by overwriting.

When your new installation is up and working as you expect then you can delete the renamed XAMPP installation.

Before doing any of the above try and fix your CSS errors which may be affecting your page loading. See below.

underdone wrote:Here's the website so you can see what i am talking about.

http://www.rainender.com

Help much appreciated.

edit: I forgot to mention that these problems happen if i use localhost:80 or just localhost to get to the site. And it also effects the configuration pages withing xampp and phpmyadmin.


The page loads, albeit very slowly, from here.

You do have a few issues with your CSSheets and also the validation links at the bottom of your page are invalid.
You can check your CSS by visiting this link and typing in your main url you posted above:
http://jigsaw.w3.org/css-validator/

You should also try and reduce the size of your images for the web.
For example this image is far too big in size of the file:
http://www.rainender.com/wp-content/upl ... h-crew.png
It is 352 KB - should be no larger than say 25 KB
The physical size 560px wide by 300px high is fine just reduce the KB of the file. Most graphic editing software can do this when you save the file for the web.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby underdone » 18. October 2006 00:53

[Rant]Documentation for the XAMPP project is abysmal to say the least especially for users who have not much experience with such things. Much is taken for granted that you at least know as much as the developers about all things XAMPP. Wink[/Rant]


I absolutely with you there, i was getting confused by the intro pages. Let alone the htacess page.

However, what version did you overwrite with 1.5.4a?
It could make a difference as some versions just won't update that way and need a fresh install.


I overwrote the 1.5.4 version, but this was before i switched os's. And it worked fine then, so i got rid of the backup i made of the old install folder and made a new one with the 1.5.4a install files.

I have tried to reinstall it like you said, but i have been unable to determine which files need to be copied to preserve settings and files.

Before doing any of the above try and fix your CSS errors which may be affecting your page loading. See below.


Well, i'm not the one who coded the website, but i'll make sure to pass that message along. But i wouldn't doubt that the CSS errors could be causing it. And, i'll try to take care of the huge images too.

What browser were you using? i have tried Firefox 1.5.0.7, and internet explorer 32bit and 64bit they all get same problem at random intervals.

Thanks for the help

edit: misplaced quote
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby underdone » 18. October 2006 01:00

I forgot to mention something. On the winxp x64 edition all 32bit programs are supposed to install in the program files(x86) directory, but for some reason xampp continues to default to the program files directory. This is supposed to be reserved for 64bit apps only. But the program runs fine without any errors that i have seen.
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby Izzy » 18. October 2006 01:26

underdone wrote:...What browser were you using? i have tried Firefox 1.5.0.7, and internet explorer 32bit and 64bit they all get same problem at random intervals...

I used:
IE (always painful to use)
Firefox
Opera 9
SeaMonkey
All load slow, especially the images (some are random which will slow down things if the image changes during loading the first image), but it may also have something to do with you being on a Uni network.

It's obvious that the server is working correctly or I wouldn't get any pages in my browsers and I would get an error messages anyway.

You will need to look at the code of the site and do some house keeping.
Check the conf files are correct in your xampp\apache\conf directories
Check your databases for errors using phpMyAdmin.

This url shows your server is up and running just fine:
http://70.84.211.98/co/DomainDossier.aspx
type rainender.com in the text box and tick the boxes you want to check.

Not much more I can suggest really not being sat in front of your PC.

Good luck with it!

underdone wrote:I forgot to mention something. On the winxp x64 edition all 32bit programs are supposed to install in the program files(x86) directory, but for some reason xampp continues to default to the program files directory. This is supposed to be reserved for 64bit apps only. But the program runs fine without any errors that i have seen.

Then thats OK I assume.
If you wanted to change the directory that XAMPP installed to then you can move it and run the setup-xampp.bat in the new location to change the paths in XAMPP.
http://www.apachefriends.org/en/faq-xam ... ml#mvxampp

Another method is to use the 7Zip installation method then you can choose your own install path - gives much more control, even into future upgrading, IMHO.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby underdone » 18. October 2006 01:53

I was looking around in the log files, and in apache's error log i found this.

[Tue Oct 17 18:47:14 2006] [warn] (OS 996)Overlapped I/O event is not in a signaled state. : winnt_accept: Asynchronous AcceptEx failed.
[Tue Oct 17 18:47:17 2006] [warn] (OS 996)Overlapped I/O event is not in a signaled state. : winnt_accept: Asynchronous AcceptEx failed.
[Tue Oct 17 18:47:24 2006] [warn] (OS 996)Overlapped I/O event is not in a signaled state. : winnt_accept: Asynchronous AcceptEx failed.
[Tue Oct 17 18:47:30 2006] [warn] (OS 996)Overlapped I/O event is not in a signaled state. : winnt_accept: Asynchronous AcceptEx failed.

[new_snode] Warning: String exceeds storage size
[new_snode] Warning: String exceeds storage size
[new_snode] Warning: String exceeds storage size


It seems to repeat almost constantly until i get towards the begining of the log.
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby Izzy » 18. October 2006 02:12

underdone wrote:...[warn] (OS 996)Overlapped I/O event is not in a signaled state. : winnt_accept: Asynchronous AcceptEx failed.
[new_snode] Warning: String exceeds storage size


Add this as the last line in xampp\apache\conf\httpd.conf
Win32DisableAcceptEx
May fix the (OS 996) error.
Save and restart Apache - backup the conf file first before editing of course.

This warning [new_snode] Warning: String exceeds storage size
seems it may be a Webalizer issue and may be related to the sometimes huge URLs that are generated by such scripts as WordPress.
Not sure how to change this behaviour in WP (Permalinks perhaps) but on some of these php generated sites the use of mod_rewrite to create simple URLs (search engine friendly) is configurable. Perhaps the WP forums can throw some light on this and even possibly this error message. Doing a WP forum search for mod_rewrite comes up with various posts on the subject.

I did a Google using the whole error warning:
[new_snode] Warning: String exceeds storage size
which gave some interesting results.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby underdone » 18. October 2006 05:11

Adding Win32DisableAcceptEx to my htaccess file stopped all of the errors and the weird loading problems. And then for the other problem, you were right its related to webalizer, and on the website it just said to turn the error reporting off. So i did that and everything seems to be working fine.

Where did you find the Win32DisableAcceptEx idea? Hopefully i can figure the next problem on my own. 8)
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby Izzy » 18. October 2006 05:32

underdone wrote:Where did you find the Win32DisableAcceptEx idea? Hopefully i can figure the next problem on my own. 8)

Your error message was telling you the problem.
The Apache manual has the asnswer:
http://httpd.apache.org/docs/2.2/mod/directives.html

http://httpd.apache.org/docs/2.2/mod/mp ... leacceptex

I was going to suggest putting this directive in the /extra/httpd-wpm.conf file which is where it should go but in the httpd.conf file is also OK and of course in a .htaccess file has the same effect but only on the directory and subdirectories it is contained in. So if you want that directive to perform on a global server basis then it should be included in either of the .conf files I mentioned.

The httpd configure file structure is thus:
Global
httpd.conf
\extra\*.conf overrides the defaults or adds directives not included in the httpd.conf

Directory tree specific:
.htaccess - included directives override all global .conf files for a specific directory structure only.

In your case the .htaccess is only effective for your WP installation.

Good out come all round and I am pleased it is now working as it should.
Good luck!
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wiedmann » 18. October 2006 12:14

Adding Win32DisableAcceptEx to my htaccess file stopped all of the errors and the weird loading problems

That's curious, because Win32DisableAcceptEx is not allowed in a .htaccess. Every access to a file inside this directory, should now result in an error 500.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby underdone » 19. October 2006 00:34

The Apache manual has the asnswer
I guess that's what i get for giving up on their help files.

I cannot find /extra/httpd-wpm.conf however i did find a /extra/httpd-mpm.conf Is that the correct one?

Adding Win32DisableAcceptEx to my htaccess file stopped all of the errors and the weird loading problems
That's curious, because Win32DisableAcceptEx is not allowed in a .htaccess. Every access to a file inside this directory, should now result in an error 500.


My bad, i meant the httpd.conf not .htaccess
User avatar
underdone
 
Posts: 34
Joined: 15. October 2006 04:56
Location: Albuquerque, NM

Postby Izzy » 19. October 2006 00:50

underdone wrote:...I cannot find /extra/httpd-wpm.conf however i did find a /extra/httpd-mpm.conf Is that the correct one?

My bad, i meant the httpd.conf not .htaccess

My typo, I meant /extra/httpd-mpm.conf

It was obvious to me that you meant httpd.conf not .htaccess as you would have not been successful using the .htaccess. This is outlined in the documentation that .htaccess is not used for this directive:
Win32DisableAcceptEx Directive
Description: Use accept() rather than AcceptEx() to accept network connections
Syntax: Win32DisableAcceptEx
Default: AcceptEx() is enabled by default. Use this directive to disable use of AcceptEx()
Context: server config
Status: MPM
Module: mpm_winnt
Compatibility: Available in Version 2.0.49 and later
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests