XAMMP Setup - Serious error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMMP Setup - Serious error

Postby SimonR » 15. October 2006 23:33

Hey all, I came across a link to XAMMP earlier today, and decided to take it for a spin. The installation went smoothly, but when I try to get to http://localhost in Firefox, nothing turns up. Just a blank page, which I'm assuming isn't what I should be seeing.

I can see an 'index.php' in the xammp folder, and when I try to access it directly (http://localhost/index.php) it asks me to download it, which I can only assume means Apache isn't running. I've attempted starting Apache through the xammp control panel, and despite any glaring errors, I'm still getting the blank page. However, I'm very much a novice at all this, and would appreciate some pointers on what to do next. Thanks for your help :D
SimonR
 
Posts: 4
Joined: 15. October 2006 23:18

Postby Sean-Michael » 16. October 2006 00:22

On the task bar right click and select task manager, in the processes tab do you see an entry for apache.exe? If so then there might be a firewall issue, if not did you run the setup_xampp.bat. What happens if you try to use the apache_start.bat, do you see and entry for apache now?
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby SimonR » 16. October 2006 00:40

I've checked, and I can't see an entry for apache.exe. However, I tried reinstalling xammp, and got an error when it attempted to install Apache. It said "Port 80 Blocked. Apache Install Failed", or something very similar. This seems pretty odd - I don't remember ever blocking any ports. :lol:

But yeah, I'm assuming if this is stopping xammp installing Apache, then that's the main reason behind my problem. Any ideas? Perhaps I could change the port Apache installs on?
SimonR
 
Posts: 4
Joined: 15. October 2006 23:18

Postby Izzy » 16. October 2006 00:40

Do a port check first to see if there is a conflict.
xampp\xampp-portcheck.exe
The result should be all ports free.

Things like Skype and IIS will be trying to compete with the ports that Apache (XAMPP) uses. You then need to remove the offenders before trying to start the XAMPP modules.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby SimonR » 16. October 2006 08:50

Wow, spot on Izzy. I don't have IIS, but I went ahead and uninstalled Skype, and now installing xammp is error-free. Everything seems to be working fine, I can get the localhost page up and everything. Great stuff, thanks!

However, I use Skype on quite a regular basis. If I reinstall Skype, will it block up Port 80 again, or will it just put itself on a different port?
SimonR
 
Posts: 4
Joined: 15. October 2006 23:18

Postby Izzy » 16. October 2006 08:54

SimonR wrote:Wow, spot on Izzy. I don't have IIS, but I went ahead and uninstalled Skype, and now installing xammp is error-free. Everything seems to be working fine, I can get the localhost page up and everything. Great stuff, thanks!

However, I use Skype on quite a regular basis. If I reinstall Skype, will it block up Port 80 again, or will it just put itself on a different port?

Skype uses port 80 and 443 by default.
You can alter that behaviour by going to:
Tools\Options\Connection
Untick
Use port 80 and 443 as alternative for incoming connections
You will have to decide a different port to use for incoming connections before Skype lets you save your changes.

With Skype using these incomming ports you become a supernode:
Basically you relay others calls, and messages.
Look here for more:
http://forum.skype.com/viewtopic.php?t= ... =supernode

Info from this thread:
http://forum.skype.com/lofiversion/inde ... 51147.html

Quote from this site:
http://en.wikipedia.org/wiki/Skype
wikipedia wrote:The use of end-user bandwidth in the form of supernodes, the use of closed source software in general, the use of closed source software for encryption of network traffic in particular as well as security of the software, have caused concern among open source advocates. Independent analyses of the software have addressed the latter to some degree.

And with Skype you really don't have a choice to not be a supernode.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby SimonR » 16. October 2006 22:45

Brilliant, thanks again Izzy. I followed your instructions, and now xammp and Skype are co-existing peacefully. Great work :)
SimonR
 
Posts: 4
Joined: 15. October 2006 23:18


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests