DocumentRoot not being set in versions 1.5.4 and 1.5.4a

Problems with the Windows version of XAMPP, questions, comments, and anything related.

DocumentRoot not being set in versions 1.5.4 and 1.5.4a

Postby Buckbeak » 12. October 2006 20:12

When I try to start Apache with xampp-control.exe or with apache_start.bat, apache doesn't start. This is the message that appears:

Apache 2 is starting ...
apache.exe: Syntax error on line 42 of C:/Documents and Settings/xxxxx/My Documents/downloads/XAMPP Lite 1.5.4a/xampplite/apache/conf/httpd.conf: ServerRoot must be a valid directory

Looking in the httpd.conf file, DocumentRoot looks like this:
Code: Select all
DocumentRoot "/xampplite/htdocs"


Version 1.5.1 starts fine. It's DocumentRoot looks like this:
Code: Select all
DocumentRoot "C:/Documents and Settings/xxxxxx/My Documents/downloads/XAMPP Lite 1.5.1/xampplite/htdocs"
Buckbeak
 
Posts: 2
Joined: 12. October 2006 19:31

Postby Sean-Michael » 12. October 2006 20:32

Did you run "setup_xampp.bat"? Its my understanding this updates such values.
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby Buckbeak » 12. October 2006 21:07

Doh! You're right. I feel so stupid.... :oops:
Buckbeak
 
Posts: 2
Joined: 12. October 2006 19:31

Postby Sean-Michael » 12. October 2006 22:49

I wouldn't feel bad, I had the same problem a little while ago when I moved Xampp to another partition, I was stuck till I went threw the instructions again , when I saw your post it sounded close.

Glad I was able to help.
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests