Skin and style problem!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Skin and style problem!

Postby Squee » 12. October 2006 18:59

Hello i have a problem with skins and style at my homepage....i have an html that is made with skin and style but when i try to view it on the web it doesnt have skin or style...
And yes i tried editing httpd with Win32DisableAcceptEx and restarting the apache server.
thanks in advence.
Squee.
Squee
 
Posts: 3
Joined: 12. October 2006 18:39

Postby Sean-Michael » 12. October 2006 19:05

I might be able to help but is there a link to check the html? Unless your sure it is correct.
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby Squee » 12. October 2006 19:20

The html is correct...
http://fatallist.servegame.com/ is the website if you want to see whats the issue with your own eyes.
Squee
 
Posts: 3
Joined: 12. October 2006 18:39

Postby Sean-Michael » 12. October 2006 19:28

Well, one thing I notice is that the linked style sheet reads like so...

"<link rel="stylesheet" href="../../../Documents and Settings/Squee/Desktop/Grassy/style.css" type="text/css" />"

Mine looks like this...

"<link rel="stylesheet" href="css/index.css" type="text/css" />"

Unless your web content folder is your entire hard drive this could be a problem... some times programs like Nvu uses links like this instead of relative links like mine, I use cssed for my style sheets and notepad++ for xhtml php editing.

Maybe I'm way off but I got this info from your "DesiKal.html" page.
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby Sean-Michael » 12. October 2006 19:33

With a lil more looking I think your link should look like this...

<link rel="stylesheet" href="style.css" type="text/css" /> :D
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby Wiedmann » 12. October 2006 19:33

http://fatallist.servegame.com/ is the website

Sorry, but there is no "website". Only a directory listing (mod_autoindex) which list the files in that directory.

Well, one thing I notice is that the linked style sheet reads like so...

"<link rel="stylesheet" href="../../../Documents and Settings/Squee/Desktop/Grassy/style.css" type="text/css" />"

That's wrong. Please read a HTML documentation about (relative) links.
--> you must use URIs in your links, which are accessible via a webserver, an not (realtive) filesystem paths.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sean-Michael » 12. October 2006 19:39

Yes, after reading Wiedmanns post you would want your home page to be titled something like...

index.html
or
index.php

and name the page title what you want like "DesiKal" or "Home" a good place to learn html or php or even css is w3schools...

http://www.w3schools.com/default.asp
Sean-Michael
 
Posts: 69
Joined: 17. September 2006 01:37

Postby Squee » 12. October 2006 19:40

Fixed it :D
Squee
 
Posts: 3
Joined: 12. October 2006 18:39


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests