Windows error OS 10048 when starting apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Windows error OS 10048 when starting apache

Postby oldguy » 12. October 2006 07:41

Just installed the latest XP updates from MS. Rebooted and the apache service didn't start and wouldn't manually start.

Uninstalled the service and tried reinstalling. I get this eror:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs

Anything I can do besides back out the XP updates?
oldguy
 
Posts: 10
Joined: 19. March 2006 08:39
Location: Portland, Oregon USA

Re: Windows error OS 10048 when starting apache

Postby Izzy » 12. October 2006 07:49

oldguy wrote:Just installed the latest XP updates from MS. Rebooted and the apache service didn't start and wouldn't manually start.

Uninstalled the service and tried reinstalling. I get this eror:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs

Anything I can do besides back out the XP updates?

No need to back out of the updates at the moment.

The error message relates to another instance on port 80 other than the one your are trying to start.
Check using xampp-portcheck.exe to see if it gives you any clues.

Post back with anything it might reveal that is not clear or there is nothing showing that is amiss.

We can look at other things to do depending on what you post back with on the port check.
Last edited by Izzy on 12. October 2006 08:19, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby oldguy » 12. October 2006 08:18

First, I uninstalled the XP updates and that made no difference. Error is still there.

Port check shows:
Apache (http) port 80 status: skype.exe

What's going on here? I've had skype installed for ages and not had a conflict before. ????
oldguy
 
Posts: 10
Joined: 19. March 2006 08:39
Location: Portland, Oregon USA

Postby Izzy » 12. October 2006 08:21

Skype uses port 80 by default.
You can close them by going to Tools>Options>Connection>(Untick) use port 80 and 443.

With Skype using these port you may become a supernode:
Basically you relay calls, and messages. Look here for more: http://forum.skype.com/viewtopic.php?t= ... =supernode

Info from this thread:
http://forum.skype.com/lofiversion/inde ... 51147.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby oldguy » 12. October 2006 09:02

Thanks, that solved the Apache problem. It's now working fine. I must have unchecked that a long time ago. But last week I had to reinstall the OS and all applications from scratch...the life of a Windows user :(

But...

Somewhere along the line I screwed up mysql. I can run it using the mysql_start.bat file but not as a service. It installs as a service but gives error 1067 when trying to start the service. Any ideas?
oldguy
 
Posts: 10
Joined: 19. March 2006 08:39
Location: Portland, Oregon USA

Postby Izzy » 12. October 2006 09:14

This has been known to fix it:

Exit the XAMPP Control Panel
Open a command prompt click on start/run.../cmd.exe
Type sc delete mysql
Open the Control Panel again and try and start the MySQL as a service again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby oldguy » 12. October 2006 09:30

Nope. That didn't fix it.

Also, nothing is showing in the mysal error file.

Also, searching the web hasn't provided anything useful.
oldguy
 
Posts: 10
Joined: 19. March 2006 08:39
Location: Portland, Oregon USA

Postby Izzy » 12. October 2006 09:38

Using the following bat files what error messages are you getting if any?
xampp\mysql\mysql_uninstallservice.bat
and
xampp\mysql\mysql_installservice.bat

Is there an instance of mysql running in the Processes tab?
Ctrl-Alt-Delete - Processes
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby oldguy » 12. October 2006 10:01

Nevermind..... :oops: When I reinstalled xampp I didn't set the paths in my.cnf. It's working now.

Thank you very much for your help Izzy. If you ever visit Oregon it's my treat at the local brew pub.
oldguy
 
Posts: 10
Joined: 19. March 2006 08:39
Location: Portland, Oregon USA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests