VirtualHost not work

Problems with the Windows version of XAMPP, questions, comments, and anything related.

VirtualHost not work

Postby raydan » 08. October 2006 13:53

my computer has 1 external ip such as 203.200.200.200

i register 1 no-ip , test.no-ip.org

now, i want do that

other people can not see any think when they type 203.200.200.200
they can see my website when they are ONLY use test.no-ip.org
they can not use test2.no-ip.org... or other domain to view my web site, how can i do that?

so i add the following in httpd-vhosts.conf

NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot D:/
ServerName test.no-ip.org
<Directory "D:/">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


in httpd.conf
DocumentRoot "D:/xampp/htdocs/"
raydan
 
Posts: 2
Joined: 08. October 2006 13:41

Postby Izzy » 08. October 2006 22:38

raydan wrote:so i add the following in httpd-vhosts.conf

NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot D:/
ServerName test.no-ip.org
<Directory "D:/">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Try this and see if it makes any difference:

Code: Select all
<VirtualHost 127.0.0.1:80>
ServerName localhost
DocumentRoot "D:/xampp/htdocs"
</VirtualHost>

NameVirtualHost *:80

<VirtualHost *:80>
ServerName test.no-ip.org
DocumentRoot "D:/"
<Directory "D:/">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerName test2.no-ip.org
DocumentRoot "D:/test2"
<Directory "D:/test2">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Put an index.html or index.php in the D:/test2 directory. Create the subdoamin test2.no-ip.org at no-ip before adding the second virtualhost container for test2.no-ip.org.

Entering IP 83.241.168.69 in your browser will resolve to your default domain test.no-ip.org only.

Save the httpd-vhosts.conf file then restart your Apache server.

I can't connect to http://test.no-ip.org or your IP 83.241.168.69 in Sweden from my browser using the Internet.
Are your ports configured correctly in your network router?
Last edited by Izzy on 09. October 2006 04:03, edited 2 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby raydan » 09. October 2006 02:47

i want enter 203.200.200.200 it can not see anything

ONLY enter test.no-ip.org can visit the web site
raydan
 
Posts: 2
Joined: 08. October 2006 13:41

Postby Izzy » 09. October 2006 03:39

Your unable to be helped because you can't read and so you have been added to my ignore list.

You will have to RTFM instead of wingeing in here like a spoiled child. I have no inclination to help anyone with an attitude.

http://httpd.apache.org/docs/2.2/vhosts/examples.html

http://httpd.apache.org/docs/2.2/mod/core.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests