Kaspersky

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Kaspersky

Postby StaticX » 27. September 2006 01:18

Hi everyone,

I have Kaspersky Internet Security and I got a problem with Apache in XAMPP.

Everytime that one friend of mine tries to connect in my server appears the next message:
"The page cannot be displayed..."

I have tried to add httpd.exe and change Preset to Allow All in settings of Anti-Hacker but it doesn't work... :\

Somebody helps me, please?

Thanks.
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 01:26

What does the xampp\apache\logs\error.log tell you just after your friend tries to connect - check the entries by date and time?

I don't know anything about Kaspersky. Is there a configuration to allow traffic on the ports that XAMPP uses?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby StaticX » 27. September 2006 01:32

In my file error.log appears:


[Tue Sep 26 18:47:50 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Sep 26 18:47:50 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Sep 26 18:47:51 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Sep 26 18:47:51 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Sep 26 18:47:53 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Sep 26 18:47:53 2006] [notice] Server built: Aug 13 2006 19:16:43
[Tue Sep 26 18:47:53 2006] [notice] Parent: Created child process 752
[Tue Sep 26 18:47:55 2006] [notice] Child 752: Child process is running
[Tue Sep 26 18:47:55 2006] [notice] Child 752: Acquired the start mutex.
[Tue Sep 26 18:47:55 2006] [notice] Child 752: Starting 250 worker threads.
[Tue Sep 26 18:47:55 2006] [notice] Child 752: Starting thread to listen on port 443.
[Tue Sep 26 18:47:55 2006] [notice] Child 752: Starting thread to listen on port 80.
[Tue Sep 26 18:48:15 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Sep 26 18:48:15 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Sep 26 18:48:19 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Sep 26 18:48:19 2006] [notice] Server built: Aug 13 2006 19:16:43
[Tue Sep 26 18:48:19 2006] [notice] Parent: Created child process 3888
[Tue Sep 26 18:48:21 2006] [notice] Child 3888: Child process is running
[Tue Sep 26 18:48:21 2006] [notice] Child 3888: Acquired the start mutex.
[Tue Sep 26 18:48:21 2006] [notice] Child 3888: Starting 250 worker threads.
[Tue Sep 26 18:48:21 2006] [notice] Child 3888: Starting thread to listen on port 443.
[Tue Sep 26 18:48:21 2006] [notice] Child 3888: Starting thread to listen on port 80.
[Tue Sep 26 19:00:37 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Sep 26 19:00:37 2006] [notice] Server built: Aug 13 2006 19:16:43
[Tue Sep 26 19:00:37 2006] [notice] Parent: Created child process 2120
[Tue Sep 26 19:00:38 2006] [notice] Child 2120: Child process is running
[Tue Sep 26 19:00:38 2006] [notice] Child 2120: Acquired the start mutex.
[Tue Sep 26 19:00:38 2006] [notice] Child 2120: Starting 250 worker threads.
[Tue Sep 26 19:00:38 2006] [notice] Child 2120: Starting thread to listen on port 443.
[Tue Sep 26 19:00:38 2006] [notice] Child 2120: Starting thread to listen on port 80.
[Tue Sep 26 21:12:26 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Sep 26 21:12:27 2006] [notice] Child 2120: Exit event signaled. Child process is ending.
[Tue Sep 26 21:12:28 2006] [notice] Child 2120: Released the start mutex
[Tue Sep 26 21:12:30 2006] [notice] Child 2120: Waiting for 250 worker threads to exit.
[Tue Sep 26 21:12:31 2006] [notice] Child 2120: All worker threads have exited.
[Tue Sep 26 21:12:32 2006] [notice] Child 2120: Child process is exiting
[Tue Sep 26 21:12:40 2006] [notice] Parent: Child process exited successfully.
[Tue Sep 26 21:12:57 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Sep 26 21:12:57 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Sep 26 21:13:06 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Sep 26 21:13:06 2006] [notice] Server built: Aug 13 2006 19:16:43
[Tue Sep 26 21:13:06 2006] [notice] Parent: Created child process 3008
[Tue Sep 26 21:13:08 2006] [notice] Child 3008: Child process is running
[Tue Sep 26 21:13:08 2006] [notice] Child 3008: Acquired the start mutex.
[Tue Sep 26 21:13:08 2006] [notice] Child 3008: Starting 250 worker threads.
[Tue Sep 26 21:13:08 2006] [notice] Child 3008: Starting thread to listen on port 443.
[Tue Sep 26 21:13:08 2006] [notice] Child 3008: Starting thread to listen on port 80.
[Tue Sep 26 22:13:36 2006] [error] [client 127.0.0.1] File does not exist: H:/XAMPP/xampp/htdocs/CFIDE
[Tue Sep 26 23:48:42 2006] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8c mod_autoindex_color PHP/5.1.6 configured -- resuming normal operations
[Tue Sep 26 23:48:42 2006] [notice] Server built: Aug 13 2006 19:16:43
[Tue Sep 26 23:48:42 2006] [notice] Parent: Created child process 2248
[Tue Sep 26 23:48:44 2006] [notice] Child 2248: Child process is running
[Tue Sep 26 23:48:45 2006] [notice] Child 2248: Acquired the start mutex.
[Tue Sep 26 23:48:45 2006] [notice] Child 2248: Starting 250 worker threads.
[Tue Sep 26 23:48:45 2006] [notice] Child 2248: Starting thread to listen on port 443.
[Tue Sep 26 23:48:45 2006] [notice] Child 2248: Starting thread to listen on port 80.

My friend has try to connect at 21:12
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 01:35

[Tue Sep 26 22:13:36 2006] [error] [client 127.0.0.1] File does not exist: H:/XAMPP/xampp/htdocs/CFIDE

Here is your problem and needs fixing.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby StaticX » 27. September 2006 01:41

Can you send the file, please?

Thanks
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 01:53

StaticX wrote:Can you send the file, please?

Thanks

I don't understand you. Send what file?

This is your problem to fix either in your path in the httpd.conf file or you have not put an index file in the H:/XAMPP/xampp/htdocs/CFIDE directory.

There is nothing anyone can do for you, you have to fix it yourself on your PC.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby StaticX » 27. September 2006 02:38

H:/XAMPP/xampp/htdocs/CFIDE

I don't have this directory.

Look:
Image

If I open index.php appears:
Code
"Something is wrong with the XAMPP installation :-( "
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 02:47

Have you changed anything in the xampp/apache/conf/httpd.conf file or any of the files in the xampp/apache/conf/extra directory?

I might be quicker if either you paste the httpd.conf file here or issue this command using the command console in the xampp/apache/bin directory:
apache -t

Clcik on Start
Click on Run...
Type cmd.exe
Type CD H:\xampp\xampp\apache\bin (if that is the path - change it to your actual path if needed)
You should now be in the bin directory
Type apache -t

Paste the results here.


Can you access the XAMPP Welcome Page in your browser?
http://localhost
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby StaticX » 27. September 2006 03:01

Izzy wrote:Have you changed anything in the xampp/apache/conf/httpd.conf file or any of the files in the xampp/apache/conf/extra directory?

No, I don't change anything.

Izzy wrote:I might be quicker if either you paste the httpd.conf file here

Download here my file httpd.conf

Izzy wrote:or issue this command using the command console in the xampp/apache/bin directory:
apache -t

Clcik on Start
Click on Run...
Type cmd.exe
Type CD H:\xampp\xampp\apache\bin (if that is the path - change it to your actual path if needed)
You should now be in the bin directory
Type apache -t

Paste the results here.


Image

Izzy wrote:Can you access the XAMPP Welcome Page in your browser?
http://localhost


Yeap, and it works fine!!
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 03:11

Your httpd.conf file looks OK.

Now, how is your friend trying to access your website?

What addresss does he type in his browser that gives you the error?

Where is your website located within the htdocs tree?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby StaticX » 27. September 2006 03:28

My adress is: http://staticx.no-ip.org/

My website is located in htdocs ( I change the index of xampp to my index ).

I don't know what's going on with this s*** :|
Image
StaticX
 
Posts: 8
Joined: 27. September 2006 00:41
Location: Portugal

Postby Izzy » 27. September 2006 03:40

StaticX wrote:My adress is: http://staticx.no-ip.org/

My website is located in htdocs ( I change the index of xampp to my index ).

I don't know what's going on with this s*** :|


I can't access your web site from the Internet. I also checked it from here:
http://70.84.211.98/co/DomainDossier.aspx
Code: Select all
Service scan
FTP - 21   Error: TimedOut
SMTP - 25   Error: ConnectionRefused
HTTP - 80   Error: TimedOut
POP3 - 110   Error: ConnectionRefused
IMAP - 143   Error: ConnectionRefused


So my conclusion is either a firewall/router on your PC is blocking access or the Apache server is not running.
Ctrl-Alt-Delete
Click on the Processes tab and look for 2 instances of apache.exe

Use the XAMPP Control Panel and set it up to run all modules as a service then reboot your PC so they start automatically.

Anything else and you will have to figure out this s*** for yourself. I don't like your attitude.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests