very sorry. session problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

very sorry. session problem

Postby hleb » 24. September 2006 11:12

Hi to All.In advance please verry sorry this is my first post here and I read this in XAMPP home page
"One small word of warning: Nearly everything in our forum is German but there's an "Apache Friends in English" section as well. Most German people will understand you and will be more or less able to answer in English. "
Isimly no understand anything from german language but if anyone can suport me pls take that.
Where i the problem?SESSIONs ;-/// Well thats is situation-I install corectly the last XAMPP distribution, adn run 3-4 scripts with sessions support, php create session in tmp folder BUT I cant get the session variabble ;-///// from examle- the simly login sysytem: I type my user and pass, script chek this with mysql return ok /if another situation "not valid username/password" I type to warn../ and after submit.. nothing ;-//// simply nothing the page is reaload and thats it...Please once again I- I try to search in forum for session support but I not fine anything for my problem.
Thanks in advance.
hleb
 
Posts: 2
Joined: 24. September 2006 11:05

Postby Wiedmann » 24. September 2006 16:02

BUT I cant get the session variabble

How did you do that (code)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hleb » 24. September 2006 16:16

Wiedmann wrote:
BUT I cant get the session variabble

How did you do that (code)?

I am not a sure but I think find the problem- simply I type no localhost or 127.0.0.1 but my real static ip adress and... done!!!I dont know where I can define the servername and apache properties for this- once again session generated correctly but I think the problem is in server adress may be- evry session is specific for evry server name/ip and may be this is the problem
hleb
 
Posts: 2
Joined: 24. September 2006 11:05

Postby hoergen » 12. January 2007 08:40

That has nothing to do with buggy code. There is a unhappy configuration in php.ini

Change the session.save_path to something like

Code: Select all
session.save_path = "0;600;C:\Temp


dem hoergen
hoergen
 
Posts: 11
Joined: 12. January 2007 08:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: ben.mansuk, JJ_Tagy and 61 guests