Just stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Just stopped working

Postby fogga » 20. September 2006 23:30

This is really strange, my server has stopped working. Everything was ok and I was playing around with Filezilla and now I cannot get access to my site via my dyndns hostname or IP address (localhost works).

Is the status page everything is "deactivated" apart from Filezilla and HTTPS (SSL). XAMPP control panel shows eveything as working.


Even manager is showing me the following errors:

The Apache service named reported the following error:
>>> Unable to open logs .


The Apache service named reported the following error:
>>> no listening sockets available, shutting down .

The Apache service named reported the following error:
>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 .
fogga
 
Posts: 16
Joined: 28. December 2005 15:10

Postby Izzy » 21. September 2006 00:44

Without knowing what you changed it may be impossible to help you.

Try do a clean uninstall of XAMPP and then do a clean install again. If you made any custom changes to conf file then do a backup of them and copy your changes back again after re-installing making sure each change you made has a correct syntax.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby fogga » 21. September 2006 00:50

no changes at all, and nothing else is using port 80.
fogga
 
Posts: 16
Joined: 28. December 2005 15:10

Postby Izzy » 21. September 2006 01:23

Something else must be using port 80. Thats what these error messages are telling you.
Even manager is showing me the following errors:

The Apache service named reported the following error:
>>> Unable to open logs .


The Apache service named reported the following error:
>>> no listening sockets available, shutting down .

The Apache service named reported the following error:
>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 .


Do you use Skype?

If so deactivate it and try to start Apache again.
You can change the port Skype uses from within the Skype configuration.

If not open up httpd.conf and change the port Apache listens on from 80 to 8080 for an example test to see if something else is indeed using port 80:

Find the line:
Listen 80
Change to:
Listen 8080

Save the httpd.conf file and restart Apache.

Changing the port means you have to add :8080 at the end of any url and you may have to change it at your dynamic DNS service for this test to work from the Internet.
http://localhost:8080
http://yoururl.con:8080
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby fogga » 21. September 2006 10:04

I've changed everything to port 8080 and still no joy. I've nothing else installed apart from XAMPP/DynDNS client.

There nothing bound to 80 apart from Apache, checked it again with CurrPorts.

Also if I ping blackdust.mine.nu it just times out. The DynDNS client says everything is fine.


I've just changed DynDNS providers to No-IP and I can ping my new address but still I cannot connect to the server.
fogga
 
Posts: 16
Joined: 28. December 2005 15:10

Postby Izzy » 21. September 2006 10:41

Can you please paste here the results of running:
xampp/xampp-portcheck.exe
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby fogga » 21. September 2006 11:11

I've tried to open xampp-portcheck.exe in command and by clicking on it but the cmd box just flashes up and doesn't stay open.


I think I may of found the problem, it's Vmware and not Apache. Vmware seemed to of changed my IP address and although I have forwarded ports in the VMware settings I still have no connection to my server.
fogga
 
Posts: 16
Joined: 28. December 2005 15:10

Postby Izzy » 21. September 2006 11:15

To get xampp-portcheck to work use a command prompt in the xampp directory, it will stay open then.

However give this a try.

There is a possibility that using the commands in the below posts and reading the explanations I dug out for them might solve your problem.
Worth a try as everything else has been exhausted.

The instructions here posted by Mod Weidmann:
http://community.apachefriends.org/f/viewtopi ... 1446#81446

My reply post here:
http://community.apachefriends.org/f/viewtopi ... 1449#81449
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby fogga » 21. September 2006 11:42

I've nailed it! When my IP address and gateway changed to one given by vmware I had to change my forwarded ports in my router from *.*.2.2 to my hosts lan IP.

Thanks for your help!
fogga
 
Posts: 16
Joined: 28. December 2005 15:10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests