xampp is working but when installing wordpress

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby Izzy » 21. October 2007 02:31

You have missing steps creating your wordpress database at item 6.

You don't have a database user with a password and privileges to access your wordpress database and is the reason the install is flopping

Open phpMyAdmin

Find and click on Privileges

Click on Add a new User

Enter the following (it can be changed by you later if you wish)

User name: wp

Host: localhost (To save typing select Local from the drop box)

Password: pw
(you can Generate a password and enter it here if you wish but for now I would keep it simple and use this example)

Re-type: pw

Click on Go bottom right of the page

You should be back at the Privileges page with a heading of:
User 'wp'@'localhost' : Edit Privileges

Find the section heading Database-specific privileges

From the drop menu select your database wordpress

The Privileges heading should now change to:
User 'wp'@'localhost' - Database wordpress : Edit Privileges

Find Database-specific privileges ( Check All / Uncheck All )
Click on Check All

Click on Go bottom right

You will now see at the top of the page an Information entry:
You have updated the privileges for 'wp'@'localhost'.

In the left menu frame click on the Home icon.

Locate and click on Privileges again to check that all is created as expected.

You should now see an entry for
User wp
Host localhost
Password Yes
Global Privileges USAGE
Grant No

Now you proceed to your item 7. and enter the credentials of your wp user in the wp-config.php.
Code: Select all
// ** MySQL settings ** //
define('DB_NAME', 'wordpress');    // The name of the database
define('DB_USER', 'wp');     // Your MySQL username
define('DB_PASSWORD', 'pw'); // ...and password (or what ever you used)
define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value


As I said previously it is not best practice to use your root access for scripts, this is a security risk and is reserved for you, the MySQL server administrator.

Using the above procedure you now know how easy it is to follow and to:
Create the database wordpress and create a user wp and give that user a password of pw with all privileges for the WordPress database using phpMyAdmin


This procedure applies also to any and all databases you create in phpMyAdmin.


With the above addition, now try and install WordPress from the beginning and see how it goes.

You can change the database user password by clicking on the Edit icon end of the row to the wp user under Privileges item and then re-editing the wp-config.php to reflect your changes.

I hope you can follow the above and it allows you to get WordPress up and running - now let the fun begin :)


===========================================
Take a look at the new DeskTopXampp launch control for XAMPP
and XAMPPlite (DTX.exe) posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967
Available at Ridgewood's new DTX web site http://zedfiles.com/DTX/
Also available here: http://nat32.com/dtx/
I highly recommend DTX.
============================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby skeezix » 21. October 2007 15:52

You have missing steps creating your wordpress database at item 6.

You don't have a database user with a password and privileges to access your wordpress database and is the reason the install is flopping


I forgot to mention that at the end of my Step 6 I received the following message:

Now you can log in with the username "admin" and password "0fb42e".

I also tried using that during the WP login but got the Incorrect password message.


So I opened XAMPP for Windows and as you suggested, clicked the phpmyadmin link, clicked "Privileges" and found the "Add new user" link just below the table in the User Overview screen.

I clicked the link but all it did was refresh the screen. I tried this a few times. Also, all clicking the Edit icon does is refresh the screen.

Did I activate phpmyadmin the correct way??

I've cleared the IE cache, stopped and restarted Apache and MySQL, rebooted, nothing changes the symptoms.



I'm not sure what to do at this point.
skeezix
 
Posts: 16
Joined: 20. October 2007 04:20
Location: Colorado

Postby Izzy » 22. October 2007 01:16

I clicked the link but all it did was refresh the screen. I tried this a few times. Also, all clicking the Edit icon does is refresh the screen.

That's very strange behavior that I can't replicate on my installation of XAMPP nor can I find a similar instance doing a search of the Internet.

Not sure either if this is peculiar to the Lite version or not as I don't use it preferring the full version and all it has to offer.
(Quote from the AF web site - XAMPP Lite is an only "Take-Run-Delete-Forget-it" package)

What version of XAMPP have you installed?
(If you installed the Lite version I recommend you install the full version as it has advantages over the lite version especially if you are serious about learning and manipulating a web server and WP is no simple web app script).

What OS?

What version of phpMyAdmin is displayed on the phpMyAdmin home page?

When you start phpMyAdmin what user name do you use and did you set a password for that user in the Security pages of XAMPP?

It may be that phpMyAdmin has been corrupted in some way, possibly during installation of XAMPP.

It may be corrected if you completely uninstall XAMPP which entails also deleting the whole XAMPP directory but, of course, only after you have backed up any files you may want to keep.

You can, of course, download the latest version of phpMyAdmin from their web site and install it over the XAMPP version without any side effects as it is only a component of XAMPP with no dependencies as long as you install to the same directory xampp\phpMyAdmin.

Also before you do this I would delete (drop) the WP database you created in phpMyAdmin. This just cleans up before you attempt any changes.

Backup the xampp\phpMyAdmin\config.inc.php file and download the English zip file version (phpMyAdmin-2.11.1.2-english.zip) then you can just unzip the files in the zip - not the directory the files are in - to the phpMyAdmin directory overwriting the existing files, it will not overwrite the config.inc.php file as the zip does not contain this file.
(All I do here is to drag and drop, holding down the Crtl key, the whole phpMyAdmin directory, which make a Copy of phpMyAdmin Then if overwriting with the new version fails , you have the original to fall back on after you rename the Copy of back to just phpMyAdmin).

I have done this on occasions when the XAMPP phpMyAdmin version was a lower version than the one I wanted to use and there was only minor cosmetic issues related to themes that were evident.
Doing this as an alternative to uninstalling XAMPP may be an option worth considering.

Now start again to install WP and see if has fixed this strange phpMyAdmin issue.

Other than that I am at a loss as to what else to suggest.

I look forward to you posting back that your WP install was successful. :)

BTW I found these 2 PDF files when doing various WP searches today but had trouble downloading them, but eventually succeeded and to save anyone else the trouble I uploaded them to Rapidshare to freely download them. They are illustrated WordPress install and configuration guides and very well put together:
everymansWPinstall.pdf
everymans_wpcom_install.pdf

Just use the free service to download ;)

I hope these 2 files help you and anyone else who reads this thread looking for help with installing and configuring WordPress.



===========================================
Take a look at the new DeskTopXampp launch control for XAMPP
and XAMPPlite (DTX.exe) posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967
Available at Ridgewood's new DTX web site http://zedfiles.com/DTX/
Also available here: http://nat32.com/dtx/
I highly recommend DTX.
============================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby skeezix » 22. October 2007 17:56

Izzy,

Just read your reply.

WinXP Pro
phpmyadmin 2.11.1
XAMPPLite

The War Dept. has just called so I have to run and see what emergency has come up. It's 11 am Monday now and finally warm enough today that I can clean up after a weekend of miserably cold Autumn weather.

I'll read your post carefully, and yes, I think it is time for a complete blow-out and reinstall of XAMPP and WP. I'll read the two docs you found and get ahumpin' after I've happified the Little Lady.
skeezix
 
Posts: 16
Joined: 20. October 2007 04:20
Location: Colorado

Postby skeezix » 23. October 2007 04:13

Cleared all traces of xampplite and wordpress from disk and registry, then installed xampp for windows 1.6.4.

Ran setup_xampp.bat, can start and stop the servers, can start the xampp program itself.

Can open phpmyadmin. However, the icon for Privileges has a padlock on it. If I go ahead and click Privileges anyway, clicking the Add new user only results in a screen refresh. Same if I click the Edit icons at the right of the two user rows (PMA and ROOT, both showing no passwords).

And another thing that keeps nagging at me - at the top of the phpmyadmin page is a yellow box with a message telling me that cookies must be enabled beyond this point.

Well, I verified that in IE6 all cookies are accepted, and in ZoneAlarm all cookies are accepted. So I don't understand why I see this message.


I think at this point I already have a problem.

WinXPSP2
I am administrator
xampp installed in d:\xampp
Verified no \xampp\xampp exists

During xampp server startup, I get a **Directory Mismatch** message.

"Current directory = d:\XAMPP
Install directory = "

Not sure what direction to take at this point.
skeezix
 
Posts: 16
Joined: 20. October 2007 04:20
Location: Colorado

Postby lyntuan » 25. October 2007 00:45

.
Last edited by lyntuan on 26. December 2008 12:45, edited 1 time in total.
AMPstart :: Launch a Portable Web Server
http://ampstart.com
----------------------------------------------------------
Please read Disclaimer section carefully before downloading
lyntuan
 
Posts: 104
Joined: 08. November 2006 00:21

Postby Izzy » 25. October 2007 03:45

I sent you a PM with a few things you could try.


The above recent replier should perhaps have read the whole thread then it would have been obvious that a blank password was being used or was there perhaps an ulterior motive to the post I wonder ;)

============================================
1. The new DeskTopXampp launch control for XAMPP / XAMPPlite
Posted by Ridgewood and available from Ridgewood'sDTX web site

2. Make Richer Ajax Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
============================================
Last edited by Izzy on 25. October 2007 07:22, edited 4 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby skeezix » 25. October 2007 04:32

Problem found, but not resolved!!

XAMPP does not work when Zone Alarm is active.

I found this by deactivating ZA, verified it on the ZA forum, and also on the German group of this forum.

What a royal PITA. If I want to fiddle with my website/blog locally, I have to disable my ZA firewall.

Thanks for all the help! Disabling my firewall is the last thing I do when problems arise. I think from now on it will be the first thing I do!
skeezix
 
Posts: 16
Joined: 20. October 2007 04:20
Location: Colorado

Postby Izzy » 25. October 2007 06:14

I will answer your PM in here for all to benefit.

As I suggested in my PM to you the other day that to disable your software firewall Zone Alarm if you were using it, may solve this issue and I am pleased that it did.
It has been known to give issues with XAMPP and others and IMHO has gone down the nick in recent times.

My other suggestion to replace ZA with the very good free Comodo firewall would resolve this issue for you and would also save you having to leave your system vulnerable by disabling your firewall every time you want to do anything useful.

Did disabling ZA solve the pesky 'Cookie' issue?

In your config.inc.php file experiment by changing Authentication method from cookie to config and see how it performs then.

The SSL line you bolded must be an addition in the latest version as I don't have that one in my config file and I would suggest to leave it as the default.

The other bolded line MySQL control user settings that I have pma entered in my comparison and not sure if it is the default or not can also be experimented with but make sure in the Privileges of phpMyAdmin that the user pma exists and is read only as suggested in the configuration file.

The link to the post by Draven with the fix for the Directory Mismatch issue that I suggested you try was also successful you noted.
For others the link was:
http://community.apachefriends.org/f/viewtopi ... 259#108259

The forum Search facility is always a very useful resource as I believe most questions have been asked and answered before and, once you master the search method, the results are often much quicker than waiting for a knowledgeable member to reply.


All in all a very satisfactory out come from what appeared to be an unsolvable dilemma :)


===========================================
1. The new DeskTopXampp launch control for XAMPP / XAMPPlite
Posted by Ridgewood available from Ridgewood'sDTX web site

2. Make Richer Ajax Applications - Faster
TIBCO General Interface Pro Edition but FREE and Open Source
Fully working with NO donations required to get a user/password
===========================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby skeezix » 27. October 2007 20:14

From your earlier posts:

Password: pw
(you can Generate a password and enter it here if you wish but for now I would keep it simple and use this example)


When you "generate" a password, does that mean the generated password is then inserted for you into the database, or that this is just a "nice quick little utility that creates a string you can use if you want" thingy?
skeezix
 
Posts: 16
Joined: 20. October 2007 04:20
Location: Colorado

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 86 guests