Warning when running a correctly installed script

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Warning when running a correctly installed script

Postby hertay » 13. September 2006 15:49

Having installed XAMPP 1.5.4 under WXP Pro, it runs fine.

Then I installed "galette" under C:\xampp\htdocs\galette but when I run http://localhost/galette/index.php, I get this warning :

Warning: include(C: mpp\htdocs\galette/includes/database.inc.php) [function.include]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 37

Warning: include() [function.include]: Failed opening 'C: mpp\htdocs\galette/includes/database.inc.php' for inclusion (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 37

Warning: include(C: mpp\htdocs\galette/includes/functions.inc.php) [function.include]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 38

Warning: include() [function.include]: Failed opening 'C: mpp\htdocs\galette/includes/functions.inc.php' for inclusion (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 38

Warning: include(C: mpp\htdocs\galette/includes/session.inc.php) [function.include]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 39

Warning: include() [function.include]: Failed opening 'C: mpp\htdocs\galette/includes/session.inc.php' for inclusion (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 39

Warning: include_once(C: mpp\htdocs\galette/includes/i18n.inc.php) [function.include-once]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 40

Warning: include_once() [function.include]: Failed opening 'C: mpp\htdocs\galette/includes/i18n.inc.php' for inclusion (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 40

Warning: include_once(C: mpp\htdocs\galette/includes/smarty.inc.php) [function.include-once]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 41

Warning: include_once() [function.include]: Failed opening 'C: mpp\htdocs\galette/includes/smarty.inc.php' for inclusion (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 41

Warning: require_once(C: mpp\htdocs\galette/includes/picture.class.php) [function.require-once]: failed to open stream: Invalid argument in C:\xampp\htdocs\galette\index.php on line 42

Fatal error: require_once() [function.require]: Failed opening required 'C: mpp\htdocs\galette/includes/picture.class.php' (include_path='.;C:\xampp\php\pear\') in C:\xampp\htdocs\galette\index.php on line 42


with these lines :
Code: Select all
36   include("includes/config.inc.php");
37   include(WEB_ROOT."includes/database.inc.php");
38   include(WEB_ROOT."includes/functions.inc.php");
39   include(WEB_ROOT."includes/session.inc.php");
40   include_once(WEB_ROOT."includes/i18n.inc.php");
41   include_once(WEB_ROOT."includes/smarty.inc.php");
42   require_once(WEB_ROOT."includes/picture.class.php");

and in config.inc.php :
Code: Select all
define("WEB_ROOT", "C:\xampp\htdocs\galette/");


Who knows what happens and specially why we read :

"...include(C: mpp\htdocs\galette..." instead of "... include(C:\xampp\htdocs\galette..."

and why "\" and "/" are mixed ?

Is it a problem with php script (I dont' think so...) or a Xampp configuration ?

Thank you :wink:
hertay
 
Posts: 2
Joined: 13. September 2006 14:31

Postby Wiedmann » 13. September 2006 17:48

Code: Select all
define("WEB_ROOT", "C:\xampp\htdocs\galette/");

Just use forward slashs in your script. And/or if there is nothing to parse in a string, use single quotes:
Code: Select all
define('WEB_ROOT', 'C:/xampp/htdocs/galette/');
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby hertay » 13. September 2006 23:28

Wiedmann wrote:Just use forward slashs in your script. [...]

Of course ! How silly I am :lol:
Thank you very much Wiedmann !
hertay
 
Posts: 2
Joined: 13. September 2006 14:31

Postby stephs » 16. September 2006 14:31

Wiedmann wrote:
Code: Select all
define("WEB_ROOT", "C:\xampp\htdocs\galette/");

Just use forward slashs in your script. And/or if there is nothing to parse in a string, use single quotes:
Code: Select all
define('WEB_ROOT', 'C:/xampp/htdocs/galette/');


hello, i am a galette developer. We detect WEB_ROOT with
Code: Select all
define("WEB_ROOT", realpath(dirname(__FILE__)."/../")."/");
(script is in a subdirectory of the galette directory) in the install script and it works fine except with xampp.

Do you know how we can detect it so that works also with xampp ?
stephs
 
Posts: 1
Joined: 16. September 2006 14:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests