Which Version would be best?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Which Version would be best?

Postby YingYang » 13. September 2006 09:31

Hi Guys.

I have recently brought my own dedicated webserver, as a hobby I play about with PHP and MySQL. My webserver has the following versions of software:

Operating System: CentOS 4.3 i686
Apache: 1.3.37 (Unix)
PHP: 4.4.2
MySQL: 4.1.21
phpMyAdmin: 2.8.0.2

What is the closest version of XAMPP to that I can use a windows machine? I ask this as I know there are certain issues with different versions of PHP MySQL etc...

Any help would be great :).

Cheers YY.
Last edited by YingYang on 13. September 2006 11:40, edited 1 time in total.
YingYang
Current Status: Sorting Dedicated Server
Current Project: Testing phpBB3
YingYang
 
Posts: 6
Joined: 13. September 2006 09:21
Location: UK

Re: Which Version would be best?

Postby Izzy » 13. September 2006 10:01

YingYang wrote:Hi Guys.

I have recently brought my own dedicated webserver, as a hobby I play about with PHP and MySQL. My webserver has the following versions of software:

Operating System: CentOS 4.3 i686
Apache: 1.3.37 (Unix)
PHP: 4.4.2
MySQL: 4.1.21
phpMyAdmin: 2.8.0.2

What is the closest version of XAMPP to that I can use a windows machine? I ask this as I know there are certain issues with different versions of PHP MySQL etc...

Any help would be great :).

Cheers YY.

This link will give you all the current versions in the Archive:
http://sourceforge.net/project/showfile ... p_id=61776

This link will give you all the older versions of XAMPP for Windows. Just click on the Notes link of each version to see what modules and version it contains (some have no information and may require you to download to find out):
http://sourceforge.net/project/showfile ... e_id=89552

Thats the best I can do for you. A developer might spot your post and may have a more accurate list to offer.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby YingYang » 13. September 2006 11:14

Thanks for help :).

After reading a few notes ive spotted that the last version of XAMPP that includes MySQL 4 is 1.4.16. But there doesnt appear to be any notes for that version, have you or anyone else got any ideas which versions are included on that release?

Again thanks for the help.

/YY
Last edited by YingYang on 13. September 2006 11:40, edited 1 time in total.
YingYang
Current Status: Sorting Dedicated Server
Current Project: Testing phpBB3
YingYang
 
Posts: 6
Joined: 13. September 2006 09:21
Location: UK

Postby Izzy » 13. September 2006 11:26

The oldest version I have on my disk is 1.4.13. This is what it contains:
ApacheFriends XAMPP (basic package) version 1.4.13

+ Apache 2.0.53
+ MySQL 4.1.11
+ PHP 5.0.4 + PHP 4.3.11 + PEAR
+ eAccelerator 0.9.2a
+ PHP-Switch win32 1.0 (von Apachefriends, man nehme die "php-switch.bat")
+ XAMPP Control Version 1.0
+ XAMPP Security 1.0
+ SQLite 2.8.15
+ OpenSSL 0.9.7f
+ phpMyAdmin 2.6.1-pl3
+ ADODB 4.60
+ Mercury Mail Transport System for Win32 and NetWare Systems v4.01a
+ FileZilla FTP Server 0.9.6a
+ Webalizer 2.01-10
+ Zend Optimizer 2.5.7
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby YingYang » 13. September 2006 11:31

Just as an example, say I created a phpBB forum on my windows machine, created usergruops set up forums etc... would that phpBB forum be able to run on my webserver? (No conficlting versions etc...)

Sorry to keep going on just need to make sure this is right :D.

/Cheers YY.
YingYang
Current Status: Sorting Dedicated Server
Current Project: Testing phpBB3
YingYang
 
Posts: 6
Joined: 13. September 2006 09:21
Location: UK

Postby Izzy » 13. September 2006 11:48

YingYang wrote:Just as an example, say I created a phpBB forum on my windows machine, created usergruops set up forums etc... would that phpBB forum be able to run on my webserver? (No conficlting versions etc...)

Sorry to keep going on just need to make sure this is right :D.

/Cheers YY.
You could do that using the latest XAMPP version 1.5.3a.
Then upload to your server after dumping/exporting your data base of course. It seems to be the database that gets people in a tiz woz. Using phpMyAdmin, it is a piece of cake especially as you have phpMyAdmin on both servers.

My advise is to set up on your hosting server then download to your XAMPP server. But the choice is yours. Either way phpbb latest version should be fine on both.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests