cpu at 100%

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cpu at 100%

Postby venn » 11. September 2006 00:54

Hello.

My cpu is almost at 100%. So I tried to follow the instructions from FAQ which are the following:
1.
>My CPU load is with the Apache almost by 99%
>>Please, enable following line = > # Win32DisableAcceptEx in >>the /xampp/Apache/conf/httpd.conf.
>>
>>In this case correct is: Win32DisableAcceptEx

Instead I found this
2.
# To enable the this Windows specific behavior (and therefore -disable- #the
# equivilant Unix behavior), uncomment the following directive:
#ScriptInterpreterSource registry

I followed "2." no luck.
Then I recommented it and followed the instructions for "1." no luck.

Any suggestions?

Thank you.
venn
 
Posts: 6
Joined: 11. September 2006 00:40
Location: NYC

Postby Izzy » 11. September 2006 01:10

Take a look at the running processes in the Windows Task Manager and see if you can locate the process that is using 100% - Cntrl-Alt-Delete - select the Process tab.

If you see that it is pv.exe then follow this from another post that the original poster appeared to have ignored: :roll:

Try and start all modules as a service from the XAMPP Control Panel then restart your computer so the services are running from boot.

All means all, even those you may not need at the moment. You can always stop those services you don't need later.

This may not fix your particular issue but it may be related to pv.exe trying to find services not running and seems to do this at very regular intervals until all memory is used.

This post went into the pv.exe issue in great detail:

http://community.apachefriends.org/f/viewtopic.php?t=18984


I had this issue and the above fixed it. If it happens again after the fix then just start all the services again and it will go away again - until the next time.

I can't seem to find the ultimate cure for this, but I am now aware of what I have to do to stop the run away process that consumes 100% of my memory.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby venn » 11. September 2006 03:25

Should I try this with the original httpd.conf file?

The process that takes up a lot of cpu is not the pv.exe. It is any application that I launch or performing an action, ie, opening msword, saving the doc, launching internet explorer...
venn
 
Posts: 6
Joined: 11. September 2006 00:40
Location: NYC

Postby Izzy » 11. September 2006 03:37

venn wrote:Should I try this with the original httpd.conf file?

The process that takes up a lot of cpu is not the pv.exe. It is any application that I launch or performing an action, ie, opening msword, saving the doc, launching internet explorer...

Then it's nothing to do with XAMPP and so there is no need to try the above. Just ignore it.

Your problem may relate to your firewall software like ZoneAlarm or BlackIce or some other named firewall or even your Anti-Virus scanning software.

You can temporarily disable them to see if your problem goes away. If it does then you may have to contact the firewall/anti-virus scanning software forums or their tech. support.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby venn » 11. September 2006 03:56

Thank you!
venn
 
Posts: 6
Joined: 11. September 2006 00:40
Location: NYC

Postby venn » 11. September 2006 04:35

one more question...

i do not see pv.exe in the task manager. is there something wrong?
venn
 
Posts: 6
Joined: 11. September 2006 00:40
Location: NYC

Postby Izzy » 11. September 2006 04:40

venn wrote:one more question...

i do not see pv.exe in the task manager. is there something wrong?

No nothing wrong. It will come and go as and when it is required. If it sticks and starts using up resouses then you might see it in the Process list showing a high CPU usage. Thats when you would try the above remedy.

By the way was it one of those firewall/anti-virus programs, if so, which one, it just might help other users with the same issues and software.
Thanks and good luck. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby venn » 11. September 2006 04:50

it must be a firewall problem, the settings are at the lowest allowed.

i am using zone alarm pro. i love it so i won't turn it off for anything. with that said, i am not sure how to remedy this problem. do you think running xampp off of my usb drive would make a difference?
venn
 
Posts: 6
Joined: 11. September 2006 00:40
Location: NYC

Postby Izzy » 11. September 2006 05:12

venn wrote:it must be a firewall problem, the settings are at the lowest allowed.

i am using zone alarm pro. i love it so i won't turn it off for anything. with that said, i am not sure how to remedy this problem. do you think running xampp off of my usb drive would make a difference?

You don't need to turn it off, just disable it temporarily so you can check if it is Zone Alarm, which by the way is notorious for doing exactly what you have said you have going on with the CPU overload.
http://www.wilderssecurity.com/archive/ ... -1058.html

Moving XAMPP to a USB stick should have no effect because as I have said Xampp or its modules have nothing to do with
...It is any application that I launch or performing an action, ie, opening msword, saving the doc, launching internet explorer...

It is a web server, an FTP server, a database server, and an mail exchanger. It will not interfere with any processes other than it's own.

The only thing I have found, and you would have seen it in the processes tab, is pv.exe. This is only used by the XAMPP Control Panel to check if the services are up and running. If it can't find a particular service it may stick and start to check every minute until it has used up all the CPU. This will be quite evident in the Processes tab.

You should check the Processes tab when you start to notice the CPU playing up. It will show you which process is using all the CPU in the CPU column. Watch it as it refreshes almost every second or so.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests