Cannot get Apache to start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot get Apache to start

Postby bombknex » 08. September 2006 03:45

Hello,

I installed Xampp via the windows installer and everything went smoothly during the install. I opened up port 80 on my router and the Apache service was successfully started during install.

Through the Xampp control panel when I click on 'Start' for Apache, MySQL, or Filezilla it says they are started in the bottom area but the nice green 'Running' indicator does not come on for any of them.

I've tried a few things from some of the other posts and nothing is working.

Here is my error.log output:
[Mon May 08 17:02:39 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon May 08 17:02:39 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon May 08 17:02:39 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon May 08 17:02:39 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon May 08 17:02:41 2006] [notice] Apache/2.2.0 (Win32) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_autoindex_color PHP/5.1.4 configured -- resuming normal operations
[Mon May 08 17:02:41 2006] [notice] Server built: Dec 1 2005 18:36:53
[Mon May 08 17:02:41 2006] [notice] Parent: Created child process 1692
[Mon May 08 17:02:42 2006] [notice] Child 1692: Child process is running
[Mon May 08 17:02:43 2006] [notice] Child 1692: Acquired the start mutex.
[Mon May 08 17:02:43 2006] [notice] Child 1692: Starting 250 worker threads.
[Mon May 08 17:02:43 2006] [notice] Child 1692: Starting thread to listen on port 443.
[Mon May 08 17:02:43 2006] [notice] Child 1692: Starting thread to listen on port 80.
[Mon May 08 17:03:04 2006] [error] [client 127.0.0.1] File does not exist: D:/xampp/htdocs/cgi

And here is my portcheck output:
RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 443 free

MySQL 3306 C:\Program Files\MySQL\MySQL Server 4.1\bin\mysqld-n
t.exe

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 C:\Program Files\Mozilla Thunderbird\thunderbird.exe

Mercury (POP3) 110 C:\Program Files\Mozilla Thunderbird\thunderbird.exe

Mercury (IMAP) 143 C:\Program Files\Mozilla Thunderbird\thunderbird.exe

I don't have windows firewall running, I've disabled Skype, I checked my hosts file and everything looks good.

When I try to view 127.0.0.1 or localhost in firefox I just get a standard can't find the page message.

Any ideas as to whats going on?

I appreciate your help. :)
bombknex
 
Posts: 2
Joined: 08. September 2006 03:28

Postby Izzy » 08. September 2006 04:19

This looks like a configuration issue and/or a path conflict.
[Mon May 08 17:02:39 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon May 08 17:02:39 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Mon May 08 17:02:39 2006] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Mon May 08 17:02:39 2006] [crit] (2)No such file or directory: unable to replace stderr with /dev/null


and/or

File does not exist: D:/xampp/htdocs/cgi


Have you created any Virtual Hosts in the xampp/apache/conf/extra/httpd-vhosts.conf file?

If so, issue this command at a command prompt in xampp/apache/bin
apache -S

Past any errors you may have that you can't handle or better still paste the whole httpd.vhosts.conf file.

Also it looks like it may be an error.log file setting in the vhost container. For a quick fix perhaps, comment out (use # at the beginning of the line) any error log file entries.

Always try and restart apache after making any edits in the conf files then check your error logs again if it won't start. Or before restarting and after editing follow the apache -S or apache -t items.

You can also check your httpd.conf file in the same way except issue this command in the same directory as the above:
apache -t

Again paste any errors that may be evident.

Check that all your paths are correct and did you install from the Windows Installer Version?

You can also try and start it using apache_start.bat and see what errors it gives you back.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby bombknex » 08. September 2006 13:59

Hello, thanks for replying...

I do not have any virtual hosts setup so I did not try anything with that.

I commented out all error.log entries and tried to start apache through the control panel but still the same problem.

I checked my httpd.conf file and changed my server root path from '/xampp/apache' to 'c:/program files/xampp/apache' and then issue the "apache -t" command at the prompt and got the following message:

C:\Program Files\xampp\apache\bin|► apache -t
apache: Syntax error on line 477 of C:/Program Files/xampp/apache/conf/httpd.con
f: Syntax error on line 7 of C:/Program Files/xampp/apache/conf/extra/httpd-xamp
p.conf: Cannot load C:/xampp/apache/bin/php5apache2.dll into server: The specifi
ed module could not be found.

I did install from the windows installer 1.5.3a and left everything at default when I installed. i.e., I didn't change anything in any of the conf files after installing.

When I try starting apache from apache_start.bat I get this message:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
The system cannot find the path specified.

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

Any other ideas as to whats going wrong here?
bombknex
 
Posts: 2
Joined: 08. September 2006 03:28

Postby Izzy » 08. September 2006 23:07

bombknex wrote:I checked my httpd.conf file and changed my server root path from '/xampp/apache' to 'c:/program files/xampp/apache'

When I try starting apache from apache_start.bat I get this message:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
The system cannot find the path specified.

This needs to be put back to /xampp/apache as the path you replaced it with is incorrect. Also try and use the default httpd.conf file - you did back it up before editing it?

Then re issue the apache -t command or PM me your httpd.conf file along with the path details of your XAMPP install (for your privacy only) . I will take a look at it and see what might be wrong. You have a couple of syntax errors on the lines mentioned in the apache -t results which need fixing.
bombknex wrote: C:\Program Files\xampp\apache\bin|► apache -t
apache: Syntax error on line 477 of C:/Program Files/xampp/apache/conf/httpd.con
f: Syntax error on line 7 of C:/Program Files/xampp/apache/conf/extra/httpd-xamp
p.conf: Cannot load C:/xampp/apache/bin/php5apache2.dll into server: The specified module could not be found.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests