Xampplite, Joomla and a "Restricted Access" Messag

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampplite, Joomla and a "Restricted Access" Messag

Postby jgaryt » 31. August 2006 01:24

ello,

I have been working with my Joomla site on a remote server with no issues for several weeks, but in order to experiment a little more freely and to conserve bandwidth I decided to use Xampplite to run my Joomla site locally. I followed the Xampplite instructions, and new have my Joomla files, along with the Joomla installation directory, located on "c:\xampplite\htdocs\MyDir\" which translates to "http://localhost/MyDir". That much is working, as the site is redirected to the http://localhost/MyDir/installation/index.php as expected. It is then that I get a "Restricted Access" message, and no more.

I have not yet done anything to 'secure' the site as recommended by XAMPP, so it's not anything to do with that.

Thanks for your help!

jgaryt
jgaryt
 
Posts: 2
Joined: 31. August 2006 01:21

Postby Izzy » 31. August 2006 01:35

This looks like a Joomla issue.

Look in your xampplite/apache/logs/error.log if that is the path to it, as I don't have the lite version installed to check the path. It may contain the missing clue. Also while you are there look in the access.log.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jgaryt » 31. August 2006 02:53

Izzy wrote:This looks like a Joomla issue.

Look in your xampplite/apache/logs/error.log if that is the path to it, as I don't have the lite version installed to check the path. It may contain the missing clue. Also while you are there look in the access.log.



Thanks for the reply. Nothing in the error.log, and in the access.log was "127.0.0.1 - - [30/Aug/2006:20:29:42 -0400] "GET /jgt/installation/index.php HTTP/1.1" 200 17"


I'll keep poking around!

jgaryt
jgaryt
 
Posts: 2
Joined: 31. August 2006 01:21

Postby WorldDrknss » 31. August 2006 03:01

Try changing

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

to
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all
</Directory>

In your httpd.conf, save then restart apache.
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby Izzy » 31. August 2006 03:32

WorldDrknss wrote:Try changing

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

to
Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Allow from all
</Directory>

In your httpd.conf, save then restart apache.


@jgaryt
Doing that will open your server and other directories to a security risk and should never be changed from the default. There is a very good reason to not open directories to those script kiddies that might have you condone this behaviour for thier own ends. So be advised.
httpd.conf wrote:#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

If you look at the next entry below this it will show you how the htdocs directory is given permissions. Just add your Directory directive either above the htdocs entry or below it. Then save and restart Apache.

You don't need to create a Directory directive for htdocs/MyDir as the directory htdocs and its subdirectories has already been given the right permissions.
Code: Select all
#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/xampplite/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI
   
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

</Directory>

See http://httpd.apache.org/docs/2.2/mod/co ... #directory for explanation of this directive.

For Security Tips read this:
http://httpd.apache.org/docs/2.2/misc/s ... erverfiles

Go safe and be as secure as you can. ;)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests