xammp help "Unable to open log" and no listening s

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xammp help "Unable to open log" and no listening s

Postby tomnuff » 29. August 2006 17:51

Hello,
I'm very new to xampp and apache,

I have a webserver that is running xampp.

When I try and start xampp I get these errors:

The Apache service named reported the following error:
>>> Unable to open logs

The Apache service named reported the following error:
>>> no listening sockets available, shutting down

Apache used to work fine ,but now it doesn't start.
My websites aren't up and I know it's because this isn't working
I'm running on a Windows 2k machine and I've uninstalled ISS.
How can I fix this. If you need more info let me know what you need to know.

-Tom
User avatar
tomnuff
 
Posts: 19
Joined: 29. August 2006 17:45

Postby Izzy » 30. August 2006 00:32

You can run netstat -ao from a command prompt to find what is running on what port:
Click Start/Run... type netstat -ao

Check with your Task Manager that another instance of Apache or indeed any other server is running. If so Kill the other server's process(es) and try and restart Apache again.

You can also check the xampp/apache/logs/error.log and access.log for any clues.

These errors usually mean that another instance of Apache is running or another server is listening on port 80.

Check what is served if you type:
http://localhost or http://127.0.0.1

Another thing to check is your Windows's network firewall settings. Make sure port 80 is open.

If you use Skype it also uses port 80. So disable Skype untill Apache has started then Skype will use another port.
Or If Skype is running on port 80, there is an option in the Connection tab in Skype that says 'Use port 80 and 443 as alternatives for incoming connections' ...uncheck it.

As another check to see if another server is running and using port 80 go to xampp/apache/conf/httpd.conf and find this part and change the port that Apache is listening on:
Code: Select all
#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)
#
#Listen 12.34.56.78:80
Listen 80

Change this to another port for example 81

Also change this to 81
Code: Select all
#
# ServerName gives the name and port that the server uses to identify itself.
# This can often be determined automatically, but we recommend you specify
# it explicitly to prevent problems during startup.
#
# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName localhost:80


Save the httpd.conf file and restart your XAMPP Apache server.

Don't forget to change them back to port 80 if you solve your multiple server issue as port 80 is the default port for serving to the Internet.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby tomnuff » 30. August 2006 17:00

Thanks for the reply, ok here we go....


You can run netstat -ao from a command prompt to find what is running on what port:
Click Start/Run... type netstat -ao

This is what pulled up when i did a netstat -na
Active Connections

Proto Local Address Foreign Address State
TCP 0.0.0.0:21 0.0.0.0:0 LISTENING
TCP 0.0.0.0:53 0.0.0.0:0 LISTENING
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1029 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1036 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1041 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1046 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1047 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1050 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1052 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1053 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1055 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1443 0.0.0.0:0 LISTENING
TCP 0.0.0.0:2143 0.0.0.0:0 LISTENING
TCP 0.0.0.0:2144 0.0.0.0:0 LISTENING
TCP 0.0.0.0:2146 0.0.0.0:0 LISTENING
TCP 0.0.0.0:3389 0.0.0.0:0 LISTENING
TCP 0.0.0.0:20480 0.0.0.0:0 LISTENING
TCP 192.168.0.11:139 0.0.0.0:0 LISTENING
TCP 192.168.0.11:1046 192.168.0.11:20491 ESTABLISHED
TCP 192.168.0.11:1047 216.229.151.48:2147 ESTABLISHED
TCP 192.168.0.11:1048 0.0.0.0:0 LISTENING
TCP 192.168.0.11:1048 192.168.0.11:2143 ESTABLISHED
TCP 192.168.0.11:1049 0.0.0.0:0 LISTENING
TCP 192.168.0.11:1049 192.168.0.11:2144 ESTABLISHED
TCP 192.168.0.11:1050 192.168.0.11:20491 ESTABLISHED
TCP 192.168.0.11:1051 0.0.0.0:0 LISTENING
TCP 192.168.0.11:1051 192.168.0.11:2143 ESTABLISHED
TCP 192.168.0.11:1052 192.168.0.11:20491 ESTABLISHED
TCP 192.168.0.11:1053 192.168.0.11:20491 ESTABLISHED
TCP 192.168.0.11:1054 0.0.0.0:0 LISTENING
TCP 192.168.0.11:1054 192.168.0.11:2144 ESTABLISHED
TCP 192.168.0.11:2143 192.168.0.11:1048 ESTABLISHED
TCP 192.168.0.11:2143 192.168.0.11:1051 ESTABLISHED
TCP 192.168.0.11:2144 192.168.0.11:1049 ESTABLISHED
TCP 192.168.0.11:2144 192.168.0.11:1054 ESTABLISHED
TCP 192.168.0.11:3389 192.168.0.135:2364 ESTABLISHED
TCP 192.168.0.11:20491 0.0.0.0:0 LISTENING
TCP 192.168.0.11:20491 192.168.0.11:1046 ESTABLISHED
TCP 192.168.0.11:20491 192.168.0.11:1050 ESTABLISHED
TCP 192.168.0.11:20491 192.168.0.11:1052 ESTABLISHED
TCP 192.168.0.11:20491 192.168.0.11:1053 ESTABLISHED
UDP 0.0.0.0:445 *:*
UDP 0.0.0.0:1027 *:*
UDP 0.0.0.0:1028 *:*
UDP 0.0.0.0:1030 *:*
UDP 0.0.0.0:1031 *:*
UDP 0.0.0.0:1032 *:*
UDP 0.0.0.0:1033 *:*
UDP 0.0.0.0:1035 *:*
UDP 0.0.0.0:1038 *:*
UDP 0.0.0.0:3456 *:*
UDP 70.253.151.133:53 *:*
UDP 70.253.151.133:500 *:*
UDP 70.253.151.135:53 *:*
UDP 70.253.151.135:500 *:*
UDP 70.253.151.136:53 *:*
UDP 70.253.151.136:500 *:*
UDP 127.0.0.1:53 *:*
UDP 127.0.0.1:1034 *:*
UDP 127.0.0.1:2821 *:*
UDP 192.168.0.11:53 *:*
UDP 192.168.0.11:137 *:*
UDP 192.168.0.11:138 *:*
UDP 192.168.0.11:500 *:*
UDP 192.168.0.11:1045 *:*
UDP 192.168.0.11:20490 *:*
UDP 192.168.0.11:20491 *:*
UDP 192.168.0.11:20493 *:*

I assume that my server is not listing on port 80 cause xampp is not running, or is there another reason why? Like I said I'm new to this.
Check with your Task Manager that another instance of Apache or indeed any other server is running. If so Kill the other server's process(es) and try and restart Apache again.

I checked and nothing is running. I've restarted xampp and I still get the erros ">>> Unable to open logs

The Apache service named reported the following error:
>>> no listening sockets available, shutting down

You can also check the xampp/apache/logs/error.log and access.log for any clues.

Reviewing my logs this is what it said:

[Tue Aug 29 13:25:21 2006] [notice] Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_color PHP/5.1.4 configured -- resuming normal operations
[Tue Aug 29 13:25:21 2006] [notice] Server built: May 9 2006 14:08:48
[Tue Aug 29 13:25:21 2006] [notice] Parent: Created child process 2756
[Tue Aug 29 13:25:25 2006] [notice] Child 2756: Child process is running
[Tue Aug 29 13:25:25 2006] [notice] Child 2756: Acquired the start mutex.
[Tue Aug 29 13:25:25 2006] [notice] Child 2756: Starting 250 worker threads.
[Tue Aug 29 13:25:27 2006] [notice] Child 2756: Starting thread to listen on port 443.
[Tue Aug 29 13:25:27 2006] [notice] Child 2756: Starting thread to listen on port 81.
[Tue Aug 29 13:39:00 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Aug 29 13:39:00 2006] [notice] Child 2756: Exit event signaled. Child process is ending.
[Tue Aug 29 13:39:01 2006] [notice] Child 2756: Released the start mutex
[Tue Aug 29 13:39:02 2006] [notice] Child 2756: Waiting for 250 worker threads to exit.
[Tue Aug 29 13:39:02 2006] [notice] Child 2756: All worker threads have exited.
[Tue Aug 29 13:39:02 2006] [notice] Child 2756: Child process is exiting
[Tue Aug 29 13:39:02 2006] [notice] Parent: Child process exited successfully.

Does this point out anything for you? ( I hope.)
Check what is served if you type:
http://localhost or http://127.0.0.1

I tried pulling up both localhost but it says "cannot display page"
127.0.0.1 takes to to an msn search page that says "We can't find "127.0.0.1"

Another thing to check is your Windows's network firewall settings. Make sure port 80 is open.

I checked and it's open

If you use Skype it also uses port 80.

Do not use skype

As another check to see if another server is running and using port 80 go to xampp/apache/conf/httpd.conf and find this part and change the port that Apache is listening on:...........
Change this to another port for example 81

Also change this to 81
Save the httpd.conf file and restart your XAMPP Apache server.

Don't forget to change them back to port 80 if you solve your multiple server issue as port 80 is the default port for serving to the Internet.


I check my httpd.conf file and did what you said. I changed it to 81 and so forth, restarted xampp but did not work.

Well I hope this information will make sense ,
again thanks for your reply and hope to hear from you soon.

-Tom
User avatar
tomnuff
 
Posts: 19
Joined: 29. August 2006 17:45

Postby Izzy » 30. August 2006 23:10

This is a strange issue now that you have found no other servers running as the error message indicates the ports are in use. I can only guess and go though some sort of check list with you now.

Run xampp/xampp-portcheck.exe

TCP 0.0.0.0:21 0.0.0.0:0 LISTENING = FTP is running?

[Tue Aug 29 13:39:00 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.

Open a command prompt in the xampp/apache/bin directory and issue the command:
apache -t

See if you get any errors. Paste here if not sure. If you get errors post the httpd.conf here, just obfuscate any private info or paste it to me in a PM.

Did you make any changes in any of the .conf files in the xampp/apache/conf/extra directory?

Do you have a router? Is that setup correctly?

How are you starting Apache? Are you trying the .bat files or using the XAMPP Control Panel?

Have you tried setting XAMPP to run as a service then booting Windows again?

Have you tried doing a clean uninstall and reinstall of XAMPP? If you have a problem install this should fix it as XAMPP should work straight out of the box, so to speak. :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby tomnuff » 31. August 2006 00:31

Izzy, thanks for the reply ...ok here we go

Run xampp/xampp-portcheck.exe


RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 free
Apache (WebDAV) 81 free
Apache (HTTPS) 443 free

MySQL 3306 free

FileZilla (FTP) 21 C:\WINNT\System32\inetsrv\inetinfo.exe
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free

Press <Return> to continue.s.

TCP 0.0.0.0:21 0.0.0.0:0 LISTENING = FTP is running?

I believe that I didnt uninstall the ftp in IIS,everything else though is gone, should I uninstall??

Open a command prompt in the xampp/apache/bin directory and issue the command:
apache -t


D:\xampp\xampp\apache\bin>apache -t
Syntax OK

I'll send you my httpd.conf file in PM.

Did you make any changes in any of the .conf files in the xampp/apache/conf/extra directory?

Nope, never touched the files in that directory.

Do you have a router? Is that setup correctly?

Yes, I have the specific router address assigned from ISP


How are you starting Apache? Are you trying the .bat files or using the XAMPP Control Panel?

Xammp Control Panel

Have you tried setting XAMPP to run as a service then booting Windows again?

How do I set up xampp to run as a service?

Have you tried doing a clean uninstall and reinstall of XAMPP? If you have a problem install this should fix it as XAMPP should work straight out of the box, so to speak.


I may do this again and deleting all the files and doing a "clean" install. I'll try it after I hear back from you.

Thanks again for you insight and expertise, you sure know your apache Izzy

-Thomas
User avatar
tomnuff
 
Posts: 19
Joined: 29. August 2006 17:45

Postby Izzy » 31. August 2006 00:55

I believe that I didnt uninstall the ftp in IIS,everything else though is gone, should I uninstall??

FileZilla (FTP) 21 C:\WINNT\System32\inetsrv\inetinfo.exe
I would uninstall as XAMPP has the FileZilla FTP module. That way all your IIS stuff has been uninstalled and therefore should not cause any conflicts, (I hope).

Try and start Apache by clicking on the apache_start.bat as this may give you an error as to why it won't kick in.


I'll send you my httpd.conf file in PM.

Do that, then I can check it out for you. Edit - I have just received it and will take a look see and get back to you.

Running XAMPP as a service:
Open XAMPP Control panel.
Tick all the Svc boxes.
Click Settings...
Tick all boxes and check the path to service.exe is correct.
Select System Account and tick Allow desktop interaction.
Click OK
Check all ticks are still in place.
Click Exit
Close and reboot your PC.

Open XAMPP Control panel and check all services are Running
Click on Statuts and you should see:
XAMPP Aplication Status 1.1.1.0
apache State 1 Service 1 Start 1 Thread 0 Op 0
same for the other services if all is OK.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby tomnuff » 31. August 2006 16:28

:o
xammp is up and running! Thank you izzy

It has all the services running green.

now my sites still don't come up??

When I type in www.blueprintfs.com from my server

i get the xampp screen like if i type in localhost??

If i try it on a diffrent computer it doesnt come up at all.

:(

I'll send you my httd.vhost.conf file, if you can please inspect it.


I think I'm getting closer and closer with your help
User avatar
tomnuff
 
Posts: 19
Joined: 29. August 2006 17:45

Postby Izzy » 01. September 2006 03:45

tomnuff wrote:...now my sites still don't come up??

When I type in www.blueprintfs.com from my server

i get the xampp screen like if i type in localhost??

If i try it on a diffrent computer it doesnt come up at all.

:(

I'll send you my httd.vhost.conf file, if you can please inspect it.


I think I'm getting closer and closer with your help

All the above should now be fixed if you followed the httpd-vhosts.conf file I sent back to you. You may have to edit it to include your particular information and paths but basically it should work for you.

Good luck and keep plugging away at it because all will come clear in the end. :)

For other members reading this thread, I have posted on many occasions some info on this particular httpd-vhosts.conf file and how it should basically be constructed. If you search the forum for vhosts or virtual hosts they should come up in the results.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xammp help "Unable to open log" and no listening s

Postby sanctivus » 13. July 2009 14:07

I had the same error as the original post. To skip all the mumbo jumbo stuff about the config and all i would like to advise everyone reading this to first of all check that your skype is closed when apache is trying to start. Skype uses port 80 and therefore your webserver cannot utilize itself. I always make the same mistake and forget it's running. If you have Skype open and having this error this is 99% the cause of this error. Simply close skype, restart apache and it oughta start. After the server startup u can open and use Skype again with no problems. Ofc ther eis many applications that could do the same but i found that most ppl run into this cause of skype.

Ugh....Just noticed it has been mentioned alr...
sanctivus
 
Posts: 1
Joined: 13. July 2009 14:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests