MySql - No Database ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySql - No Database ?

Postby frouleau » 24. August 2006 04:17

I just install MySql and see in the MyODBC test box "not found" what should I do ? I did install the driver MyOdbc3.dll (API level) / MyODBC35.dll (SQLLevel)
[/img]
frouleau
 
Posts: 3
Joined: 24. August 2006 04:04

Re: MySql - No Database ?

Postby Izzy » 24. August 2006 04:50

frouleau wrote:I just install MySql and see in the MyODBC test box "not found" what should I do ? I did install the driver MyOdbc3.dll (API level) / MyODBC35.dll (SQLLevel)
[/img]

MyODBC is not used by XAMPP mySQL.

Can you be much more specific with your question please.

Once you have XAMPP installed run xampp/xampp-control.exe and use this XAMPP Control Panel to run your XAMPP components including the XAMPP mySQL component.
Last edited by Izzy on 27. August 2006 00:49, edited 2 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby frouleau » 24. August 2006 05:02

That exactly what I am doing. MySql is running. I click Admin... this open winMySqlAdmin. If I go to the Database tab I have no Database.. I expect to see something in the database panel.. I there something I should do before ?
frouleau
 
Posts: 3
Joined: 24. August 2006 04:04

Postby Izzy » 24. August 2006 05:39

frouleau wrote:That exactly what I am doing. MySql is running. I click Admin... this open winMySqlAdmin. If I go to the Database tab I have no Database.. I expect to see something in the database panel.. I there something I should do before ?

Try looking in phpMyAdmin located here:

http://localhost/xampp/index.php

Click on the phpMyAdmin link in the left hand frame.

You should see all your databases in there and you should be able to administer them.

If you prefer to use the command line (console) see this post:

http://community.apachefriends.org/f/viewtopi ... 3391#83391
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Izzy » 24. August 2006 08:05

I have mySQL running as a service which starts automagically when windows starts. It loads xampp\mysql\bin\mysql-nt.exe not mysqld.exe as is loaded when you start it manually.

I also created a password for user root so mySQL was secure.

Here is what I see under the relevant tabs in WinMySQLadmin:

Start Check tab (greyed out)
Thare is a my.ini file................... yes
Veryfying the my.ini file keys.
MySQL server path key............... OK
datadir....................................... OK
basedir....................................... OK


my.ini Setup tab (not greyed out)
#This File was made using the WinMySQLAdmin 1.4 Tool
#24/08/2006 2:22:44 PM

#Uncomment or Add only the keys that you know how works.
#Read the MySQL Manual for instructions

[mysqld]
basedir=C:/xampp/mysql (this will be your path to mysql)
#bind-address=111.111.111.111 (this will be your IP)
datadir=C:/xampp/mysql/data (this will be your path to the data directory)
#language=C:/xampp/mysql/share/your language directory (same here)
#slow query log#=
#tmpdir#=
#port=3306
#set-variable=key_buffer=16M
[WinMySQLadmin]
Server=C:/xampp/mysql/bin/mysqld-nt.exe
user=root
password=myrootpasswordhere


Databases tab
a database tree.

MYComputerNameHere (111.111.111.111) - My IP in the brackets
database 1
database 2
database 3
etc.
etc.


I was able to replicate your problem by renaming the my.ini file that is stored in the C:/Windows directory.

I renamed it back again and opened WinMySQLadmin again and all was working fine.

It saves the my.ini automagically as indicated in the my.ini Setup tab
Last edited by Izzy on 27. August 2006 00:49, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby frouleau » 24. August 2006 15:59

Thanks for the help but still dont see anything. On the Start Check tab I see exactly what you see. On the Server,Variables & Process tab nothing listed and no Database tree on the Database Tab. I run W2K as OS. I also stopped Windows Defender & Antivirus and re-installed XAMPP. Same problem. !!!
frouleau
 
Posts: 3
Joined: 24. August 2006 04:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests