htaccess Problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

htaccess Problem

Postby thekingofcaseys » 20. August 2006 10:53

OK read the forum but nothing i could find on this problem.

Installed xampp all fine changed document root for my websites to

srv/domains/DOMAIN NAMES


however kept document root at

Program Files/xampp/htdocs


So problem is if i place a .htaccess file into HTDOCS and type in LOCALHOST in my browser i get the pop up box for username and password Now if i place the htaccess file in the root of my website i get nothing.

my question is how do i get my sites to use the htaccess file,

the url in question is www.seeders.co.uk
For One On One Xampp Support Try Me I May Know The Answer PM Or Email Or MSN
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby Izzy » 20. August 2006 11:32

Are you using the same .htaccess file in both locations?

This is not possible as the .htaccess for your htdocs directory refers to an xampp.user file in the xampp/security directory that is encrypted with the password and the htdocs directory path.

You will need to create another .htaccess/.htpasswd pair for your web site directory.

Google for generators.
Last edited by Izzy on 27. August 2006 01:02, edited 4 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby thekingofcaseys » 20. August 2006 14:51

i created a new htaccess file but nothing works it still shows the site and i used the generator also that didnt work

Example:

htaccess
AuthUserFile /srv/www/seeders.co.uk/.htpasswd
AuthGroupFile /dev/null
AuthName "Password Protected Area"
AuthType Basic

<limit GET POST>
require valid-user
</limit>


password file

Test:Tegj/We2QdsGU


Both placed in website root but still nothing works
For One On One Xampp Support Try Me I May Know The Answer PM Or Email Or MSN
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby maxnorris » 21. August 2006 15:39

thekingofcaseys wrote:i created a new htaccess file but nothing works it still shows the site and i used the generator also that didnt work

Example:

htaccess
AuthUserFile /srv/www/seeders.co.uk/.htpasswd
AuthGroupFile /dev/null
AuthName "Password Protected Area"
AuthType Basic

<limit GET POST>
require valid-user
</limit>


password file

Test:Tegj/We2QdsGU


Both placed in website root but still nothing works


Your file locations look Linux-ish.. AuthUserFile and AuthGroupFile in your setup above is listing a folder structure with it.. is that actually the folder structure that's on your system? It won't work if it cant find the files.
maxnorris
 
Posts: 17
Joined: 21. August 2006 06:51

Postby WorldDrknss » 21. August 2006 16:56

Test:Tegj/We2QdsGU

This is not an Apache Specific Password

Here is a correct .htaccess and .htpasswd

.htaccess
AuthUserFile /srv/www/domain.com/.htpasswd
AuthGroupFile /dev/null
AuthName "Password Protected Area"
AuthType Basic

<limit GET POST>
require valid-user
</limit>


.htpasswd
Admin:$apr1$zE3.....$nGJTynddgh/FcLX5P10CN0
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests