HELP ME!! People can't access my IP.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

HELP ME!! People can't access my IP.

Postby White Monkey » 16. August 2006 22:21

Right so I have created a forum using XAMPP and it looked like it was all working fine until I realised people can't type in my IP address and view my forum unless they are in my LAN. Please could someone help me as I have spent quite alot of money on the forum and it was a big shock and an upset when I just realised it dosn't work unless your in my LAN. Thankyou everyone.

p.s. I am curently registering a domain with it if that makes any difference.
White Monkey
 
Posts: 16
Joined: 03. August 2006 22:49

Postby White Monkey » 17. August 2006 13:37

Please could someone help me...
White Monkey
 
Posts: 16
Joined: 03. August 2006 22:49

Postby shutout5591 » 17. August 2006 18:38

There is much more to it that that. I use to have an xampp server...

1. Check which port apache uses and make sure your isp allows incoming packets with that port
2. Configure router to foreward packets with that port to your computers LAN address

Tell me how that goes...
shutout5591
 
Posts: 6
Joined: 02. April 2006 16:47

Postby White Monkey » 17. August 2006 22:50

shutout5591 wrote:There is much more to it that that. I use to have an xampp server...

1. Check which port apache uses and make sure your isp allows incoming packets with that port
2. Configure router to foreward packets with that port to your computers LAN address

Tell me how that goes...


I don't really know how to do that :( sorry, please could you tell me.
White Monkey
 
Posts: 16
Joined: 03. August 2006 22:49

Postby maxnorris » 21. August 2006 15:09

Setting up port forwarding varies depending on your network setup, but it's usually a simple thing. Basically, you need to tell your router which computer to send network data to when it receives on a particular port, in normal web use that would be 80.

(Note that I'm working under the assumption that your ISP isn't blocking port 80, you're not on a college dorm network, etc etc)

You need to edit your router's configuration. Most have some sort of web interface. Most LinkSys routers you can access via http://192.168.1.1 or something similiar.. check your router's documentation for that one.

On my router anyway (Linksys BEFW11S4), from the main configuration page, I'll hit "Applications and Gaming" on the top of the screen, and then under that "UPnP Port Forwarding". (This is for single ports, there's also a "Port Range Forwarding" page that works similarly)

On that page, I need to set three things. First, the port number to be forwarded. That would be port 80, on TCP. Then, I need to tell it where to send port 80 data too, that would be the local IP of the machine that's running Apache. And finally, I need to make sure it's actually enabled.

It varies from router to router but that's the general gist of what you need to do.. check your router's manual. You'll need to do this for most server type applications that need outside internet connections (FTP, mail which takes two ports, P2P, SSL web pages and so on.. client apps like mail readers and games and whatnot usually don't need this)

One suggestion, I recommend your Apache machine have a static IP, not one assigned by NAT (makes it a lot easier to keep port forwarding working properly, don't want your IP changing on you all the time)
maxnorris
 
Posts: 17
Joined: 21. August 2006 06:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests