Xampp 1.53 on windows xp sp2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp 1.53 on windows xp sp2

Postby eyekeeper » 15. August 2006 20:57

Hello!

I got Xampp installed and reinstalle it for many times but I still didn't get it to run...

When I look into the control panel it says that all the installed options are running (Apache, Mysql, FileZilla and Mercury) but when I check the status for mysql it shows me a red "deactivated" for MYSQL.

I have already read the FAQS on the main site and Through this topic I tried to check how mysql was responding and I get the following error: access denied for user ODBC@localhost...

I changed the my.cnf file within the xampp/mysql/bin folder and the same file under windows... set the user to root and pass to 123456, but still no change... I simply can't connect to mysql...

I've already been trying to run it for 3 days without success...
Anyone can help me further?

Thanks,

eyekeeper
eyekeeper
 
Posts: 3
Joined: 15. August 2006 20:13

Postby bluemamba » 15. August 2006 23:29

you must look into the Control Panel/Administrative Tools/Event Viewer for any mysql errors and analize that info.

after that, open Control Panel/Administrative Tools/Services, right click on "mysql" and look at the parameters for that service. Analize that info.

after that,
look into the XAMPPinstallDirectory/mysql/data for a file ending in "*.err" and analize the errors you find there.

Maybe you'll find the answer by yourself, if not, tell us what you've found on the logs.
bluemamba
 
Posts: 6
Joined: 04. June 2006 06:42

Postby eyekeeper » 16. August 2006 11:44

ok... thanks..
I could solve the mysql connection now
I looked at the error log and redefined the pass for root..
I had already done it but I don't know why it hadn't been changed.
At the status page it still says deactivated but through connection scripts it works :-)

Now a second thing...

when I try to start phpMySQL Admin I get an error saying the php extension wasn't loaded although the mentioned file is in the required directory and in the php.ini file it is uncommented, so I guess it should be loading...

Any ideias?
eyekeeper
 
Posts: 3
Joined: 15. August 2006 20:13

Postby Izzy » 16. August 2006 12:05

eyekeeper wrote:...Now a second thing...

when I try to start phpMySQL Admin I get an error saying the php extension wasn't loaded although the mentioned file is in the required directory and in the php.ini file it is uncommented, so I guess it should be loading...

Any ideias?
Are you trying to start it from the XAMPP Control Panel or from xampp/mysql/bin directory using the winmysqladmin.exe

What extension does it say is not loading?

Which php.ini file are you looking in?
xampp/apache/bin/php.ini
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby eyekeeper » 16. August 2006 12:27

Hello Izzy,

from the control panel it shows it is running without any errors...
after I setup my.ini file for winmysqladmin.exe I can start and run, see all information shown there in the winmysqladmin panel.

But when I point my browser to http://localhost/xampp/status.php the information for MySQL database says it is "deactivated" in red... further in the left navigation page under http://localhost/xampp I choose phpmyadmin link and there I'm redirected to an error page:

phpMyAdmin - Error (all with a red background) and the text says:
The mysql extension wasn't loaded. Check check the configurations for php"

the php.ini file is under xampp/php
eyekeeper
 
Posts: 3
Joined: 15. August 2006 20:13

Postby SlackPack » 22. August 2006 00:57

I'm having the same problem
SlackPack
 
Posts: 3
Joined: 21. August 2006 23:23

Postby SlackPack » 22. August 2006 01:22

I was able to get it to work by switching from php 5 to php 4
SlackPack
 
Posts: 3
Joined: 21. August 2006 23:23

Postby Izzy » 22. August 2006 01:34

eyekeeper wrote:...the php.ini file is under xampp/php

The php.ini file is in:
xampp/apache/bin/php.ini

@SlackPack
Try switching back to 5 and see if you get the same problems as before.
If you had to switch to 4 then the php scripts you are using are not 5 compatible as php is notorious for is backward incompatibility issues.

If you make any changes or want to check the extensions please use the above ini file.
Don't forget that a restart of Apache needs to be done when editing Apache .conf and .ini files so Apache can read your edits.

In the XAMPP Welcome Page there is a menu item in the left hand frame that is called phpinfo().
Click on this and it will give you all the php configuration info pertaining to your install.

If all this works and you can read the XAMPP Welcome Page then your php installation should be fine as XAMPP uses php to display content in these pages.

You will need to check that all is correct in your XAMPP Control Panel.

On the main window check that all Svc are checked on the services you want to start as a service.
All services checked are Running
Click on Status and check State 1 - Service 1 - Start 1 for all services running.

Clicking on Admin... for each service running will take you to the various services admin panels.

Click on Settings...
Check that all boxes that you want to start automatically on Windows start up are ticked.
Check that the path to service.exe is correct and it has the services you wish to start added after the exe - service.exe apache mysql ftp mercury

When you are happy with all that then you can restart Windows.
After Windows has restarted you should see an icon in the System Tray.
Click on it and check that all the above has stuck and all is still correct.

Now you can check your XAMPP Welcome Page menu items again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests