(Win)PHPMyAdmin and root 'localhost' Password

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby Oswald » 31. January 2003 12:08

Hello David!

Very, very strange. But your idea is good. Try out using 'http'. It will activate authentication via so called HTTP Auth. If you now access to your phpMyAdmin your browser should pop up a small dialog window asking for a user name and password. Substantially the same like 'cookie' but another technologie.

Many grettings from Berlin! :)
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby DavidMD » 01. February 2003 02:15

Hello, Oswald!

Thank you for your message.

I tried HTTP authentication in my experiments with Phoenix yesterday, but I got the same response (refresh and then the login screen).

I have gone back to 'config' and no password, which is not my preference, but at least it works. :(

If you have any ideas, Oswald, I would be grateful!

Thanks very much, Oswald! :)

Cordially,

David
--
http://ddickerson.igc.org/



Kai Seidler wrote:Hello David!

Very, very strange. But your idea is good. Try out using 'http'. It will activate authentication via so called HTTP Auth. If you now access to your phpMyAdmin your browser should pop up a small dialog window asking for a user name and password. Substantially the same like 'cookie' but another technologie.

Many grettings from Berlin! :)
Oswald
In a world of absurdity, we must
invent reason; we must create
beauty out of nothingness.

-- Elie Wiesel
User avatar
DavidMD
 
Posts: 23
Joined: 29. January 2003 02:41
Location: Hermitage, Tennessee, USA

password

Postby zappa » 01. March 2003 17:34

hi folks,

I'm absolutey!!! a NEWBIE in terms of wamp and lamp stuff!!
had the same password-problems as mentioned before. I solved this problem by not only adding a password but also changing the user 'root' to anything else. now it works brilliant!!

hope I could help
cheers
zappa

@ appachefriends:
thank you for that great stuff!!!!
tried to install WAMP' S before I knew about this <org> and always ended up with trouble!
BUT WITH YOUR HELP EVERYTHING WORKS FINE NOW!!! :)
zappa
 
Posts: 5
Joined: 01. March 2003 17:00
Location: Rodgau

Postby DavidMD » 03. March 2003 01:06

Hello, Zappa! :)

I thought I might give your approach a try, but when I try to access PHPMYADMIN, I get the following error:

> Welcome to phpMyAdmin 2.3.3pl1
>
> Error
>
> MySQL said:
>
> Can't connect to MySQL server on 'localhost' (10061)

I currently have no password in use, to get around the problem that I was having, but now I am locked out of PHPMYADMIN and I do not know why. (I have MySQL running as a services that launches on starup, so I know that it is running.) :shock:

Thanks!

David
--
http://ddickerson.igc.org/
In a world of absurdity, we must
invent reason; we must create
beauty out of nothingness.

-- Elie Wiesel
User avatar
DavidMD
 
Posts: 23
Joined: 29. January 2003 02:41
Location: Hermitage, Tennessee, USA

Postby zappa » 03. March 2003 11:51

hi david,
with the first installation I had a little bit of trouble getting the things work right because I changed the password (dreamweaver needs one) and lost controll of what I had done.

so I just deleted the whole wampp-folder and reinstalled wampp, taking absolutely care of the steb-by-step instructions.
I tested it without changing anything and it worked.

therafter I did that password-stuff.
remember these lines in the instructions!

------------------------------------------------------------------------------
MySQL starts with standard values for the user id and the password. The preset
user id is "root", the password is "" (= no password). To access MySQL via PHP
with the preset values, you'll have to use the following syntax:
mysql_connect("localhost","root","");
If you want to set a password for MySQL access, please make use of mysqladmin.
To set the passwort "secret" for the user "root", type the following:
C:\wampp2\mysql\bin\mysqladmin - u root password secret

After changing the password you'll have to reconfigure PHPMyAdmin to use the
new password, otherwise it won't be able to access the databases. To do that,
open the file config.inc.php in \wampp2\phpmyadmin\ and edit the
following lines:

$cfgServers[1]['user'] = 'root'; // MySQL user
$cfgServers[1]['password'] = 'secret'; // MySQL password

----------------------------------------------------------------------

now everything os OK!!

sorry, I can't give any other hints because I'm an absolutely WAMPP newbie!!

good luck
zappa
zappa
 
Posts: 5
Joined: 01. March 2003 17:00
Location: Rodgau

Postby zappa » 03. March 2003 11:57

here the last reminder that may cause trouble.
To use the MySQL Daemon with "innodb" for better performance,
please edit the "my" (or "my.cnf") in the /wampp2/mysql/bin
directory respective for Service the C:\my.cnf for NT/2000.
There, activate the "innodb_data_file_path=ibdata1:30M"
statement. Attention, "innodb" is not recommanded for 95/98/ME/XP Home.

To use MySQL as Service for NT/2000/XP Professional, simply copy the "my"
/ "my.cnf" file to C:\my, respective to C:\my.cnf. Please note that this
file has to be placed in C:\ (root), other locations are not permitted. Then
execute the "mysql_installservice.bat" in the mysql Folder.


I use windows 2000!!!
zappa
 
Posts: 5
Joined: 01. March 2003 17:00
Location: Rodgau

?? Funny question here---

Postby John » 12. April 2003 14:09

Hey!
Just curious but did you copy that *exactly*?
$cfg['Servers'][$i]['password'] = 'secret';
(?) Curious if maybe 'secret' is a password TYPE? Might just try this before I get a reply... but would be nice to figure it out!

:) Also I found a few nifty things out for those of you running Wampp with the use of .htaccess files: Windows by itself will *not* let you name a file without anything in front (a.htaccess will work but .htaccess gives 'you must supply a filename!') Found a trick to work that out! Just go to a command prompt, and type 'rename a.htaccess .htaccess' Works!
:( An issue I'm having with MySQL is that the 'install as service' batch file doesn't seem to work on Win2k for me. Not much of a problem since I can add myself or use a batch file, but I figured it would be worth a look-see!
:( Another problem: Where do I set the SERVER_ADMIN variable and stuff for the email link on the error pages?

If you want to contact me via e-mail: ariesiiiN0SP/\M@earthlink.net (anti-emailbot: remove n0sp/\m) I'd use the Mercury mail but I'm not sure if I trust my skill with these things yet:(

zappa wrote:hi david,
with the first installation I had a little bit of trouble getting the things work right because I changed the password (dreamweaver needs one) and lost controll of what I had done.

so I just deleted the whole wampp-folder and reinstalled wampp, taking absolutely care of the steb-by-step instructions.
I tested it without changing anything and it worked.

therafter I did that password-stuff.
remember these lines in the instructions!

------------------------------------------------------------------------------
MySQL starts with standard values for the user id and the password. The preset
user id is "root", the password is "" (= no password). To access MySQL via PHP
with the preset values, you'll have to use the following syntax:
mysql_connect("localhost","root","");
If you want to set a password for MySQL access, please make use of mysqladmin.
To set the passwort "secret" for the user "root", type the following:
C:\wampp2\mysql\bin\mysqladmin - u root password secret

After changing the password you'll have to reconfigure PHPMyAdmin to use the
new password, otherwise it won't be able to access the databases. To do that,
open the file config.inc.php in \wampp2\phpmyadmin\ and edit the
following lines:

$cfgServers[1]['user'] = 'root'; // MySQL user
$cfgServers[1]['password'] = 'secret'; // MySQL password

----------------------------------------------------------------------

now everything os OK!!

sorry, I can't give any other hints because I'm an absolutely WAMPP newbie!!

good luck
zappa
:lol: :lol: :cry:
John
 

HEY! Woot--Found out a way to do it!

Postby John » 12. April 2003 16:08

Okay!
As far as the password dealy goes--
here are my steps:

leave password blank in config.inc.php
start MySQL
log in on webpage - you get the evil red warning
go to "priviledges"
edit root/localhost
change password in the page
re-open config.inc.php
set passwords
DONE!!!!!! wheeeee

Hope this helps, and I think the mysqladmin -u root password **** is BROKEN. But the webconfig works perfectly :) now just to pray that outside users cant screw up the thing --- I'm still figuring out the security stuff :(
John
 

Hi, all friends!

Postby chanio » 14. April 2003 04:37

:twisted: :idea: :arrow: Please, don't panic!
I have been using the right configuration without any trouble for some days: Declaring the password in the inc. file with cookie.
I have now tried what you where speaking about, and now, I can sum myself as another one in disgrace.
But let me ask you something:
Have you considered restarting the server before arriving to any conclusion?
I don't know what keeps on living in the system's memory, but I cannot return to my previous condition! That is not possible, just for erasing the password and then writing it again! I restarted the browser (any IE or NS) and the login won't accept my root password even after declaring it in the .inc file! I can enter as root without password (that is the default root user without password). But nothing else.
I had some problems with the localhost password before. But worse , because the MySQL service couldn't start. It did start by manual.
The service message said that the root@localhost password was incorrect, and then it crashed. Then, I installed it all again and solved the previous problem.
So this password thing, carries a lot of history.
But what confuses me more is that any change seems to not affect the actual configuration instantly. :roll:

Besides, MySQL and PHPmyAdmin:
As a security for your system, did you consider installing a firewall like
Zone Alarm?.
With it, you can forget about your paranoia by dosifying it every time that the program asks you if you allow certain program to connect in/from Internet. You are asked to allow or not allow every connection and also tell the program to remember your answer. I think that in the paid version you can even have virus protection with it, and technical solutions. But the program works so well that you might never have any trouble with it.
Hope it helped
alberto
Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina

Solved for me as I thought

Postby chanio » 15. April 2003 05:55

Yes, it was just a matter of rebooting the machine. To avoid other problems, I configured the .ini file with my password and without cookies. Works fine!
Should work fine with you also.
Alberto :P
Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina

Did any o fyou check out the MySQL thread I posted?

Postby John » 26. April 2003 04:42

Hey... the cure (at least for me) I posted a while back... check the thread "The cure for the MySQL woes". Perhaps I shoudl have called it PHPAdmin woes??
John
 

Oops. And I can't edit above post!

Postby Guest » 26. April 2003 04:50

Well... the actual thread name is "Solutions to the mySQL woes!"
It has worked for me several times now (I have managed to mess up the server trying to get some PHP and CGI scripts to work)

BTW, does anyone know how to get the server to insert my WAN IP into a page? Only thing I've been able to find is a PHP script that blows up--think it was designed for linux :(
Guest
 

Postby AlexPausB » 26. April 2003 12:24

Hola,

with PHP you can easily display your wan-ip with the variable "SERVER_ADDR".
The following code works with linux and windows (i just tested)

Code: Select all
echo $SERVER_ADDR


Otherwise you can use ssi (server side includes) to show off your ip.

Code: Select all
<!--#echo var="SERVER_ADDR" -->


Bye!
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Just tried that. Didn't work :(

Postby Liath » 08. May 2003 15:43

I put a new thread up in case anyone else has this problem, and since its off topic
Liath
 
Posts: 12
Joined: 08. May 2003 15:18

possible solution

Postby Phrozin » 22. June 2003 07:30

Ok, I know this seems simple enough, and sometimes it's the simple things we over look, but have you guys tried setting your privacy setting lower, or adding your site to your "manage sites" list?

Yes I know, "i've allowed cookies" I was yelling the same thing at my screen for 15 minutes before it hit me lol. See I don't use MyAdmin, so I've never had this problem before. I saw your troubles so I started trying to figure it out, this is what I found out.

Could not find a Privacy Policy for http://127.0.0.1/phpmyadmin/index.php.


So now I went to my tool bar in IE and clicked Tools -> internet options... -> privacy -> and clicked the edit button on the bottom in web sites area.

once there I entered 127.0.0.1 and my domain name (www.your_sites_name.com) and clicked Allow after each. Poof! everything now works like a charm, I have cookies enabled in config.php.inc root as user and no password set. when I enter my username "root" and my password on login it now works perfectly.

Also as a bonus!!!!!!!!!! (can you tell I like this part? lol) you can now Logout of phpadmin! Now I might start using it. I hate not being able to logout. Anywho, I'll throw up some screen shots as soon as my passwrd is emailed to me to verify my email address. In the mean time I hope this helps
Phrozin
 

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests