Can just see my website from my local IP. :(

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can just see my website from my local IP. :(

Postby Milkon » 12. August 2006 15:30

As the topic says.

I cant see it from my global. I have been configure the router and opend the ports that should be open and i have disable my firewall. It most be some confiuration somewere that not match with my conection och computer.
Thx for an answer.


//Milkon :P
Milkon
 
Posts: 5
Joined: 12. August 2006 15:22

Postby Izzy » 12. August 2006 23:48

Even though your translation into English is not bad I still can not understand your question.
Could you please give more details and try and get someone to translate your problem for you.
Thanks.
Last edited by Izzy on 27. August 2006 01:14, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Milkon » 13. August 2006 10:51

I have been trying to put up an php website to make accounts for a game. Its works greate to put up them so i can see them from my local IP but when someone else wont to see it from my public ip it doesent work. I hope you understand now...
I really need help with this, have been trying for many days now...
Milkon
 
Posts: 5
Joined: 12. August 2006 15:22

Postby Izzy » 13. August 2006 10:59

Milkon wrote:I have been trying to put up an php website to make accounts for a game. Its works greate to put up them so i can see them from my local IP but when someone else wont to see it from my public ip it doesent work. I hope you understand now...
I really need help with this, have been trying for many days now...

So if I understand you, this works:
http://127.0.0.1/yourwebsite

But this does not:
http://123.123.123.123/yourwebsite

Is that correct?
Last edited by Izzy on 13. August 2006 11:58, edited 2 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Milkon » 13. August 2006 11:48

I can see it from 127.0.0.1

But not from my public IP.
Milkon
 
Posts: 5
Joined: 12. August 2006 15:22

Postby robsy » 13. August 2006 11:49

Assuming your A-records for your domain are pointing at your ip and you have made the right port forwarding settings on your router, the problem must be in the setup of the httpd.conf. Maybe Izzy can tell how Apache grabs the request headers for your web site, but it should be pretty straightforward.
I bet you tried http://<global-ip>/, so what I would do is to get a remote portscan from a site like http://grc.com they have a service called shields up and see if the port you are using to serve your web pages are open, that is if you dont use port 80.
You need to supply more information for the community to troubleshoot your problem :) Alslo check your dns records with nslookup might give you a clue to where the problem is
robsy
 
Posts: 5
Joined: 05. August 2006 13:50

Postby Milkon » 13. August 2006 12:23

yes, but what should i change in the file? :roll:
Milkon
 
Posts: 5
Joined: 12. August 2006 15:22

Postby Izzy » 13. August 2006 12:31

You can try this:

Open the xampp/apache/conf/extra/httpd-vhosts.conf file in your text editor.

Add these entries at the end of the file.

Change the details to your own.

C:/xampp/htdocs change this to the path to your htdocs.

123.123.123.123 is your public IP

C:/xampp/htdocs/yourwebsite change this to the path of your web site.

yourwebsitename is the name of your web site - example gamesite
Code: Select all
NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
DocumentRoot "C:/xampp/htdocs"
ServerName localhost
</VirtualHost>

<VirtualHost 123.123.123.123:80>
ServerName yourwebsitename
DocumentRoot "C:/xampp/htdocs/yourwebsite"
<Directory "C:/xampp/htdocs/yourwebsite">
Options Indexes FollowSymLinks
AllowOverride FileInfo
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Milkon » 13. August 2006 15:59

Ok, i made is it stands i think but it still dont work. :S


Iam really get sad about this :cry:
Milkon
 
Posts: 5
Joined: 12. August 2006 15:22

Postby Izzy » 14. August 2006 00:44

Did you follow the instructions in robsy's post?
Are you sure that you have set up your router correctly to do what you want to do? Double check your router and firewall configurations.

Check your hosts file in C:\windows\system32\drivers\etc using a text editor. Add your IP if it is not there and follow the instructions included in the file. Google for hosts file for some useful reading.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests