webdav troubles

Problems with the Windows version of XAMPP, questions, comments, and anything related.

webdav troubles

Postby robsy » 05. August 2006 14:04

I an trying to get webdav to work in xampp and I have looked at the different conf files in the extra conf folder and commented out the most restrictive parts but when I do a telnet localhost 80 I get something like this
OPTIONS /WEBDAV HTTP/1.1
Host: *
Accept: *

HTTP/1.1 200 OK
Date: Sat, 05 Aug 2006 12:49:49 GMT
Server: Apache/2.2.2 (Win32) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b mod_autoindex_co
lor PHP/5.1.4
Allow: GET,HEAD,POST,OPTIONS,TRACE
Content-Length: 0
Connection: close
Content-Type: text/plain

Where are all the other methods supported by webdav??
Last edited by robsy on 07. August 2006 09:11, edited 1 time in total.
robsy
 
Posts: 5
Joined: 05. August 2006 13:50

Postby Izzy » 05. August 2006 14:29

In the readme-en.txt file in the xampp directory there is a note to uncomment the mod.dav entries in the httpd.conf file. Did you spot that and will that help with your problem?
(3) To use Mod_Dav load the Modules
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby robsy » 06. August 2006 10:06

Yup yup actually they were already uncommented in the zip distribution I downloaded. Besides if you look at the header that apache returns it says DAV/2 which I presume is the webdav module "speaking"
Anyway I tried in the <Directory "/xampp/webdav">
to set <LimitExcept GET POST OPTIONS PROPFIND>
Order allow,deny
Allow from all
</LimitExcept>

But as you see it's not the methods returned by Apache, weird huh?
robsy
 
Posts: 5
Joined: 05. August 2006 13:50

Webdav might or might not be working !?

Postby robsy » 07. August 2006 09:07

Okay I made it work partly but for some strange reason I had to do a AllowOverride None anyway the respone from Apache should look a little like this:

OPTIONS / HTTP/1.1
Accept: *
Host: localhost

HTTP/1.1 200 OK
Date: Mon, 07 Aug 2006 07:57:34 GMT
Server: Apache/2.2.2 (Win32) DAV/2 mod_ss
lor PHP/5.1.4
DAV: 1,2
MS-Author-Via: DAV
Allow: OPTIONS,GET,HEAD,POST,DELETE,TRACE,PROPFIND,PROPPATCH,COPY,MOVE,LOCK,UNLOCK

Content-Length: 0
Content-Type: httpd/unix-directory

But as you see a lot of webdav options are still missing and it really bakes my noodle another thing is that when i try to put in the directive DAVLockDB "/xampp/htdocs/DAVLock" I get an error, whats wrong with the syntax?

BTW for those of you who wants webdav to work you have to put in DAV On inside the <Directory> in the httpd.conf file or you can use <Location>
robsy
 
Posts: 5
Joined: 05. August 2006 13:50


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests