Hi, I want to re-install activeperl - any suggestions?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Hi, I want to re-install activeperl - any suggestions?

Postby chanio » 02. August 2003 09:10

:lol: Hello friends,
Does anybody have any suggestions, about reinstalling ActivePerl over the installed one? (its my first time)
I didn't wanted to, but it happens that I already had ActivePerl installed at another drive and it is now messing with this one.

:idea: My brilliant idea, is now to :
1) copy all my other modules over Wampp2's Perl lib.
2) deleting the other drive's ActivePerl
3) reinstalling all over previous Wampp2's ActivePerl

:lol: Why?
Because I thought that both installations might live together and share modules by declaring PERL5LIB Win environment variable.
Don't do it! It messes all the modules, and crashes PPM3, and installs all the modules at your first declared PERL5LIB path.
Mine was, fortunatelly, Wampp2's perl library, so I might have nearly all the modules correctly installed to re-install ActivePerl over it.

:roll:(wish me luck)
Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina

Postby Guest » 03. August 2003 11:57

Make a back op of the config file and webroot from wamp,
The remove it, and remove the 2nd instalation of active perl,
Then reinstall wamp, and copy your config back and your set
Guest
 

Postby phoenix » 03. August 2003 16:00

Hi

Perhaps I'm missing something here (I usually do :cry: ) but isn't the version of perl included with the latest XAMPP the ActiveState version?

Regards

Bill
phoenix
 
Posts: 3
Joined: 31. July 2003 19:05

Thanks 4 the advice

Postby chanio » 03. August 2003 22:15

:lol: Yes, it is ActivePerl. And works great!
But, I had another copy at another drive, and when I created an Environment Variable called PERL5LIB (not necessary but I thought it might help find some modules installed at my other lib in the copy) perl started to mix all up until it recently said in an error that perl was not installed in one of my directories. That isn't logic since all the subdirectories that have as parent my htdocs one should be supported by perl.
Some other strange things like loosing the registry values, started happening and now, I would not go back to my previous and stable state but start all over with a new and only ONE perl version running in my machine.
This is another way of learning about this great server and about perl.
I know that I will sweat some litters of addrenaline for a while, but I am curious about the results. I would like to keep as much of my installed modules as I can.:lol:
Thanks again.
Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina

results of my intent of merging both Perls...

Postby chanio » 11. August 2003 04:50

:lol:
ActivePerl can't be installed at other place but in the default path. I wouldn't be compilling it. So I guess that I must be happy having two separate ActivePerls (one for each drive).
I did the following...
* Backuped Wampp2 (bah, kept all the folder where it was...
* Unpacked the brand new XAMPP at the new D:\xampp\ folder.
* Copied all my C:\Perl\lib and C:\Perl\Site\lib files at D:\xampp\Perl\ folder.
* Uninstalled ActivePerl at drive C:
* Tried to Install it over D:\Xampp\Perl and discovered that it would only allow the option by default at C:\Perl.
* Copied a new unzipped Xampp on top of the previous one (to solve some possible problems with default libraries.
* Passed my previous pages and scripts on the new folders.
* Replaced in a batch fashion all the wampp2\ words at .pl, .cgi, .php*, .?htm* file extensions with xampp\.
* Copied by hand my previous httpd <directories> configuration to the new httpd.conf.
* Started all and everything worked justt fine.

You wouldn't say that I risked much in all this, but since changing the default ActivePerl folder is only possible by: 1) recompiling 2) moving it all at a shorter folder name (and nothing is shorter that c:\Perl...).
I quited doing the merging.

Notice that the only real solution applied was basically that I removed the previous PERL5LIB environment variable.

Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests