upgrade issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

upgrade issues

Postby saithilak » 01. August 2006 04:08

Hi all,

I have installed xampp (for windows) in my machine in the local network. The set up was fine & the applications working fine. I find a new version of xampp being released, now and then. How do i upgrade my files with latest xampp files, without altering my application setup.
saithilak
 
Posts: 2
Joined: 01. August 2006 03:59

Postby Izzy » 01. August 2006 05:13

This from Xampp For Windows page:
http://www.apachefriends.org/en/xampp-windows.html
Practice 4: The XAMPP upgrades
When individual components of the XAMPP collection are upgraded, we will bring XAMPP up to date as well. However, some developments are not compatible to our last release and so we cannot upgrade these elements. Usually we are able to update all servers and programms in XAMPP. NOT the configuration files because you could have modified them. Tip: If you have the installer version it is much easier to use the installer upgrade. All others should take the (7-)ZIP archive. Extract that package in the XAMPP folder directly and overwrite the older files.
The whole page is worh a read.

You might like to read the FAQ which does not have upgrade details but is also worh a read.
http://www.apachefriends.org/en/faq-xampp-windows.html

HTH :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 03. August 2006 06:57

I did as recommended above and I lost all my database connections, specifically the one for zencart. Any idea what went wrong? I get this error message: Sorry!
There seems to be a problem connecting to our database. Please give us a few minutes to remedy the problem. Thank you.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 03. August 2006 07:42

Please provide more info of what you did like version upgrade from and to.
Any and all complete error messages. As much info as possible so there can be more than a guess answer to your problems. ;)

You should always backup data in your databases and any configuration files when ever you anticipate there may be file overwriting, as in upgrades.

Use phpMyAdmin to check your databases are intact.
Check your scripts config files have the correct database access details:
Host
User
Db name
User password.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 03. August 2006 14:03

I upgraded from 1.0 to 1.5.3a. phpmyadmin let me in at first after the upgrade and all the databases apeared intact, but now it won't even let me into that.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 03. August 2006 23:19

jcpahman77 wrote:I upgraded from 1.0 to 1.5.3a. phpmyadmin let me in at first after the upgrade and all the databases apeared intact, but now it won't even let me into that.
There is no upgrade to 1.5.3a. You need to do a clean install and copy over your backups to the new install.
XAMPPWelcomePage wrote:The XAMPP 1.5.3a (SSI bug fixed) is available!
(1) There is no upgrade available for this version because the security leak problems described by Thierry Zoller can not be solved.

What error messages did phpMyAdmin give you?
What other, if any, error messages are produced?
Paste them in here.
How did you do the upgrade/install?
Did you use the zipped archive for your install or the exe installer version?
Did you use the setup_xampp.bat after installing to make sure your paths were setup correctly?
Did you check all your user/pass information has not been deleted or over written when you did your 'upgraded'?

You may have a corrupt install. I can only suggest, that if all else fails, to do a backup of your data and configurations then do a clean uninstall and then do a fresh clean install of XAMPP 1.5.3a. Then reinstate your data and configurations.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 04. August 2006 03:28

I should have been more clear. When I said "upgraded" I ment it in the strickest sence. I ran the installer and did make sure the directory was correct. Apache seems to work fine, anything that doesn't require a database connection is giving me no errors. With a little more work I was able to log into phpmyadmin with the default account but it says I have no privileges. I know there is a file or string I have to run in order to change the control user/pass but I can't remember how to do it. When I log in now it says I have no permissions.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 04. August 2006 03:36

Can you select any menu items in phpMyAdmin?
If so click on Priveleges.

If not paste the actual error messages and what page is in the address bar of your browser. localhost/phpmyadmin etc.

By default the mySQL and phpMyAdmin user is root and if you set the password for root in the Security page of XAMPP Welcome screen then the root user has full permissions or priveleges.

If you created a new user newuser and logged in using it, then you will have to give that newuser priveleges and give it access to a database of your choice.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 04. August 2006 03:46

I have a list of options on the page localhost/phpmyadmin such as:

Show MySQL runtime information
Show MySQL system variables
Show processes
Character Sets and Collations
Storage Engines
Databases
Export
Import
Log out

No where is there an option for privilleges though.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 04. August 2006 03:53

What user name are you logging in with? Because you are not logging in with the root user as it has full permissions as would be expected for the root user.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 04. August 2006 03:57

user: pma
pass: N/A

I've tried root to no avail, I'm sure it exsists I just can't get it to let me in. The config.inc.php file shows no password for root.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 04. August 2006 04:14

Here is what I did.

Go to the Security page from the XAMPP Welcome (start) page and Click on:
http://localhost/xampp/xamppsecurity.php

You will see text boxes for Root - Super user to add or change the password.
Leave Current Password blank
Add a New Password
Repeat the New Password
Select Cookie for PhpMyAdmin authentification
Click on Password Changing.

Now restart your mySQL services (although this is not usually required).

To check things look in xampp/security/mysqlrootpasswd.txt it should have:
mysql user = root
mysql password = ThePasswordYouCreated


You can also check this file before you start the above proceedure.

Now try and login again with root not pma as pma or any other user has no permissions to do anything until you grant them to it using the super user root or you create a database under that user.

The config.inc.php will always show a blank password for root.
Last edited by Izzy on 04. August 2006 04:42, edited 2 times in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 04. August 2006 04:40

Izzy wrote:Here is what I did.

Go to the Security page from the XAMPP Welcome (start) page and Click on:
http://localhost/xampp/xamppsecurity.php

You will see text boxes for Root - Super user to add or change the password.
Leave Current Password blank
Add a New Password
Repeat
Select Cookie Authentication
Click on Password Changing.

Now restart your mySQL services (although this is not usually required).

To check things look in xampp/security/mysqlrootpasswd.txt it should have:
mysql user = root
mysql password = ThePasswordYouCreated


You can also check this file before you start the above proceedure.

Now try and login again with root not pma as pma or any other user has no permissions to do anything until you grant them to it using the super user root or you create a database under that user.
I tried this (just now) and it doesn't give me an error message or anything but it won't let me log in with the new password. I'm worried that there may be an old password that I have forgotten.

Izzy wrote:The config.inc.php will always show a blank password for root.
Hillarious
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Postby Izzy » 04. August 2006 04:57

Izzy wrote:
The config.inc.php will always show a blank password for root.
Hillarious
Not really as the file I asked you to check above xampp/security/mysqlrootpasswd.txt is checked for the root password.

Another thing you can try is to manually change this line in config.inc.php as often this might block you:
$cfg['Servers'][$i]['auth_type'] = 'config';
// Authentication method (config, http or cookie based)?

To
$cfg['Servers'][$i]['auth_type'] = 'cookie';
// Authentication method (config, http or cookie based)?

Allow localhost to set cookies in your browser.
Clear your browser's cache often when doing development work. The cache can be your worst enemy at these times. Disable it for your particular browser then you can enable it for normal surfing when you are finished developing.

Also in relation to the above root access a comprehensive how-to for the command line is contained within the readme-en.txt file located in the xampp directory. Worth a read. ;)

If all else fails and you have followed all the instructions, FAQs and searched these forums for similar issues then a clean reinstall might be in order to clear out any problems you might have introduced. XAMPP will run straight away after install 'out of the box' with no problems at all. Problems occur usually when people try and change things before reading or knowing what the consequences are of making these changes or how to correct the changes if they break things.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jcpahman77 » 04. August 2006 05:18

Ok I did an uninstall and reinstall and now phpmyadmin won't let me in.

localhost/phpmyadmin

Welcome to phpMyAdmin 2.8.1

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

Error
MySQL said:

Cannot connect: invalid settings.
jcpahman77
 
Posts: 11
Joined: 03. August 2006 06:51

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests