Server error! When i try to access a php page

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Server error! When i try to access a php page

Postby savo » 26. July 2006 10:44

Dont know if anyone can help but i just got everything installed and running ok ( after days of trying to do it manualy) The only problem is the whole point of the server is to host databace for me but when i try to access the install page i get the error below.

I assume it is becasue the dir is set to readonly but i cannot remove the read only.

Any one got any ideas?

Thanks Sav



Server error!


The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
savo
 
Posts: 5
Joined: 26. July 2006 10:34

Postby Izzy » 26. July 2006 10:58

Check what the server error log has to say as it may be able to give you more specific details as to why it's chucking a wobbley.

xampp\apache\logs\error.log

The error mesage returned to the browser does not give the right answers on a 500 error which is really a catch all error message for the server.
I assume it is becasue the dir is set to readonly but i cannot remove the read only.

Why not?
Right click on the xampp directory any directory you want to remove Read-only properties then select Properties.
Click on the box next to Read-only
Click on Apply
Click on Apply changes to this folder, sub-folders and files.
Click OK
Done.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby savo » 26. July 2006 11:16

I know it should be simple but that doesnt seem to be the case as soon as i uncheck it and press aply it goes through all the files then i click ok and when i go back its checked again.

The log is says

[Wed Jul 26 12:10:26 2006] [alert] [client 127.0.0.1] C:/server/xampp/htdocs/meshtrak/main/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Is there a simple way to fix the .htaccess ? do i just change the dicrectory path ?

Code: Select all
#php_value include_path ".:/home/timbuktu/configs:/home/timbuktu/include:/home/timbuktu/smarty_2_5:"
RewriteEngine On
RewriteRule ^request/([^/]*).html$ index.php?request=$1 [L,QSA]



So guess its not the read only then. I will have to look into that because all folders on all drives are the same.

Thanks for your help

Sav
savo
 
Posts: 5
Joined: 26. July 2006 10:34

Postby Izzy » 26. July 2006 11:28

Thats better that tells you exactly what's wrong.
As a quick workaround untill you clear up the mod_rewrite syntax is to just quickly rename the .htaccess files to say temp.htaccess. Then you can start your server.

You will have to read up on the mod rewrite syntax to fix it.
http://httpd.apache.org/docs/1.3/mod/mod_rewrite.html
is a good starting point.
A google for key words apache mod_rewrite will give you lots of reading

You will also have to make sure the mod_rewrite module is accessable by the server by checking the httpd.conf file.
#LoadModule rewrite_module modules/mod_rewrite.so
to
LoadModule rewrite_module modules/mod_rewrite.so
This may be enough to get you going and you should check this first.

Good luck :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby savo » 26. July 2006 11:35

Thanks alot, have played with mod rewrite before and had it going so shouldnt take me to long.

Saying that i had apache and php running fine before but no luck this time.

Thanks again

Sav
savo
 
Posts: 5
Joined: 26. July 2006 10:34

Postby savo » 26. July 2006 11:37

just removing the # got it all going fine (i had already changed paths)

Thanks again
savo
 
Posts: 5
Joined: 26. July 2006 10:34


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests