Configured Vhosts and now I get 403 errors for all sites

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Configured Vhosts and now I get 403 errors for all sites

Postby burgermeister » 18. July 2006 19:33

I just added in 5 entries into the httpd-vhosts.conf file and now no matter how I try to get to my server (http://localhost/ http://127.0.0.1 http://www.zpanelhost.info) I get a 403 Forbidden... How do I fix this because I need my subdomains to work.

It's not my computer because I've used Uniform Server and set-up vhosts without any problems. Please help me!
Last edited by burgermeister on 18. July 2006 23:30, edited 1 time in total.
burgermeister
 
Posts: 8
Joined: 18. July 2006 19:22

Postby burgermeister » 18. July 2006 23:29

I don't need to re-install do I?
burgermeister
 
Posts: 8
Joined: 18. July 2006 19:22

Postby Izzy » 19. July 2006 00:56

It may help if you post what changes you made in the httpd-vhost.conf file as any errors in this file will have disasterous consequences.

The error message tells you what is amiss here.

Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.


Check you directory paths in the httpd-vhosts.conf are indeed correct then double check them ;) then make sure that an index file, index.html or index.php etc. is present in those indicated virtual host web root directories.

Also check the permissions or in Windows they call them Properties is not set to read-only. change them and re-start Apache. Always restart Apache when you make changes in any of the .conf files in the Apache conf directory or it won't know of the changes you have made.

Should be no need to re-install because if the httpd-vhosts.conf is incorrect or as indicated by the error message there is no index file or permissions are incorect then you will only get the same result.

If it's any help I installed zpanel on a test domain and it creates accounts and functions as it should with no problems in XAMPP. Make sure all the paths in the zpanel configuration point to the correct places within the XAMPP tree.

Good luck! :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby burgermeister » 19. July 2006 04:07

Turned off read-only and it works... thanks for the help!
burgermeister
 
Posts: 8
Joined: 18. July 2006 19:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests