Apache problem with files largeer then 10k

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache problem with files largeer then 10k

Postby s_mannem » 16. July 2006 20:15

I just started out with Xampp. I'm having some problems with Apache
It seems that all files are corrupted after 10k of binary data. This applies
to pictures, but also to the HTML files. When I open them directly in the htdocs folder they look fine, but when I open them through Apache (open IE and type the IP-adres of my server in the adress bar) the larger HTML-files and pictures are distorted. I've been trying to solve this for three days now, without result. I have reinstalled XAmpp, cleaned up the HTML-files (created with MS Publisher, cleaned up with DreamWeaver), adjusted some settings in httpd.conf and PHP.ini, but have had no luck with it so far. For some examples, just take a look at 'http://192.168.0.250/oldhome/Stamboom.htm' (top bar picture distorted, text not properly displayed, tree picture distorted, etc). It's a mess. Please help.
s_mannem
 
Posts: 2
Joined: 16. July 2006 19:36
Location: The Netherlands

Postby Wiedmann » 16. July 2006 20:31

Change the setting for "EnableSendfile" in "httpd.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Apache: Problems with files larger then 10k

Postby s_mannem » 16. July 2006 22:17

Wiedmann wrote:Change the setting for "EnableSendfile" in "httpd.conf".


:D
IT WORKS.
I tried it before with both options set to ON.
Now have 'EnableMMAP off' and 'EnnableSendFile ON'.
Many thanks. :wink:
s_mannem
 
Posts: 2
Joined: 16. July 2006 19:36
Location: The Netherlands


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests