PHP Applications not working in XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP Applications not working in XAMPP

Postby radiobob » 14. July 2006 19:47

Posted: Fri Jul 14, 2006 11:29 am Post subject: PHP Apps Not Working in XAMPP

--------------------------------------------------------------------------------

Hello:

I recently installed XAMPP for Windows version 1.5.3a on XP SP2 and everything seems to work fine. I can execute individual php files, but applications are not working. I downloaded two simple freeware click tracking apps, (ccount and tclick) and the problem with both of them seems to be that variables are not getting passed from one script to another within the application. Or perhaps that is the symptom to the problem that I am unable decipher. I really don't think it is the apps themselves, I think it is my deployment or the environment.

Cheers if anyone has any ideas,
Bob
radiobob
 
Posts: 2
Joined: 14. July 2006 19:35

Postby Wiedmann » 14. July 2006 20:34

What was the answer from the software support for these apps about this question?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby radiobob » 14. July 2006 20:47

Hi, thanks for your reply. They are just free scripts, no support is offered. For example ccount is from PHPJunkyard / Hotscripts. Since 15 people reviewed it and said they got it working easily and gave it 5 stars, I figured it was a problem with me!
radiobob
 
Posts: 2
Joined: 14. July 2006 19:35

Postby Wiedmann » 14. July 2006 22:28

I figured it was a problem with me!

"it was" => So your problem is solved?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Izzy » 15. July 2006 00:08

radiobob wrote:...I downloaded two simple freeware click tracking apps, (ccount and tclick) and the problem with both of them seems to be that variables are not getting passed from one script to another within the application...

In Windows XP the default permissions/attributes of files and directories is Read-only. This may stop variables from being passed/written to each other.

You would need to change that behavior by right clicking on the directories/folders involved and selecting Properties (down at the bottom of the list). You may need to be a user with administrator privileges to do this.

Then click on Attribute: Read-only to remove the check or square block mark.

Then click on Apply.

Then check the box next to Apply changes to this folder, subfolders and files.

Then click on Ok and try your applications again.

If that didn't help, you may be up shit creek without a paddle :).

Good luck!
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 80 guests