how do i make my XAMPP installation public?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

how do i make my XAMPP installation public?

Postby ax0rz » 14. July 2006 15:50

hi. i installed XAMPP and everything works great blahblah under "http://localhost"... but when i try to access the server by typing in my IP address, it asks me to enter username & password for "WebAdmin" (which i don't remember setting!!!!)... and then gives me the following error:

[b]Authentication Failed[/b]
Web configuration is protected.
Return to the last page to authenticate.

what's going on?

also, what security settings should i keep in mind while making my XAMPP installation publicly accessable?

any help would be appreciated! thanks!
ax0rz
 
Posts: 3
Joined: 14. July 2006 15:24

Postby ax0rz » 14. July 2006 15:55

also, i think this question should be in the FAQ! :twisted:
ax0rz
 
Posts: 3
Joined: 14. July 2006 15:24

Postby WooshMan » 14. July 2006 16:08

If you are behind a router you need to open port 80 for standard access and 433 for SSL.

You should secure xampp using http://localhost and follow the security advice in there.

For pure ease put your html files in the htdocs folder.

Thats it.

WooshMan
WooshMan
 
Posts: 33
Joined: 10. November 2005 23:03

Postby ax0rz » 14. July 2006 19:29

WooshMan! You're absolutely correct. But I'm having problems! :P

I looked at my router settings (Huawei MT841), and found "WAN Access" and made the following settings:

[code]HTTP Access Enable: Enabled
IP Address: *
Access Port: 80
[/code]

However, when I tried my accessing my IP address (not localhost), it took me to a summary of my router settings! Arghhh! What am I doing wrong here?

(edit: atleast, this time, it didn't ask me for a username & password! :P)
ax0rz
 
Posts: 3
Joined: 14. July 2006 15:24

Postby WooshMan » 15. July 2006 10:16

You need to turn off what your turned on. You have allowed http access to your router settings from the outside world. Turn it off quickly.

You need to look for something named:

Virtual Host
Port Forwarding

Or something like the above.

If there are any predifined settings allow the http rule on port 80 and point it the the internal ip address of the pc running xampp.

If there isn't a predefined rule, add http, port 80 and then point to ip internal address.

Failing that, read the user guide supplied with your router as they vary.

Good luck.

WooshMan
WooshMan
 
Posts: 33
Joined: 10. November 2005 23:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests