Page 1 of 1

Trouble with XAMPP/Perl on WinXP boxes

PostPosted: 04. July 2006 20:21
by vegtabill
***note: this is a duplicate of my post at***


I am currently working with the local community college to devise an educational/development all-in-one tool that they will use for a variety of classes (Java, PHP, Perl, XML, HTML, etc, etc). This is a pretty involved thing, using Eclipse (+ many plugins), XAMPP, Tomcat and more. The trick is, it all has to be runnable from a removable drive. XAMPP is, of course, a perfect fit for this. Among other things, it provides Apache, MySQL, PHP and Perl (with the add-on). I have it pretty much ironed out and running quite well on my machine at home. It's also running well on a couple of the professor's machines I've been working with.

Here's the problem: When I finally got a version ready to test at the school, Apache failed to start. Checking the logs, I found the cause to be that it could not load Perl mod Apache::ASP. We won't be doing any ASP stuff with Perl, so I went into the perl.conf file in Apache and commented out that section. The good news is that Apache started normally after that. The bad news is that I got a new error on the modperl info page, indicating that it can't locate DBI method "available_drivers". (By the way, if it's not terribly obvious, Perl is *not* something I'd claim to be knowledgable in.) My suspicion is that whatever was conflicting with Apache::ASP is actually conflicting with more than it appears on the surface. Unfortunately, I'm really not sure where to start looking. I've tried disabling IIS... even unistalling IIS... that wasn't it.

Further complicating matters is the fact that the machines at the school all get imaged for the semester at the same time. So if it won't run on one of the lab computers, it won't run on any of them. We're hoping to figure out the problem ASAP because this tool (Eclipse, XAMPP, et al) will be imaged along with the rest of the school's software next week. It would be good to be able to put a version on the image that will run, needless to say! (I know, I said it had to run from a removable drive... and it does! We have a growing number of distance learning students that can't install software where they do their work. Nevertheless, we're going to use the same software in the classrooms/labs, so besides being portable, it will also be on these machines.)

I apologize for getting long-winded... it's a weakness of mine! My question would be this: Has anyone heard of similar conflicts and, if so, where should I look for an answer? The machines in question are all Win XP Pro (SP2) boxes. They all have IIS, Visual Studio, and of course .Net2. I've configured Apache to run on port 8880, so the port 80 problem should not be an issue. I believe these machines also have Macromedia Studio 8 on them, so it occurred to me that ColdFusion might have something to do with it, but I haven't had an opportunity to explore this as of yet.

I'd be *very* appreciative of any input I can get on this. Thanks very much in advance!


PostPosted: 06. July 2006 02:41
by vegtabill

I found two processes running on the lab machines that I did not recognize right off: TNSLSNR.exe and isqlplussvc.exe. As it turns out, these are both associated with Oracle listeners. Any idea if this could be the source of the conflict? And if so, anyone know of a work-around in XAMPP?


PostPosted: 06. July 2006 22:15
by vegtabill
Second follow-up: (the entire thread is at

OK, I got to the bottom of the problem. It was, in fact, Oracle that was creating difficulties.

On the machines at the school they have Oracle 10 ("b" I think) installed for the database courses. Within this installation is Perl 5.6.1. When the installation took place, Oracle added a number of entries to the Windows PATH, including Perl. From what I can tell, Apache was reading this PATH when it tried to load the Perl modules and, of course, could not find what it was looking for, which caused it to abort.

In our case, this will not be an issue. Starting this semester Oracle will no longer be installed on the lab/classroom machines. Instead, they are going to run one Oracle server and install a thin client on the workstations that will connect to the server. The thin client willl not have Perl installed, so the PATH will not be an issue.

To be certain that Oracle was the culprit, I uninstalled it on the machine I was working on and then tried to start XAMPP. It started normally and loaded the Perl modules just as it should. When I clicked on the link it displayed all of the available drivers, just like it does on my machine.

So it appears that I have the situation corrected as far as our problem is concerned. I did not attempt to make XAMPP and Oracle co-exist because I know that, on these machines, they won't have to. Nevertheless, I'm sure someone out there at some point will have to address this. If I come up with anything useful I will certainly pass it along here.