MediaWiki and Mercury Mail on XAMPP...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MediaWiki and Mercury Mail on XAMPP...

Postby hotmonkeyac » 21. June 2006 18:17

I was just wondering, has ANYONE sucessfully gotten the E-Mail feature of MediaWiki working while running XAMPP? I can't even seem to get the SMTP of Mercury to run correctly. I am running Windows XP and am on a Domain. Can anyone help?
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby taustin » 21. June 2006 23:52

What exact problems are you having with Mercury?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby WorldDrknss » 22. June 2006 08:32

You will need to configure php.ini to use fake sendmail.
Open xampp/apache/bin/php.ini
Find sendmail

and change it so that it looks something similar to bellow - make sure to change to the correct path.:

Code: Select all
; For Win32 only.
;sendmail_from = me@example.com

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = "/xampp/xampp/sendmail/sendmail.exe -t"


then open xampp/sendmail/sendmail.ini and edit the following:
Code: Select all
;smtp_server=localhost

to
Code: Select all
smtp_server=localhost

and
Code: Select all
;auth_username=
;auth_password=

to
Code: Select all
auth_username=MercuryMail UserName
auth_password=MercuryMail Password


then save and restart apache.
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby hotmonkeyac » 22. June 2006 15:20

Thanks WorldDrknss, I'm almost there! This is the farthest I've ever gotten to getting this thing to work! Now when the Wiki sends mail I get a nice message saying

A new password has been sent to the e-mail address registered for "Username". Please log in again after you receive it.


The problem now is that I never get an email. Also, when I pull up Mercury, I don't see any activity showing that it processed anything. Could I have done something wrong? Thanks for the help!!
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby hotmonkeyac » 23. June 2006 15:20

maybe if i changed

Code: Select all
:
;smtp_server=localhost


to the IP address of the exchange server running on the domain? would that help?

EDIT: I tried that and it did NOT work.... bummer
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby hotmonkeyac » 26. June 2006 15:31

can anyone help with this? WorldDrknss, any ideas?
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby hotmonkeyac » 03. July 2006 16:23

i'm bumping this one 1 more time! i'm so close to getting this to work. has anyone gotten this to work on windows???
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby WorldDrknss » 04. July 2006 09:09

MercuryMail Tutorial:
In this tutorial we will show you how to configure mercurymail so that you can receive and send emails from your website.
Lets begin:
Open up MercuryMail and click on configuration and then go to Protocal Modules here we will only check the protocals that we need. The following should only be check:
-MercuryS SMTP Server
-MercuryP POP3 Server
-MercuryC SMTP relaying client
-MercuryD distributing POP3 client
-MecuryI IMAP4rev1 Server
Restart MercuryMail
Once back in mercurymail click on configuration and then go to MercuryC SMTP client and fill in the following information.
Smart host name: smtp.somedomain.com <-your isp smtp server should go here, if you do not know it you can use the services from bluebottle.com
Username: isp username or other mail service username
Password: isp password or other mail service password
then click on save once you have those fields conpleted.
Click on configuration and go to Mercury core module and click on the Local domains tab, then click on add new domain, then add your domain to both the boxes and click on. Next we will add which users will have an email account on your server and to do this click on configuration then go to Manage local users here you can edit, delete, or add users.

Provided to you by: http://xampptutorials.com

Fake Sendmail Configuration:
; configuration for fake sendmail

[sendmail]

; you must change mail.mydomain.com to your smtp server

smtp_server=localhost

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=local

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

;error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

;debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

auth_username=yourusername
auth_password=yourpassword
; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines

;pop3_server=
;pop3_username=
;pop3_password=

; to force the sender to always be the following email address, uncomment and
; populate with a valid email address. this will only affect the "MAIL FROM"
; command, it won't modify the "From: " header of the message content

;force_sender=me@localhost

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting. you can manually set the ehlo/helo name if required

;hostname=localhost
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby hotmonkeyac » 06. July 2006 17:26

no dice. maybe it's because i'm on a domain and don't have direct access to the exchange server. thanks for the help anyways!
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby Izzy » 07. July 2006 05:15

hotmonkeyac wrote:maybe if i changed

Code: Select all
:
;smtp_server=localhost


to the IP address of the exchange server running on the domain? would that help?

EDIT: I tried that and it did NOT work.... bummer
You did remove the ; from in front of the line, didn't you?

Should look like this:
smtp_server=localhost
not
;smtp_server=localhost

Any line starting with a ; is not read by the script.
It is used for comment lines or in the above case to deactivate (comment out) a configuration line.

HTH :)
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hotmonkeyac » 07. July 2006 15:07

yeah, i removed the ; in front of that. is there anything special I have to do on the exchange server? or do i just need to point it to the IP address and let it do it's magic?
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby hotmonkeyac » 07. July 2006 19:08

got it working! thanks for the help!!!
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby Izzy » 08. July 2006 02:01

hotmonkeyac wrote:got it working! thanks for the help!!!
Mind sharing with the rest of us what you did to get it working?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hotmonkeyac » 08. July 2006 06:22

Here's what I did ....I had to use PEAR mail....

Add the following to localsettings.php:

Code: Select all
$wgSMTP = array(
'host'     => "localhost",
'IDHost'   => "my domain",
'port'     => "25",
'auth'     => false,
'username' => "my_user_name",
'password' => "my_password"
);


AND
Code: Select all
$path = array( $IP, "$IP/includes", "$IP/languages", "C:\pear"); - actually, just add "C:\pear" (or where the PEAR mail path is)


Configured windows to relay mail to the exchange server:

IIS --> Default SMTP Virtual Server --> Properties

Changed the following:

Access --> Authentication --> Anonymous Access

Access --> Relay --> All except the list below
hotmonkeyac
 
Posts: 12
Joined: 21. June 2006 18:04

Postby Izzy » 08. July 2006 06:35

Thanks for that. Good job. Glad to see it working for you now :).
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 65 guests