phpmyadmin error - cannot load mysql extension!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin error - cannot load mysql extension!

Postby chilledandy » 20. June 2006 17:19

Hi
I am new to xampp and the applications included. I recently installed the xampp package on my win xp pro sp2 computer and after messing around with the ports, changing skype settings, deleting iis I was able to get it all up and running, including apache which was a major headache.
However, when i type in http://localhost/phpmyadmin I get the following error message:
cannot load mysql extension. Please check your PHP configuration. - Documentation. When I click on the documentation link, it takes me to the phpmyadmin documentation section regarding this error and states the following:
"[1.20] I receive the error "cannot load MySQL extension, please check PHP Configuration".
To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar. "


However, I have checked the ext libraries and the php_mysql.dll and php_mysqli.dll are both present in the ext folder under the PHP folder.

Also, in the PHP config file, the extensions_dir is set to the correct location:
extension_dir = "C:\Program Files\xampp\php\ext\"
as xampp was installed under C:\Program Files\xampp.

Also, the extension php_mysql.dll is enabled in the config file.

I have not modified any config settings in the phpmyadmin folder so perhaps it could be something to do with that!
I have no idea where to go from here. Please help??

Many thanks in advance
Andy


EDIT
It seems the problem was that I had a previously installed PHP folder under the C:\ at C:\PHP and I also still had the path set to C:\PHP in the environment variables.
I ran phpinfo.php and figured this out as it stated that the php.ini file was located at C:\PHP. So i went into that and deleted it all, and replaced it with the code from the xampp\php\php5.ini file. This solved the original problem of not finding the library.
However, since then I have updated the path files to reflect the newly installed version of PHP that came with xampp, and restarted my computer but when i run phpinfo.php it still shows the php.ini file as being located at c:\PHP and also still displays the old extensions_dir despite the c:\PHP\php.in file being modified to reflect the new location of the ext folder.
it displays it as c:\php\ext despite the c:\PHP\php.ini file having the address as C:\Program Files\xampp\php\ext
What is going on?
I would like to be able to delete the old PHP folder and just use the one that came with xampp but it seems that if i do this, then php won't work not to mention phpmyadmin etc.. Everything else seems correct as before I was running it with IIS and now i'm using apache and this change is reflected in the phpinfo.php.
Any ideas anyone??

Thanks in advance
Andy
chilledandy
 
Posts: 1
Joined: 20. June 2006 17:02

Return to XAMPP for Windows

Who is online

Users browsing this forum: DrSeussFreak and 63 guests