Having Trouble With My Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Having Trouble With My Apache

Postby mjhasbach » 16. June 2006 22:24

Hello, I have used Xampp in the past, but I reciently had to uninstall it and now i need it again. I am having trouble getting the Apache to work. In the Xammp control panel, whenever i click the "Start" button for Apache, it turns on and then quickly turns off.

I have run apache_start.bat from the Xampp folder, and this is the error that I get:

"(OS 10048) Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started"

Any help would be greatly appreciated.
mjhasbach
 
Posts: 10
Joined: 05. February 2006 23:28

Postby Wiedmann » 16. June 2006 22:44

There is an other server listening on port 80. Stop this server and XAMPP/Apache will work.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mjhasbach » 17. June 2006 02:42

Well, I can't figure out what else is listening on port 80. Is there an easy way to find out? Or a way to change the port that the Apache listens on?
mjhasbach
 
Posts: 10
Joined: 05. February 2006 23:28

Postby Wiedmann » 17. June 2006 11:08

I can't figure out what else is listening on port 80. Is there an easy way to find out?

For example: netstat, tcpview, xampp-portcheck, ...

Or a way to change the port that the Apache listens on?

Directive "Listen" in "httpd.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mjhasbach » 17. June 2006 22:11

Umm...I ran netstat as well as tcpview and xampp-portcheck.

I found out that there is a program "C:\WINDOWS\system32\inetsvr\inetinfo.exe" that is listening on port 80 (Apache (HTTP)), port 443 (Apache (HTTPS)), port 25 (Mercury (SMTP)).

This file is obviously keeping my Xampp from running properly. I am wondering if it is safe to kill the process, because it is running in the WINDOWS folder?
mjhasbach
 
Posts: 10
Joined: 05. February 2006 23:28

Postby deepsurfer » 17. June 2006 23:07

I found out that there is a program "C:\WINDOWS\system32\inetsvr\inetinfo.exe"

This programm listen on Port 80

This programm is the MS-Webserver called "IIS"
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mjhasbach » 18. June 2006 00:35

Well, I still can't start my Apache.

I deleted that file inetinfo.exe from my computer. When I run xampp-portcheck it says that all of the Apache ports are free. Yet when i run my Apache from the Control Panel, it starts and then stops. When I run apache_start.bat it says that the Apache cannot be started. Does anyone have any sugestions on how to fix this problem?
mjhasbach
 
Posts: 10
Joined: 05. February 2006 23:28

Postby josefec » 28. August 2006 09:14

I have this problem too. Could anybody help what to do? The process can't be killed.. It starts again after killing. I don't know if it would be good if I deleted the file at all and now I read here that even deleting the file doesn't help.
Thanks very much...
josefec
 
Posts: 2
Joined: 28. August 2006 09:09

Postby Izzy » 28. August 2006 10:08

josefec wrote:I have this problem too. Could anybody help what to do? The process can't be killed.. It starts again after killing. I don't know if it would be good if I deleted the file at all and now I read here that even deleting the file doesn't help.
Thanks very much...

What OS are you using?

If XP try in Windows Control Panel/Add or Remove Programs/ click on Add/Remove Windows Components - look for IIS server to remove it.

Not sure if it will help as I don't have IIS installed on my XP Pro to be able to test it for you.

You can also try and remove the IIS Service from your Windows Control Panel/Administrative Tools/Services look for the IIS Service and change from Automatic to Manual or Disabled.

Good Luck.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby josefec » 28. August 2006 13:58

Yes, I'm using WinXP. Neither I have installed anything like IIS Server. I haven't find anything in Add Remove Programs... I've found something like IIS Service Administration service (I run localized version of WinXP) but there are many services depending on this one... Publishing On Web, Simple Mail Transport Protocol (SMTP) and FTP Publishing...
Couldn't it harm functioning of my email client if I stopped all these depending services?
josefec
 
Posts: 2
Joined: 28. August 2006 09:09

Postby Izzy » 28. August 2006 17:08

These are servers of which XAMPP will take over once installed.

As I said in my previous post I do not have IIS I use XAMPP instead.

If you stop all those services and their dependancies and install XAMPP you will have SMTP with Mercury Mail, FTP with FileZilla, Web Publishing with Apache.

Unless you use IIS at the moment you will see no difference only that you will be able to start and run XAMPP on the default port 80, which is what you wanted to do when you first posted here.

If you have problems, you can always uninstall XAMPP and restart the IIS services and their dependancies.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

similar problem with apache starting/ stopping

Postby gleka » 20. September 2006 23:56

Wiedmann wrote:
I can't figure out what else is listening on port 80. Is there an easy way to find out?

For example: netstat, tcpview, xampp-portcheck, ...

Or a way to change the port that the Apache listens on?

Directive "Listen" in "httpd.conf".


I have a similar problem with apache starting and then stopping within a second or two. My isp (AOL) uses port 443 - actually the aoltpsp.exe file. I do not want to disconnect my isp, so how do i manage to get apache running and also continue to be able to use aol as my isp?
gleka
 
Posts: 3
Joined: 20. September 2006 23:33
Location: England

Postby Wiedmann » 21. September 2006 00:19

My isp (AOL) uses port 443 - actually the aoltpsp.exe file.

You mean "aoltpspd.exe"?

This is the AOL TopSpeed feature. You don't need this program to surf via AOL.

Look in the AOL manuals (or support) how to disable this feature.

(And of course:
Ask your provider, why he use a well known standard port for his proprietary software...)

You can also diasable SSL in Apache. In "httpd.conf":
Code: Select all
#LoadModule ssl_module modules/mod_ssl.so
#Include conf/extra/httpd-ssl.conf

(Add the "#" in these 2 lines)

--> 443 is the port a webserver listen for SSL connections ("https://...")
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby gleka » 21. September 2006 00:41

Wiedmann wrote:
My isp (AOL) uses port 443 - actually the aoltpsp.exe file.

You mean "aoltpspd.exe"?

This is the AOL TopSpeed feature. You don't need this program to surf via AOL.

Look in the AOL manuals (or support) how to disable this feature.

(And of course:
Ask your provider, why he use a well known standard port for his proprietary software...)

You can also diasable SSL in Apache. In "httpd.conf":
Code: Select all
#LoadModule ssl_module modules/mod_ssl.so
#Include conf/extra/httpd-ssl.conf

(Add the "#" in these 2 lines)

--> 443 is the port a webserver listen for SSL connections ("https://...")

Wow - spot on! I merely disabled topspeed in aol and apache is fine, and so is the remainder of xampp!. Cant say a big enough thankyou - I am a COMPLETE novice!.
:D
gleka
 
Posts: 3
Joined: 20. September 2006 23:33
Location: England

Who in their right mind uses AOL anyway ..

Postby nimd4 » 28. September 2006 00:04

AOL Rules ! :roll:
User avatar
nimd4
 
Posts: 18
Joined: 20. September 2006 20:43


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests